summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.4.2.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.4.2.bb b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.4.2.bb
new file mode 100644
index 00000000..c8482286
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.4.2.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native upower libevdev"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
12
13SRC_URI = "git://github.com/intel/thermal_daemon/ \
14 "
15
16SRCREV = "86d6634b7e648ad5a3304e8dcf4eee613fa07fac"
17S = "${WORKDIR}/git"
18
19inherit pkgconfig autotools systemd gtk-doc
20
21# gtkdocsize runs before autotools do_configure and it copies gtk-doc.m4 and fails
22# to copy becuase there is no m4 dir yet.
23do_configure_prepend () {
24 mkdir -p ${S}/m4
25}
26
27EXTRA_OECONF = " \
28 --with-systemdsystemunitdir=${systemd_system_unitdir} \
29 "
30
31FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
32
33SYSTEMD_SERVICE_${PN} = "thermald.service"
34
35COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
36
37CONFFILES_${PN} = " \
38 ${sysconfdir}/thermald/thermal-conf.xml \
39 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
40 "
41
42UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"