summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/embree/embree_3.13.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/embree/embree_3.13.0.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/embree/embree_3.13.0.bb
new file mode 100644
index 00000000..93fdcd18
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/embree/embree_3.13.0.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Collection of high-performance ray tracing kernels"
2DESCRIPTION = "A collection of high-performance ray tracing kernels \
3intended to graphics application engineers that want to improve the \
4performance of their application."
5HOMEPAGE = "https://github.com/embree/embree"
6
7LICENSE = "Apache-2.0 & syrah"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \
9 file://third-party-programs.txt;md5=86f6028ba2138fe41ac5c121d0a3518e \
10 file://common/math/transcendental.h;beginline=6;endline=8;md5=73380bb2ab6613b30b8464f114bd0ca8"
11
12inherit pkgconfig cmake
13
14S = "${WORKDIR}/git"
15
16SRC_URI = "git://github.com/embree/embree.git;protocol=https \
17 "
18SRCREV = "7c53133eb21424f7f0ae1e25bf357e358feaf6ab"
19
20COMPATIBLE_HOST = '(x86_64).*-linux'
21
22DEPENDS = "tbb jpeg libpng glfw"
23
24EMBREE-MAX-ISA = "SSE4.2"
25EMBREE-MAX-ISA_intel-corei7-64 = "SSE4.2"
26EMBREE-MAX-ISA_intel-skylake-64 = "AVX2"
27
28EXTRA_OECMAKE += " \
29 -DEMBREE_ISPC_SUPPORT=OFF \
30 -DEMBREE_IGNORE_CMAKE_CXX_FLAGS=OFF \
31 -DEMBREE_MAX_ISA=${EMBREE-MAX-ISA} \
32 -DEMBREE_TUTORIALS=OFF \
33 "