summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2020.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2020.3.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2020.3.0.bb148
1 files changed, 148 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2020.3.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2020.3.0.bb
new file mode 100644
index 00000000..41964728
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2020.3.0.bb
@@ -0,0 +1,148 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Deep Learning Deployment Toolkit"
2HOMEPAGE = "https://github.com/opencv/dldt"
3DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic."
6
7SRC_URI = "gitsm://github.com/openvinotoolkit/openvino.git;protocol=git;branch=releases/2020/3 \
8 https://download.01.org/opencv/2020/openvinotoolkit/2020.3/inference_engine/firmware_usb-ma2450_1119.zip;name=ma2450 \
9 https://download.01.org/opencv/2020/openvinotoolkit/2020.3/inference_engine/firmware_pcie-ma248x_1119.zip;name=ma248x \
10 https://download.01.org/opencv/2020/openvinotoolkit/2020.3/inference_engine/firmware_usb-ma2x8x_1119.zip;name=ma2x8x \
11 file://0001-inference-engine-use-system-installed-packages.patch \
12 file://0002-cldNN-disable-Werror.patch \
13 file://0003-inference-engine-installation-fixes.patch \
14 file://0004-fix-compilation-errors.patch \
15 file://0005-cldnn-fix-inclusion-of-headers.patch \
16 file://0001-mkldnn_memory_solver.hpp-include-stdint.h-to-avoid-b.patch \
17 file://0001-dont-install-licenses-and-version-file.patch;patchdir=ngraph \
18 file://run-ptest \
19 "
20
21SRCREV = "2fe9b1523058e282ad374db7dc1b3538c7d2dd27"
22
23SRC_URI[ma2450.sha256sum] = "9b8f61954751343995dde9d714134e5082dbaadffb0c7c33d41ce84c1296a20e"
24SRC_URI[ma248x.sha256sum] = "338940db127b16231e0afa948c83ed576458b130dd2a0a593c5edb29d9637f35"
25SRC_URI[ma2x8x.sha256sum] = "94cd485105de47ef3f747baec1261a1254ddf30e308807948dd8b0176ecdfebf"
26
27LICENSE = "Apache-2.0 & ISSL & MIT"
28LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
29 file://inference-engine/thirdparty/mkl-dnn/LICENSE;md5=afa44a3d001cc203032135324f9636b7 \
30 file://inference-engine/thirdparty/mkl-dnn/src/cpu/xbyak/COPYRIGHT;md5=3b9bf048d063d54cdb28964db558bcc7 \
31 file://inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/LICENSE.txt;md5=88b295a48d2b3244ba65d3c055472c8a \
32 file://inference-engine/tests/ie_test_utils/common_test_utils/gtest/googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
33 file://inference-engine/tests/ie_test_utils/common_test_utils/gtest/googletest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
34"
35LICENSE_${PN}-vpu-firmware = "ISSL"
36
37inherit cmake ptest python3native
38
39S = "${WORKDIR}/git"
40
41EXTRA_OECMAKE += " \
42 -DENABLE_OPENCV=0 \
43 -DENABLE_PLUGIN_RPATH=0 \
44 -DENABLE_GNA=0 \
45 -DPYTHON_EXECUTABLE=${PYTHON} \
46 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
47 -DTHREADING=TBB -DTBB_DIR=${STAGING_LIBDIR} \
48 -DENABLE_TESTS="${@bb.utils.contains('PTEST_ENABLED', '1', '1', '0', d)}" \
49 -DBUILD_GMOCK=1 \
50 -DBUILD_GTEST=0 \
51 -DINSTALL_GMOCK=0 \
52 -DINSTALL_GTEST=0 \
53 -DENABLE_SAMPLES=1 \
54 -DENABLE_NGRAPH=ON \
55 -DENABLE_MKL_DNN=ON \
56 -DIE_CPACK_IE_DIR=${prefix} \
57 -DNGRAPH_UNIT_TEST_ENABLE=FALSE \
58 -DNGRAPH_TEST_UTIL_ENABLE=FALSE \
59 -DNGRAPH_ONNX_IMPORT_ENABLE=OFF \
60 -DNGRAPH_JSON_ENABLE=FALSE \
61 -DNGRAPH_NATIVE_ARCH_ENABLE=FALSE \
62 -DNGRAPH_NOP_ENABLE=FALSE \
63 -DNGRAPH_GENERIC_CPU_ENABLE=FALSE \
64 -DTREAT_WARNING_AS_ERROR=FALSE \
65 "
66
67DEPENDS += "libusb1 \
68 ade \
69 opencv \
70 pugixml \
71 protobuf-native \
72 tbb \
73 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gflags', '', d)} \
74 "
75
76COMPATIBLE_HOST = '(x86_64).*-linux'
77COMPATIBLE_HOST_libc-musl = "null"
78
79PACKAGECONFIG ?= "vpu"
80PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1 -DCLDNN__IOCL_ICD_INCDIRS=${STAGING_INCDIR} -DCLDNN__IOCL_ICD_STLDIRS=${STAGING_LIBDIR} -DCLDNN__IOCL_ICD_SHLDIRS=${STAGING_LIBDIR}, -DENABLE_CLDNN=0, ocl-icd opencl-headers libva, intel-compute-runtime"
81PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native, python3 python3-numpy python3-opencv python3-progress python3-cython"
82PACKAGECONFIG[vpu] = "-DENABLE_VPU=ON -DVPU_FIRMWARE_USB-MA2450_FILE=../mvnc/usb-ma2450.mvcmd -DVPU_FIRMWARE_USB-MA2X8X_FILE=../mvnc/usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA248X_FILE=../mvnc/pcie-ma248x.mvcmd,-DENABLE_VPU=OFF,,${PN}-vpu-firmware"
83PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0"
84
85do_install_append() {
86 if ${@bb.utils.contains('PACKAGECONFIG', 'vpu', 'true', 'false', d)}; then
87 install -m0644 ${WORKDIR}/mvnc/usb-ma2450.mvcmd ${D}${libdir}/
88 install -m0644 ${WORKDIR}/mvnc/usb-ma2x8x.mvcmd ${D}${libdir}/
89 install -m0644 ${WORKDIR}/mvnc/pcie-ma248x.mvcmd ${D}${libdir}/
90 fi
91
92 if ${@bb.utils.contains('PACKAGECONFIG', 'opencl', 'true', 'false', d)}; then
93 cp -r ${S}/inference-engine/src/cldnn_engine/cldnn_global_custom_kernels ${D}${libdir}/
94 fi
95
96 if ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'true', 'false', d)}; then
97 install -d ${D}${datadir}/inference_engine
98 mv ${D}/usr/samples/python ${D}${datadir}/inference_engine/
99
100 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
101 mv ${D}${prefix}/python/${PYTHON_DIR}/openvino ${D}${PYTHON_SITEPACKAGES_DIR}/
102 mv ${D}${prefix}/deployment_tools/tools/benchmark_tool ${D}${PYTHON_SITEPACKAGES_DIR}/openvino/
103
104 rm -rf ${D}${prefix}/python
105 rm -rf ${D}${prefix}/deployment_tools
106 fi
107
108 # Remove the samples source directory. We install the built samples.
109 rm -rf ${D}/usr/samples
110}
111
112do_install_ptest_base_prepend() {
113 # While not a Makefile based project that strictly falls into the category of
114 # what ptest helps with, adding the unit tests here as ptest would help.
115 # Create a dummy Makefile so installation doesn't fail.
116 touch ${WORKDIR}/Makefile
117
118 mv ${D}${bindir}/*UnitTests ${D}${PTEST_PATH}/
119}
120
121# Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR
122# instead of RSS
123SSTATE_SCAN_FILES_append = " *.cmake"
124
125FILES_${PN}-dev = "${includedir} \
126 ${libdir}/cmake \
127 "
128
129FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \
130 ${datadir}/openvino \
131 ${libdir}/cldnn_global_custom_kernels \
132 ${libdir}/custom_kernels \
133 ${libdir}/plugins.xml \
134 ${libdir}/cache.json \
135 "
136
137# Move inference engine samples into a separate package
138PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware"
139
140FILES_${PN}-samples = "${datadir}/inference_engine \
141 ${bindir} \
142 "
143FILES_${PN}-vpu-firmware += "${libdir}/*.mvcmd"
144
145# Package for inference engine python API
146PACKAGES =+ "${PN}-${PYTHON_PN}"
147
148FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}/openvino"