summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.1.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.1.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.1.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.1.bb
new file mode 100644
index 00000000..82ca4af8
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.1.bb
@@ -0,0 +1,62 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Open Model Zoo repository"
2HOMEPAGE = "https://github.com/opencv/open_model_zoo"
3DESCRIPTION = "This repository includes optimized deep learning \
4models and a set of demos to expedite development of high-performance \
5deep learning inference applications."
6
7SRC_URI = "git://github.com/opencv/open_model_zoo.git;protocol=git;branch=master \
8 "
9
10SRCREV = "75ec8ad4b6c4fd7fb161ae9d2c3056281b2443de"
11
12LICENSE = "Apache-2.0"
13LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
14"
15
16inherit cmake
17
18S = "${WORKDIR}/git/demos"
19
20DEPENDS += "openvino-inference-engine opencv gflags"
21
22RDEPENDS_${PN} += " \
23 python3-decorator \
24 python3-defusedxml \
25 python3-networkx \
26 python3-protobuf \
27 python3-test-generator \
28 python3-requests \
29 python3-pyyaml \
30"
31
32COMPATIBLE_HOST = '(x86_64).*-linux'
33
34EXTRA_OECMAKE += " \
35 -DIE_MAIN_SOURCE_DIR=${B} \
36 -DENABLE_SAMPLES=ON \
37 -DIE_INCLUDE_DIR=${STAGING_EXECPREFIXDIR} \
38 -DIE_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine.so \
39 -DIE_C_API_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_c_api.so \
40 -DIE_LEGACY_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_legacy.so \
41 -DIE_NN_BUILDER_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_nn_builder.so \
42 -DIE_ROOT_DIR=${WORKDIR}/InferenceEngine \
43"
44
45do_configure_prepend(){
46 mkdir -p ${WORKDIR}/InferenceEngine/share
47 cp ${STAGING_LIBDIR}/cmake/InferenceEngine/* ${WORKDIR}/InferenceEngine/share/
48}
49
50do_install(){
51 install -d ${D}${libdir}
52 install -d ${D}${bindir}
53 install -d ${D}${datadir}/openvino/open-model-zoo/tools
54 install -d ${D}${datadir}/openvino/open-model-zoo/demos/python_demos
55 cp -rf ${WORKDIR}/build/intel64/Release/lib/*.a ${D}${libdir}
56 cp -rf ${WORKDIR}/build/intel64/Release/*_demo* ${D}${bindir}
57 cp -rf ${WORKDIR}/git/models ${D}${datadir}/openvino/open-model-zoo
58 cp -rf ${WORKDIR}/git/tools/downloader ${D}${datadir}/openvino/open-model-zoo/tools
59 cp -rf ${WORKDIR}/git/demos/python_demos ${D}${datadir}/openvino/open-model-zoo/demos
60}
61
62FILES_${PN} += "${datadir}/openvino"