summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch115
1 files changed, 115 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
new file mode 100644
index 00000000..8fc7e32e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
@@ -0,0 +1,115 @@
1From 6fef79d47c2b92b3e194c412849d44ef632f9905 Mon Sep 17 00:00:00 2001
2From: Liwei Song <liwei.song@windriver.com>
3Date: Fri, 22 May 2020 15:47:44 +0800
4Subject: [PATCH] use meta-oe gflags
5
6gflags is available in meta-oe, use this one instead of the thirdparty
7one in open-model-zoo
8
9Upstream-Status: Inappropriate [meta-intel specific]
10
11Signed-off-by: Liwei Song <liwei.song@windriver.com>
12---
13 CMakeLists.txt | 8 ++++----
14 multi_channel/common/CMakeLists.txt | 2 +-
15 multi_channel/face_detection_demo/CMakeLists.txt | 2 +-
16 human_pose_estimation_demo/CMakeLists.txt | 2 +-
17 object_detection_demo_yolov3/CMakeLists.txt | 2 +-
18 5 files changed, 8 insertions(+), 8 deletions(-)
19
20diff --git a/CMakeLists.txt b/CMakeLists.txt
21index b22b2734656f..ed89411f1dfa 100644
22--- a/CMakeLists.txt
23+++ b/CMakeLists.txt
24@@ -89,12 +89,10 @@ if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
25 endif()
26 ####################################
27
28-set (GFLAGS_IS_SUBPROJECT TRUE)
29+set (GFLAGS_IS_SUBPROJECT FALSE)
30 set (HAVE_SYS_STAT_H 1)
31 set (HAVE_INTTYPES_H 1)
32
33-add_subdirectory(thirdparty/gflags)
34-
35 if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
36 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
37 endif()
38@@ -185,7 +183,7 @@ macro(ie_add_sample)
39 endif()
40
41 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${OpenCV_LIBRARIES} ${InferenceEngine_LIBRARIES}
42- ${IE_SAMPLE_DEPENDENCIES} gflags)
43+ ${IE_SAMPLE_DEPENDENCIES} ${GFLAGS_LIBRARIES})
44
45 if(UNIX)
46 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE pthread)
47@@ -206,11 +204,13 @@ endmacro()
48 # use this flag if you need to throw custom message in case if the IE package is not found.
49 if (IE_NOT_FOUND_MESSAGE)
50 find_package(InferenceEngine 2.0 QUIET)
51+ find_package(gflags 2.2 QUIET)
52 if (NOT(InferenceEngine_FOUND))
53 message(FATAL_ERROR ${IE_NOT_FOUND_MESSAGE})
54 endif()
55 else()
56 find_package(InferenceEngine 2.0 REQUIRED)
57+ find_package(gflags 2.2 REQUIRED)
58 endif()
59
60 # collect all samples subdirectories
61diff --git a/multi_channel/common/CMakeLists.txt b/multi_channel/common/CMakeLists.txt
62index 740f3e1ec46e..573d12606d33 100644
63--- a/multi_channel/common/CMakeLists.txt
64+++ b/multi_channel/common/CMakeLists.txt
65@@ -113,7 +113,7 @@ target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
66 if(TARGET IE::ie_cpu_extension)
67 add_definitions(-DWITH_EXTENSIONS)
68 endif()
69-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES})
70+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES})
71 if(TARGET IE::ie_cpu_extension)
72 target_link_libraries(${TARGET_NAME} IE::ie_cpu_extension)
73 endif()
74diff --git a/multi_channel/face_detection_demo/CMakeLists.txt b/multi_channel/face_detection_demo/CMakeLists.txt
75index 41730f1d73d4..3b2eb100ccf8 100644
76--- a/multi_channel/face_detection_demo/CMakeLists.txt
77+++ b/multi_channel/face_detection_demo/CMakeLists.txt
78@@ -64,7 +64,7 @@ if(TARGET IE::ie_cpu_extension)
79 add_definitions(-DWITH_EXTENSIONS)
80 endif()
81
82-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} common)
83+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} common)
84
85 if(TARGET IE::ie_cpu_extension)
86 target_link_libraries(${TARGET_NAME} IE::ie_cpu_extension)
87diff --git a/multi_channel/human_pose_estimation_demo/CMakeLists.txt b/multi_channel/human_pose_estimation_demo/CMakeLists.txt
88index f4c05cf5b0e8..2602f59c314f 100644
89--- a/multi_channel/human_pose_estimation_demo/CMakeLists.txt
90+++ b/multi_channel/human_pose_estimation_demo/CMakeLists.txt
91@@ -63,7 +63,7 @@ endif()
92 if(TARGET IE::ie_cpu_extension)
93 add_definitions(-DWITH_EXTENSIONS)
94 endif()
95-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} common)
96+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} common)
97 if(TARGET IE::ie_cpu_extension)
98 target_link_libraries(${TARGET_NAME} IE::ie_cpu_extension)
99 endif()
100diff --git a/multi_channel/object_detection_demo_yolov3/CMakeLists.txt b/multi_channel/object_detection_demo_yolov3/CMakeLists.txt
101index 2f2b3bc540f8..ac10776e2b4e 100644
102--- a/multi_channel/object_detection_demo_yolov3/CMakeLists.txt
103+++ b/multi_channel/object_detection_demo_yolov3/CMakeLists.txt
104@@ -64,7 +64,7 @@ if(TARGET IE::ie_cpu_extension)
105 add_definitions(-DWITH_EXTENSIONS)
106 endif()
107
108-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} common)
109+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} common)
110
111 if(TARGET IE::ie_cpu_extension)
112 target_link_libraries(${TARGET_NAME} IE::ie_cpu_extension)
113--
1142.17.1
115