summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch126
1 files changed, 19 insertions, 107 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
index a938b942..816a98a3 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
@@ -1,115 +1,27 @@
1From d63d1a1291a2715b7d70ed88c4d764b22e6f2f4d Mon Sep 17 00:00:00 2001 1From 804b08023b3f8e72b8e3eb09e464d6775c11d966 Mon Sep 17 00:00:00 2001
2From: Liwei Song <liwei.song@windriver.com> 2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Fri, 22 May 2020 15:47:44 +0800 3Date: Fri, 21 Oct 2022 11:38:23 +0800
4Subject: [PATCH] use meta-oe gflags 4Subject: [PATCH] demos: use gflags from meta-oe
5 5
6gflags is available in meta-oe, use this one instead of the thirdparty 6Upstream-Status: Inappropriate
7one in open-model-zoo
8 7
9Upstream-Status: Inappropriate [meta-intel specific] 8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
10 10
11Signed-off-by: Liwei Song <liwei.song@windriver.com>
12--- 11---
13 CMakeLists.txt | 8 ++++---- 12 demos/CMakeLists.txt | 2 +-
14 multi_channel/common/CMakeLists.txt | 2 +- 13 1 file changed, 1 insertion(+), 1 deletion(-)
15 multi_channel/face_detection_demo/CMakeLists.txt | 2 +-
16 multi_channel/human_pose_estimation_demo/CMakeLists.txt | 2 +-
17 multi_channel/object_detection_demo_yolov3/CMakeLists.txt | 2 +-
18 5 files changed, 8 insertions(+), 8 deletions(-)
19 14
20diff --git a/CMakeLists.txt b/CMakeLists.txt 15diff --git a/demos/CMakeLists.txt b/demos/CMakeLists.txt
21index 40b549f..dfdbf93 100644 16index 51767051c..fb7e3d22f 100644
22--- a/CMakeLists.txt 17--- a/demos/CMakeLists.txt
23+++ b/CMakeLists.txt 18+++ b/demos/CMakeLists.txt
24@@ -89,12 +89,10 @@ if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU) 19@@ -141,7 +141,7 @@ endmacro()
25 endif() 20 find_package(OpenCV REQUIRED COMPONENTS core highgui videoio imgproc imgcodecs)
26 #################################### 21 find_package(OpenVINO REQUIRED COMPONENTS Runtime)
27
28-set (GFLAGS_IS_SUBPROJECT TRUE)
29+set (GFLAGS_IS_SUBPROJECT FALSE)
30 set (HAVE_SYS_STAT_H 1)
31 set (HAVE_INTTYPES_H 1)
32 22
33-add_subdirectory(thirdparty/gflags) 23-add_subdirectory(thirdparty/gflags)
34- 24+#add_subdirectory(thirdparty/gflags)
35 if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU) 25 add_subdirectory(common/cpp)
36 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
37 endif()
38@@ -177,7 +175,7 @@ macro(ie_add_sample)
39 target_include_directories(${IE_SAMPLE_NAME} PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/../common")
40
41 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${OpenCV_LIBRARIES} ${InferenceEngine_LIBRARIES}
42- ${IE_SAMPLE_DEPENDENCIES} gflags)
43+ ${IE_SAMPLE_DEPENDENCIES} ${GFLAGS_LIBRARIES})
44
45 if(UNIX)
46 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE pthread)
47@@ -198,11 +196,13 @@ endmacro()
48 # use this flag if you need to throw custom message in case if the IE package is not found.
49 if (IE_NOT_FOUND_MESSAGE)
50 find_package(InferenceEngine 2.0 QUIET)
51+ find_package(gflags 2.2 QUIET)
52 if (NOT(InferenceEngine_FOUND))
53 message(FATAL_ERROR ${IE_NOT_FOUND_MESSAGE})
54 endif()
55 else()
56 find_package(InferenceEngine 2.0 REQUIRED)
57+ find_package(gflags 2.2 REQUIRED)
58 endif()
59
60 find_package(ngraph REQUIRED)
61diff --git a/multi_channel/common/CMakeLists.txt b/multi_channel/common/CMakeLists.txt
62index d5e5d93..c33afbb 100644
63--- a/multi_channel/common/CMakeLists.txt
64+++ b/multi_channel/common/CMakeLists.txt
65@@ -110,7 +110,7 @@ endif()
66
67 target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
68
69-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES})
70+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES})
71
72 if(UNIX)
73 target_link_libraries( ${TARGET_NAME} pthread)
74diff --git a/multi_channel/face_detection_demo/CMakeLists.txt b/multi_channel/face_detection_demo/CMakeLists.txt
75index 5b497fc..78c518e 100644
76--- a/multi_channel/face_detection_demo/CMakeLists.txt
77+++ b/multi_channel/face_detection_demo/CMakeLists.txt
78@@ -60,7 +60,7 @@ if(MULTICHANNEL_DEMO_USE_TBB)
79 endif()
80 endif()
81 26
82-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} common) 27 find_package(OpenCV QUIET COMPONENTS gapi)
83+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} common)
84
85 if(UNIX)
86 target_link_libraries( ${TARGET_NAME} pthread)
87diff --git a/multi_channel/human_pose_estimation_demo/CMakeLists.txt b/multi_channel/human_pose_estimation_demo/CMakeLists.txt
88index 7fe4823..7e76796 100644
89--- a/multi_channel/human_pose_estimation_demo/CMakeLists.txt
90+++ b/multi_channel/human_pose_estimation_demo/CMakeLists.txt
91@@ -60,7 +60,7 @@ if(MULTICHANNEL_DEMO_USE_TBB)
92 endif()
93 endif()
94
95-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} common)
96+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} common)
97
98 if(UNIX)
99 target_link_libraries( ${TARGET_NAME} pthread)
100diff --git a/multi_channel/object_detection_demo_yolov3/CMakeLists.txt b/multi_channel/object_detection_demo_yolov3/CMakeLists.txt
101index e959349..cf1de4a 100644
102--- a/multi_channel/object_detection_demo_yolov3/CMakeLists.txt
103+++ b/multi_channel/object_detection_demo_yolov3/CMakeLists.txt
104@@ -60,7 +60,7 @@ if(MULTICHANNEL_DEMO_USE_TBB)
105 endif()
106 endif()
107
108-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} ngraph::ngraph common)
109+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} ngraph::ngraph common)
110
111 if(UNIX)
112 target_link_libraries( ${TARGET_NAME} pthread)
113--
1142.25.4
115