summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0006-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0006-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0006-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0006-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0006-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch
new file mode 100644
index 00000000..b0c0a5d4
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0006-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch
@@ -0,0 +1,27 @@
1From e41aafcd133ecf7215e941e01a58fcacd5c91bd7 Mon Sep 17 00:00:00 2001
2From: Chin Huat Ang <chin.huat.ang@intel.com>
3Date: Mon, 30 Sep 2019 13:50:45 +0800
4Subject: [PATCH 6/7] Install clDNN plugin to CMAKE_INSTALL_LIBDIR
5
6Upstream-Status: Pending
7Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com>
8---
9 inference-engine/src/cldnn_engine/CMakeLists.txt | 2 ++
10 1 file changed, 2 insertions(+)
11
12diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
13index b618084..7bdb311 100644
14--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
15+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
16@@ -22,6 +22,8 @@ target_include_directories(${TARGET_NAME} PRIVATE
17 ${IE_MAIN_SOURCE_DIR}/src/inference_engine
18 ${IE_MAIN_SOURCE_DIR}/thirdparty/pugixml/src)
19
20+install(TARGETS ${TARGET_NAME} EXPORT ${TARGET_NAME} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
21+
22 # copy default global xml file describing the custom kernels and the *.cl files
23
24 add_custom_command(TARGET ${TARGET_NAME} POST_BUILD
25--
262.7.4
27