summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch18
1 files changed, 8 insertions, 10 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
index ad4d8e8a..d4819077 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
@@ -1,4 +1,4 @@
1From 74b6af221e7e2663687654e6eb2d68a5c7158af9 Mon Sep 17 00:00:00 2001 1From aa515686548d74a68456b9ba7a295b6ae4be343a Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:50:19 +0800 3Date: Wed, 10 Jun 2020 09:50:19 +0800
4Subject: [PATCH] cldnn: fix inclusion of headers 4Subject: [PATCH] cldnn: fix inclusion of headers
@@ -6,6 +6,7 @@ Subject: [PATCH] cldnn: fix inclusion of headers
6Upstream-Status: Inappropriate 6Upstream-Status: Inappropriate
7 7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9
9--- 10---
10 inference-engine/include/gpu/gpu_ocl_wrapper.hpp | 2 +- 11 inference-engine/include/gpu/gpu_ocl_wrapper.hpp | 2 +-
11 inference-engine/src/cldnn_engine/CMakeLists.txt | 1 + 12 inference-engine/src/cldnn_engine/CMakeLists.txt | 1 +
@@ -13,30 +14,30 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
13 3 files changed, 3 insertions(+), 2 deletions(-) 14 3 files changed, 3 insertions(+), 2 deletions(-)
14 15
15diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp 16diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
16index 282dcd844..0d5d4084c 100644 17index 68ccf3217..c5b0ce6be 100644
17--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp 18--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
18+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp 19+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
19@@ -22,7 +22,7 @@ 20@@ -39,7 +39,7 @@
20 # pragma GCC system_header 21 # pragma GCC system_header
21 #endif 22 #endif
22 23
23-#include <CL/cl2.hpp> 24-#include <CL/cl2.hpp>
24+#include <cl2.hpp> 25+#include <cl2.hpp>
25 26
26 #if defined __GNUC__ 27 #ifdef __GNUC__
27 # pragma GCC diagnostic pop 28 # pragma GCC diagnostic pop
28diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt 29diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
29index cdc0de406..70883465b 100644 30index 7e15abbed..46d43e0e5 100644
30--- a/inference-engine/src/cldnn_engine/CMakeLists.txt 31--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
31+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt 32+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
32@@ -33,6 +33,7 @@ target_include_directories(${TARGET_NAME} PRIVATE 33@@ -31,6 +31,7 @@ target_include_directories(${TARGET_NAME} PRIVATE
33 ${CMAKE_CURRENT_SOURCE_DIR} 34 ${CMAKE_CURRENT_SOURCE_DIR}
34 $<TARGET_PROPERTY:inference_engine_transformations,INTERFACE_INCLUDE_DIRECTORIES> 35 $<TARGET_PROPERTY:inference_engine_transformations,INTERFACE_INCLUDE_DIRECTORIES>
35 ${CLDNN__IOCL_ICD_INCDIRS} 36 ${CLDNN__IOCL_ICD_INCDIRS}
36+ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp 37+ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp
37 ${CLDNN_TOP_FOLDER}) 38 ${CLDNN_TOP_FOLDER})
38 39
39 # install 40 set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_RELEASE ${ENABLE_LTO})
40diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp 41diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
41index 97608c30a..3a04096c0 100644 42index 97608c30a..3a04096c0 100644
42--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp 43--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
@@ -50,6 +51,3 @@ index 97608c30a..3a04096c0 100644
50 #include "cl_intel_usm_defs.h" 51 #include "cl_intel_usm_defs.h"
51 52
52 #include <memory> 53 #include <memory>
53--
542.26.2
55