summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
new file mode 100644
index 00000000..1b842da2
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
@@ -0,0 +1,52 @@
1From 0d0810481186fc443fe65a6119ddcc71ba21e814 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:50:19 +0800
4Subject: [PATCH 5/5] cldnn: fix inclusion of headers
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 inference-engine/include/gpu/gpu_ocl_wrapper.hpp | 2 +-
11 inference-engine/src/cldnn_engine/CMakeLists.txt | 1 +
12 .../thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp | 2 +-
13 3 files changed, 3 insertions(+), 2 deletions(-)
14
15diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
16index fce7d8f1..827e5764 100644
17--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
18+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
19@@ -21,4 +21,4 @@
20 # pragma GCC system_header
21 #endif
22
23-#include <CL/cl2.hpp>
24+#include <cl2.hpp>
25diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
26index de56ed8e..c81453ab 100644
27--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
28+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
29@@ -31,6 +31,7 @@ set (CLDNN_TOP_FOLDER ${IE_MAIN_SOURCE_DIR}/thirdparty/clDNN)
30 target_include_directories(${TARGET_NAME} PRIVATE
31 ${CMAKE_CURRENT_SOURCE_DIR}
32 ${CLDNN__IOCL_ICD_INCDIRS}
33+ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp
34 ${CLDNN_TOP_FOLDER})
35
36 # copy default global xml file describing the custom kernels and the *.cl files
37diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
38index 8f668b18..a1d24438 100644
39--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
40+++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
41@@ -29,7 +29,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel;
42 typedef cl_va_api_device_source_intel cl_device_source_intel;
43 typedef cl_va_api_device_set_intel cl_device_set_intel;
44 #endif
45-#include <CL/cl_intel_planar_yuv.h>
46+#include <CL/cl_ext_intel.h>
47 #include "cl_intel_usm_defs.h"
48
49 #include <memory>
50--
512.25.4
52