summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
index 1b842da2..d47d273c 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
@@ -1,7 +1,7 @@
1From 0d0810481186fc443fe65a6119ddcc71ba21e814 Mon Sep 17 00:00:00 2001 1From f201d67c965318ebe49f0d38ea36e530c35a4701 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:50:19 +0800 3Date: Wed, 10 Jun 2020 09:50:19 +0800
4Subject: [PATCH 5/5] cldnn: fix inclusion of headers 4Subject: [PATCH] cldnn: fix inclusion of headers
5 5
6Upstream-Status: Inappropriate 6Upstream-Status: Inappropriate
7 7
@@ -13,7 +13,7 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
13 3 files changed, 3 insertions(+), 2 deletions(-) 13 3 files changed, 3 insertions(+), 2 deletions(-)
14 14
15diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp 15diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
16index fce7d8f1..827e5764 100644 16index fce7d8f17..827e5764a 100644
17--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp 17--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
18+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp 18+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
19@@ -21,4 +21,4 @@ 19@@ -21,4 +21,4 @@
@@ -23,19 +23,19 @@ index fce7d8f1..827e5764 100644
23-#include <CL/cl2.hpp> 23-#include <CL/cl2.hpp>
24+#include <cl2.hpp> 24+#include <cl2.hpp>
25diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt 25diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
26index de56ed8e..c81453ab 100644 26index eeb9b5c80..32a283ba4 100644
27--- a/inference-engine/src/cldnn_engine/CMakeLists.txt 27--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
28+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt 28+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
29@@ -31,6 +31,7 @@ set (CLDNN_TOP_FOLDER ${IE_MAIN_SOURCE_DIR}/thirdparty/clDNN) 29@@ -33,6 +33,7 @@ target_include_directories(${TARGET_NAME} PRIVATE
30 target_include_directories(${TARGET_NAME} PRIVATE
31 ${CMAKE_CURRENT_SOURCE_DIR} 30 ${CMAKE_CURRENT_SOURCE_DIR}
31 $<TARGET_PROPERTY:inference_engine_transformations,INTERFACE_INCLUDE_DIRECTORIES>
32 ${CLDNN__IOCL_ICD_INCDIRS} 32 ${CLDNN__IOCL_ICD_INCDIRS}
33+ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp 33+ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp
34 ${CLDNN_TOP_FOLDER}) 34 ${CLDNN_TOP_FOLDER})
35 35
36 # copy default global xml file describing the custom kernels and the *.cl files 36 # install
37diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp 37diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
38index 8f668b18..a1d24438 100644 38index c67c81726..5ca48c597 100644
39--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp 39--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
40+++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp 40+++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
41@@ -29,7 +29,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel; 41@@ -29,7 +29,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel;