summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch55
1 files changed, 0 insertions, 55 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
deleted file mode 100644
index ad4d8e8a..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
+++ /dev/null
@@ -1,55 +0,0 @@
1From 74b6af221e7e2663687654e6eb2d68a5c7158af9 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:50:19 +0800
4Subject: [PATCH] cldnn: fix inclusion of headers
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 inference-engine/include/gpu/gpu_ocl_wrapper.hpp | 2 +-
11 inference-engine/src/cldnn_engine/CMakeLists.txt | 1 +
12 .../thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp | 2 +-
13 3 files changed, 3 insertions(+), 2 deletions(-)
14
15diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
16index 282dcd844..0d5d4084c 100644
17--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
18+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
19@@ -22,7 +22,7 @@
20 # pragma GCC system_header
21 #endif
22
23-#include <CL/cl2.hpp>
24+#include <cl2.hpp>
25
26 #if defined __GNUC__
27 # pragma GCC diagnostic pop
28diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
29index cdc0de406..70883465b 100644
30--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
31+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
32@@ -33,6 +33,7 @@ target_include_directories(${TARGET_NAME} PRIVATE
33 ${CMAKE_CURRENT_SOURCE_DIR}
34 $<TARGET_PROPERTY:inference_engine_transformations,INTERFACE_INCLUDE_DIRECTORIES>
35 ${CLDNN__IOCL_ICD_INCDIRS}
36+ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp
37 ${CLDNN_TOP_FOLDER})
38
39 # install
40diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
41index 97608c30a..3a04096c0 100644
42--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
43+++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
44@@ -29,7 +29,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel;
45 typedef cl_va_api_device_source_intel cl_device_source_intel;
46 typedef cl_va_api_device_set_intel cl_device_set_intel;
47 #endif
48-#include <CL/cl_intel_planar_yuv.h>
49+#include <CL/cl_ext_intel.h>
50 #include "cl_intel_usm_defs.h"
51
52 #include <memory>
53--
542.26.2
55