summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch52
1 files changed, 0 insertions, 52 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
deleted file mode 100644
index d47d273c..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From f201d67c965318ebe49f0d38ea36e530c35a4701 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:50:19 +0800
4Subject: [PATCH] cldnn: fix inclusion of headers
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 inference-engine/include/gpu/gpu_ocl_wrapper.hpp | 2 +-
11 inference-engine/src/cldnn_engine/CMakeLists.txt | 1 +
12 .../thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp | 2 +-
13 3 files changed, 3 insertions(+), 2 deletions(-)
14
15diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
16index fce7d8f17..827e5764a 100644
17--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
18+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
19@@ -21,4 +21,4 @@
20 # pragma GCC system_header
21 #endif
22
23-#include <CL/cl2.hpp>
24+#include <cl2.hpp>
25diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
26index eeb9b5c80..32a283ba4 100644
27--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
28+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
29@@ -33,6 +33,7 @@ target_include_directories(${TARGET_NAME} PRIVATE
30 ${CMAKE_CURRENT_SOURCE_DIR}
31 $<TARGET_PROPERTY:inference_engine_transformations,INTERFACE_INCLUDE_DIRECTORIES>
32 ${CLDNN__IOCL_ICD_INCDIRS}
33+ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp
34 ${CLDNN_TOP_FOLDER})
35
36 # install
37diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
38index c67c81726..5ca48c597 100644
39--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
40+++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
41@@ -29,7 +29,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel;
42 typedef cl_va_api_device_source_intel cl_device_source_intel;
43 typedef cl_va_api_device_set_intel cl_device_set_intel;
44 #endif
45-#include <CL/cl_intel_planar_yuv.h>
46+#include <CL/cl_ext_intel.h>
47 #include "cl_intel_usm_defs.h"
48
49 #include <memory>
50--
512.25.4
52