summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-use-GNUInstallDirs-on-nix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-use-GNUInstallDirs-on-nix.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-use-GNUInstallDirs-on-nix.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-use-GNUInstallDirs-on-nix.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-use-GNUInstallDirs-on-nix.patch
new file mode 100644
index 00000000..ec8b9fea
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-use-GNUInstallDirs-on-nix.patch
@@ -0,0 +1,81 @@
1From 970443ce6bf31128c3517374e2890a93518d988e Mon Sep 17 00:00:00 2001
2From: Kevron Rees <kevron.m.rees@intel.com>
3Date: Wed, 3 Apr 2019 09:20:48 -0700
4Subject: [PATCH] use GNUInstallDirs on *nix
5
6Upstream-Status: Submitted [Patch taken from Clear Linux and has been submitted
7upstream]
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 .../thirdparty/clDNN/CMakeLists.txt | 3 +-
11 .../thirdparty/clDNN/src/CMakeLists.txt | 36 +++++++++++++++----
12 2 files changed, 31 insertions(+), 8 deletions(-)
13
14diff --git a/inference-engine/thirdparty/clDNN/CMakeLists.txt b/inference-engine/thirdparty/clDNN/CMakeLists.txt
15index 624d95c..5957791 100644
16--- a/inference-engine/thirdparty/clDNN/CMakeLists.txt
17+++ b/inference-engine/thirdparty/clDNN/CMakeLists.txt
18@@ -93,7 +93,8 @@ set(CLDNN__GTEST_DIR "${CLDNN__COMMON_DIR}/googletest-fused")
19 # Build targets settings.
20
21 # Path which points to default root directory for compilation output.
22-set(CLDNN_BUILD__DEFAULT_OUT_ROOT "${CMAKE_CURRENT_SOURCE_DIR}/build/out")
23+set(CLDNN_BUILD__DEFAULT_OUT_ROOT "${CMAKE_BINARY_DIR}")
24+set(CLDNN__OUTPUT_DIR, "${CMAKE_BINARY_DIR}")
25
26 # Prefix for all targets in internal pass.
27 set(CLDNN_BUILD__PROJ_NAME_PREFIX "")
28diff --git a/inference-engine/thirdparty/clDNN/src/CMakeLists.txt b/inference-engine/thirdparty/clDNN/src/CMakeLists.txt
29index 132c6e4..cc88535 100644
30--- a/inference-engine/thirdparty/clDNN/src/CMakeLists.txt
31+++ b/inference-engine/thirdparty/clDNN/src/CMakeLists.txt
32@@ -247,17 +247,39 @@ target_link_libraries("${CLDNN_BUILD__PROJ}" PRIVATE ${CLDNN__SYSTEM_LINK_LIBRAR
33
34 # ========================================== Installation ==============================================
35
36+if(UNIX)
37+ include(GNUInstallDirs)
38+endif(UNIX)
39+
40+
41 # API headers.
42-install(DIRECTORY "${CLDNN__API_DIR}/"
43+if(UNIX)
44+ install(DIRECTORY "${CLDNN__API_DIR}/"
45+ DESTINATION "${CMAKE_INSTALL_FULL_INCLUDEDIR}/clDNN"
46+ FILE_PERMISSIONS OWNER_WRITE OWNER_READ GROUP_READ WORLD_READ
47+ )
48+else()
49+ install(DIRECTORY "${CLDNN__API_DIR}/"
50 DESTINATION "include/clDNN"
51 FILE_PERMISSIONS OWNER_WRITE OWNER_READ GROUP_READ WORLD_READ
52 )
53+endif(UNIX)
54+
55 # Binaries.
56-install(TARGETS "${CLDNN_BUILD__PROJ}"
57- ARCHIVE DESTINATION "lib"
58- LIBRARY DESTINATION "lib"
59- RUNTIME DESTINATION "bin"
60- INCLUDES DESTINATION "include/clDNN"
61- )
62+if(UNIX)
63+ install(TARGETS "${CLDNN_BUILD__PROJ}"
64+ ARCHIVE DESTINATION "${CMAKE_INSTALL_FULL_LIBDIR}"
65+ LIBRARY DESTINATION "${CMAKE_INSTALL_FULL_LIBDIR}"
66+ RUNTIME DESTINATION "${CMAKE_INSTALL_FULL_BINDIR}"
67+ INCLUDES DESTINATION "${CMAKE_INSTALL_FULL_INCLUDEDIR}/clDNN"
68+ )
69+else()
70+ install(TARGETS "${CLDNN_BUILD__PROJ}"
71+ ARCHIVE DESTINATION "lib"
72+ LIBRARY DESTINATION "lib"
73+ RUNTIME DESTINATION "bin"
74+ INCLUDES DESTINATION "include/clDNN"
75+ )
76+endif(UNIX)
77
78 # ======================================================================================================
79--
802.23.0
81