summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch204
1 files changed, 204 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
new file mode 100644
index 00000000..5fa1b2ec
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
@@ -0,0 +1,204 @@
1From 0838608d9c2b09a845efbdde88a09e151ac9ff7d Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 11 Jun 2020 14:24:04 +0800
4Subject: [PATCH] fixes
5
6Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
7---
8 CMakeLists.txt | 14 --------------
9 cmake/developer_package.cmake | 10 ++++++----
10 inference-engine/samples/CMakeLists.txt | 8 +++-----
11 .../samples/common/format_reader/CMakeLists.txt | 2 ++
12 .../src/inference_engine/CMakeLists.txt | 4 ++--
13 .../src/vpu/myriad_plugin/CMakeLists.txt | 2 +-
14 inference-engine/tests/unit/cpu/CMakeLists.txt | 4 +++-
15 .../tests/unit/inference_engine/CMakeLists.txt | 4 +++-
16 inference-engine/tests/unit/vpu/CMakeLists.txt | 4 +++-
17 9 files changed, 23 insertions(+), 29 deletions(-)
18
19diff --git a/CMakeLists.txt b/CMakeLists.txt
20index 902d3289..f1bfb3f5 100644
21--- a/CMakeLists.txt
22+++ b/CMakeLists.txt
23@@ -123,12 +123,8 @@ add_subdirectory(docs)
24
25 # install setupvars
26
27-ie_cpack_add_component(setupvars REQUIRED)
28
29 if(UNIX)
30- install(PROGRAMS scripts/setupvars/setupvars.sh
31- DESTINATION bin
32- COMPONENT setupvars)
33 elseif(WIN32)
34 install(PROGRAMS scripts/setupvars/setupvars.bat
35 DESTINATION bin
36@@ -138,22 +134,12 @@ endif()
37 # install install_dependencies
38
39 if(UNIX)
40- ie_cpack_add_component(install_dependencies REQUIRED)
41- install(DIRECTORY scripts/install_dependencies/
42- DESTINATION install_dependencies
43- COMPONENT install_dependencies)
44 endif()
45
46 # install files for demo
47
48-ie_cpack_add_component(demo_scripts REQUIRED DEPENDS core)
49
50 if(UNIX)
51- install(DIRECTORY scripts/demo/
52- DESTINATION deployment_tools/demo
53- COMPONENT demo_scripts
54- USE_SOURCE_PERMISSIONS
55- PATTERN *.bat EXCLUDE)
56 elseif(WIN32)
57 install(DIRECTORY scripts/demo/
58 DESTINATION deployment_tools/demo
59diff --git a/cmake/developer_package.cmake b/cmake/developer_package.cmake
60index 23cd9b2d..24c33711 100644
61--- a/cmake/developer_package.cmake
62+++ b/cmake/developer_package.cmake
63@@ -7,7 +7,9 @@ set(CMAKE_MODULE_PATH "${OpenVINO_MAIN_SOURCE_DIR}/cmake/download" ${CMAKE_MODUL
64 include(CPackComponent)
65 unset(IE_CPACK_COMPONENTS_ALL CACHE)
66
67-set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
68+if (NOT DEFINED IE_CPACK_IE_DIR)
69+ set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
70+endif()
71
72 # Search packages for the host system instead of packages for the target system
73 # in case of cross compilation these macros should be defined by the toolchain file
74@@ -40,8 +42,8 @@ function(ie_cpack_set_library_dir)
75 set(IE_CPACK_RUNTIME_PATH ${IE_CPACK_IE_DIR}/bin/${ARCH}/${CMAKE_BUILD_TYPE} PARENT_SCOPE)
76 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH}/${CMAKE_BUILD_TYPE} PARENT_SCOPE)
77 else()
78- set(IE_CPACK_LIBRARY_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
79- set(IE_CPACK_RUNTIME_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
80+ set(IE_CPACK_LIBRARY_PATH ${CMAKE_INSTALL_LIBDIR} PARENT_SCOPE)
81+ set(IE_CPACK_RUNTIME_PATH ${CMAKE_INSTALL_BINDIR} PARENT_SCOPE)
82 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
83 endif()
84 endfunction()
85@@ -143,7 +145,7 @@ if("${CMAKE_BUILD_TYPE}" STREQUAL "")
86 set(CMAKE_BUILD_TYPE "Release")
87 endif()
88
89-set(OUTPUT_ROOT ${OpenVINO_MAIN_SOURCE_DIR})
90+set(OUTPUT_ROOT ${CMAKE_CURRENT_BINARY_DIR})
91
92 # Enable postfixes for Debug/Release builds
93 set(IE_DEBUG_POSTFIX_WIN "d")
94diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
95index 033a8aab..4a871ca6 100644
96--- a/inference-engine/samples/CMakeLists.txt
97+++ b/inference-engine/samples/CMakeLists.txt
98@@ -28,7 +28,7 @@ endif()
99
100 if(IE_MAIN_SOURCE_DIR)
101 # in case if samples are built from IE repo
102- set(IE_MAIN_SAMPLES_DIR ${OpenVINO_MAIN_SOURCE_DIR})
103+ set(IE_MAIN_SAMPLES_DIR ${CMAKE_BINARY_DIR})
104 # hint for find_package(InferenceEngine in the samples folder)
105 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}")
106 else()
107@@ -110,10 +110,6 @@ set (HAVE_INTTYPES_H 1)
108 set (INTTYPES_FORMAT C99)
109 set (BUILD_TESTING OFF)
110
111-if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/gflags")
112- add_subdirectory(thirdparty/gflags)
113-endif()
114-
115 if (CMAKE_CXX_COMPILER_ID STREQUAL GNU)
116 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
117 endif()
118@@ -222,6 +218,8 @@ macro(ie_add_sample)
119 if(COMMAND add_cpplint_target AND NOT IE_SAMPLE_EXCLUDE_CPPLINT)
120 add_cpplint_target(${IE_SAMPLE_NAME}_cpplint FOR_TARGETS ${IE_SAMPLE_NAME})
121 endif()
122+
123+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin)
124 endmacro()
125
126 # collect all samples subdirectories
127diff --git a/inference-engine/samples/common/format_reader/CMakeLists.txt b/inference-engine/samples/common/format_reader/CMakeLists.txt
128index 6d935135..fe12eeb7 100644
129--- a/inference-engine/samples/common/format_reader/CMakeLists.txt
130+++ b/inference-engine/samples/common/format_reader/CMakeLists.txt
131@@ -40,3 +40,5 @@ target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}"
132 "${CMAKE_CURRENT_SOURCE_DIR}/..")
133
134 set_target_properties(${TARGET_NAME} PROPERTIES COMPILE_PDB_NAME ${TARGET_NAME})
135+
136+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
137diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
138index c8cd4b27..babe8ff5 100644
139--- a/inference-engine/src/inference_engine/CMakeLists.txt
140+++ b/inference-engine/src/inference_engine/CMakeLists.txt
141@@ -289,8 +289,8 @@ install(TARGETS ${TARGET_NAME} ${TARGET_NAME}_nn_builder
142 install(FILES "${OpenVINO_BINARY_DIR}/share/ie_parallel.cmake"
143 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig.cmake"
144 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig-version.cmake"
145- DESTINATION ${IE_CPACK_IE_DIR}/share
146+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/InferenceEngine
147 COMPONENT core)
148 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
149- DESTINATION ${IE_CPACK_RUNTIME_PATH}
150+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
151 COMPONENT core)
152diff --git a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
153index b35910f6..304d6d40 100644
154--- a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
155+++ b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
156@@ -48,5 +48,5 @@ target_link_libraries(${TARGET_NAME}
157 # install
158
159 install(FILES ${IE_MAIN_SOURCE_DIR}/thirdparty/movidius/mvnc/src/97-myriad-usbboot.rules
160- DESTINATION ${IE_CPACK_IE_DIR}/external
161+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
162 COMPONENT myriad)
163diff --git a/inference-engine/tests/unit/cpu/CMakeLists.txt b/inference-engine/tests/unit/cpu/CMakeLists.txt
164index 9ec5ad02..45c62571 100644
165--- a/inference-engine/tests/unit/cpu/CMakeLists.txt
166+++ b/inference-engine/tests/unit/cpu/CMakeLists.txt
167@@ -22,4 +22,6 @@ addIeTargetTest(
168 ADD_CPPLINT
169 LABELS
170 CPU
171-)
172\ No newline at end of file
173+)
174+
175+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
176diff --git a/inference-engine/tests/unit/inference_engine/CMakeLists.txt b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
177index 55e52b59..9d383d74 100644
178--- a/inference-engine/tests/unit/inference_engine/CMakeLists.txt
179+++ b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
180@@ -12,4 +12,6 @@ addIeTargetTest(
181 ADD_CPPLINT
182 LABELS
183 INFERENCE_ENGINE
184-)
185\ No newline at end of file
186+)
187+
188+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
189diff --git a/inference-engine/tests/unit/vpu/CMakeLists.txt b/inference-engine/tests/unit/vpu/CMakeLists.txt
190index 39fb1d5a..5ce82b5f 100644
191--- a/inference-engine/tests/unit/vpu/CMakeLists.txt
192+++ b/inference-engine/tests/unit/vpu/CMakeLists.txt
193@@ -23,4 +23,6 @@ addIeTargetTest(
194 LABELS
195 VPU
196 MYRIAD
197-)
198\ No newline at end of file
199+)
200+
201+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
202--
2032.25.4
204