summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch97
1 files changed, 54 insertions, 43 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
index 5fa1b2ec..ac34fa4f 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
@@ -1,26 +1,29 @@
1From 0838608d9c2b09a845efbdde88a09e151ac9ff7d Mon Sep 17 00:00:00 2001 1From d9adfdc9c802fdb880fb658085854384f90a88c2 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 11 Jun 2020 14:24:04 +0800 3Date: Thu, 11 Jun 2020 14:24:04 +0800
4Subject: [PATCH] fixes 4Subject: [PATCH] cmake installation fixes
5
6Make sure that libraries/samples/binaries are installed correctly.
5 7
6Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
7--- 9---
8 CMakeLists.txt | 14 -------------- 10 CMakeLists.txt | 14 --------------
9 cmake/developer_package.cmake | 10 ++++++---- 11 cmake/developer_package.cmake | 10 ++++++----
10 inference-engine/samples/CMakeLists.txt | 8 +++----- 12 .../ie_bridges/c/samples/common/CMakeLists.txt | 2 ++
13 inference-engine/samples/CMakeLists.txt | 9 +++------
11 .../samples/common/format_reader/CMakeLists.txt | 2 ++ 14 .../samples/common/format_reader/CMakeLists.txt | 2 ++
12 .../src/inference_engine/CMakeLists.txt | 4 ++-- 15 .../src/inference_engine/CMakeLists.txt | 4 ++--
13 .../src/vpu/myriad_plugin/CMakeLists.txt | 2 +- 16 .../src/vpu/myriad_plugin/CMakeLists.txt | 2 +-
14 inference-engine/tests/unit/cpu/CMakeLists.txt | 4 +++- 17 inference-engine/tests/unit/cpu/CMakeLists.txt | 4 +++-
15 .../tests/unit/inference_engine/CMakeLists.txt | 4 +++- 18 .../tests/unit/inference_engine/CMakeLists.txt | 2 ++
16 inference-engine/tests/unit/vpu/CMakeLists.txt | 4 +++- 19 inference-engine/tests/unit/vpu/CMakeLists.txt | 4 +++-
17 9 files changed, 23 insertions(+), 29 deletions(-) 20 10 files changed, 24 insertions(+), 29 deletions(-)
18 21
19diff --git a/CMakeLists.txt b/CMakeLists.txt 22diff --git a/CMakeLists.txt b/CMakeLists.txt
20index 902d3289..f1bfb3f5 100644 23index 1f981ed25..2c014ca27 100644
21--- a/CMakeLists.txt 24--- a/CMakeLists.txt
22+++ b/CMakeLists.txt 25+++ b/CMakeLists.txt
23@@ -123,12 +123,8 @@ add_subdirectory(docs) 26@@ -121,12 +121,8 @@ add_subdirectory(docs)
24 27
25 # install setupvars 28 # install setupvars
26 29
@@ -33,7 +36,7 @@ index 902d3289..f1bfb3f5 100644
33 elseif(WIN32) 36 elseif(WIN32)
34 install(PROGRAMS scripts/setupvars/setupvars.bat 37 install(PROGRAMS scripts/setupvars/setupvars.bat
35 DESTINATION bin 38 DESTINATION bin
36@@ -138,22 +134,12 @@ endif() 39@@ -136,22 +132,12 @@ endif()
37 # install install_dependencies 40 # install install_dependencies
38 41
39 if(UNIX) 42 if(UNIX)
@@ -57,10 +60,10 @@ index 902d3289..f1bfb3f5 100644
57 install(DIRECTORY scripts/demo/ 60 install(DIRECTORY scripts/demo/
58 DESTINATION deployment_tools/demo 61 DESTINATION deployment_tools/demo
59diff --git a/cmake/developer_package.cmake b/cmake/developer_package.cmake 62diff --git a/cmake/developer_package.cmake b/cmake/developer_package.cmake
60index 23cd9b2d..24c33711 100644 63index 5e022244b..6e2cbf44e 100644
61--- a/cmake/developer_package.cmake 64--- a/cmake/developer_package.cmake
62+++ b/cmake/developer_package.cmake 65+++ b/cmake/developer_package.cmake
63@@ -7,7 +7,9 @@ set(CMAKE_MODULE_PATH "${OpenVINO_MAIN_SOURCE_DIR}/cmake/download" ${CMAKE_MODUL 66@@ -10,7 +10,9 @@ list(APPEND CMAKE_MODULE_PATH
64 include(CPackComponent) 67 include(CPackComponent)
65 unset(IE_CPACK_COMPONENTS_ALL CACHE) 68 unset(IE_CPACK_COMPONENTS_ALL CACHE)
66 69
@@ -71,7 +74,7 @@ index 23cd9b2d..24c33711 100644
71 74
72 # Search packages for the host system instead of packages for the target system 75 # Search packages for the host system instead of packages for the target system
73 # in case of cross compilation these macros should be defined by the toolchain file 76 # in case of cross compilation these macros should be defined by the toolchain file
74@@ -40,8 +42,8 @@ function(ie_cpack_set_library_dir) 77@@ -43,8 +45,8 @@ function(ie_cpack_set_library_dir)
75 set(IE_CPACK_RUNTIME_PATH ${IE_CPACK_IE_DIR}/bin/${ARCH}/${CMAKE_BUILD_TYPE} PARENT_SCOPE) 78 set(IE_CPACK_RUNTIME_PATH ${IE_CPACK_IE_DIR}/bin/${ARCH}/${CMAKE_BUILD_TYPE} PARENT_SCOPE)
76 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH}/${CMAKE_BUILD_TYPE} PARENT_SCOPE) 79 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH}/${CMAKE_BUILD_TYPE} PARENT_SCOPE)
77 else() 80 else()
@@ -82,20 +85,30 @@ index 23cd9b2d..24c33711 100644
82 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE) 85 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
83 endif() 86 endif()
84 endfunction() 87 endfunction()
85@@ -143,7 +145,7 @@ if("${CMAKE_BUILD_TYPE}" STREQUAL "") 88@@ -147,7 +149,7 @@ endif()
86 set(CMAKE_BUILD_TYPE "Release")
87 endif()
88 89
89-set(OUTPUT_ROOT ${OpenVINO_MAIN_SOURCE_DIR}) 90 # allow to override default OUTPUT_ROOT root
90+set(OUTPUT_ROOT ${CMAKE_CURRENT_BINARY_DIR}) 91 if(NOT DEFINED OUTPUT_ROOT)
92- set(OUTPUT_ROOT ${OpenVINO_MAIN_SOURCE_DIR})
93+ set(OUTPUT_ROOT ${CMAKE_CURRENT_BINARY_DIR})
94 endif()
91 95
92 # Enable postfixes for Debug/Release builds 96 # Enable postfixes for Debug/Release builds
93 set(IE_DEBUG_POSTFIX_WIN "d") 97diff --git a/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt b/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt
98index b8d5ddf62..d086478f6 100644
99--- a/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt
100+++ b/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt
101@@ -29,3 +29,5 @@ set_target_properties(${TARGET_NAME} PROPERTIES FOLDER c_samples)
102 if(COMMAND add_cpplint_target)
103 add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
104 endif()
105+
106+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
94diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt 107diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
95index 033a8aab..4a871ca6 100644 108index 594e581b1..4e95a7808 100644
96--- a/inference-engine/samples/CMakeLists.txt 109--- a/inference-engine/samples/CMakeLists.txt
97+++ b/inference-engine/samples/CMakeLists.txt 110+++ b/inference-engine/samples/CMakeLists.txt
98@@ -28,7 +28,7 @@ endif() 111@@ -34,7 +34,7 @@ endif()
99 112
100 if(IE_MAIN_SOURCE_DIR) 113 if(IE_MAIN_SOURCE_DIR)
101 # in case if samples are built from IE repo 114 # in case if samples are built from IE repo
@@ -103,21 +116,22 @@ index 033a8aab..4a871ca6 100644
103+ set(IE_MAIN_SAMPLES_DIR ${CMAKE_BINARY_DIR}) 116+ set(IE_MAIN_SAMPLES_DIR ${CMAKE_BINARY_DIR})
104 # hint for find_package(InferenceEngine in the samples folder) 117 # hint for find_package(InferenceEngine in the samples folder)
105 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}") 118 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}")
106 else() 119 # hint for find_package(ngraph in the samples folder)
107@@ -110,10 +110,6 @@ set (HAVE_INTTYPES_H 1) 120@@ -118,11 +118,6 @@ set (HAVE_INTTYPES_H 1)
108 set (INTTYPES_FORMAT C99) 121 set (INTTYPES_FORMAT C99)
109 set (BUILD_TESTING OFF) 122 set (BUILD_TESTING OFF)
110 123
111-if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/gflags") 124-if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/gflags")
112- add_subdirectory(thirdparty/gflags) 125- add_subdirectory(thirdparty/gflags)
126- set_target_properties(gflags_nothreads_static PROPERTIES FOLDER thirdparty)
113-endif() 127-endif()
114- 128-
115 if (CMAKE_CXX_COMPILER_ID STREQUAL GNU) 129 if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
116 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall") 130 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
117 endif() 131 endif()
118@@ -222,6 +218,8 @@ macro(ie_add_sample) 132@@ -239,6 +234,8 @@ macro(ie_add_sample)
119 if(COMMAND add_cpplint_target AND NOT IE_SAMPLE_EXCLUDE_CPPLINT) 133 add_cpplint_target(${IE_SAMPLE_NAME}_cpplint FOR_TARGETS ${IE_SAMPLE_NAME}
120 add_cpplint_target(${IE_SAMPLE_NAME}_cpplint FOR_TARGETS ${IE_SAMPLE_NAME}) 134 CUSTOM_FILTERS ${custom_filters})
121 endif() 135 endif()
122+ 136+
123+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin) 137+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin)
@@ -125,20 +139,20 @@ index 033a8aab..4a871ca6 100644
125 139
126 # collect all samples subdirectories 140 # collect all samples subdirectories
127diff --git a/inference-engine/samples/common/format_reader/CMakeLists.txt b/inference-engine/samples/common/format_reader/CMakeLists.txt 141diff --git a/inference-engine/samples/common/format_reader/CMakeLists.txt b/inference-engine/samples/common/format_reader/CMakeLists.txt
128index 6d935135..fe12eeb7 100644 142index 48dbed9f2..76532fd04 100644
129--- a/inference-engine/samples/common/format_reader/CMakeLists.txt 143--- a/inference-engine/samples/common/format_reader/CMakeLists.txt
130+++ b/inference-engine/samples/common/format_reader/CMakeLists.txt 144+++ b/inference-engine/samples/common/format_reader/CMakeLists.txt
131@@ -40,3 +40,5 @@ target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}" 145@@ -41,3 +41,5 @@ target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}"
132 "${CMAKE_CURRENT_SOURCE_DIR}/..")
133 146
134 set_target_properties(${TARGET_NAME} PROPERTIES COMPILE_PDB_NAME ${TARGET_NAME}) 147 set_target_properties(${TARGET_NAME} PROPERTIES COMPILE_PDB_NAME ${TARGET_NAME}
148 FOLDER cpp_samples)
135+ 149+
136+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}) 150+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
137diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt 151diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
138index c8cd4b27..babe8ff5 100644 152index 4ae0d5607..b9ee12498 100644
139--- a/inference-engine/src/inference_engine/CMakeLists.txt 153--- a/inference-engine/src/inference_engine/CMakeLists.txt
140+++ b/inference-engine/src/inference_engine/CMakeLists.txt 154+++ b/inference-engine/src/inference_engine/CMakeLists.txt
141@@ -289,8 +289,8 @@ install(TARGETS ${TARGET_NAME} ${TARGET_NAME}_nn_builder 155@@ -265,8 +265,8 @@ install(TARGETS ${TARGET_NAME}
142 install(FILES "${OpenVINO_BINARY_DIR}/share/ie_parallel.cmake" 156 install(FILES "${OpenVINO_BINARY_DIR}/share/ie_parallel.cmake"
143 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig.cmake" 157 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig.cmake"
144 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig-version.cmake" 158 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig-version.cmake"
@@ -150,7 +164,7 @@ index c8cd4b27..babe8ff5 100644
150+ DESTINATION ${CMAKE_INSTALL_LIBDIR} 164+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
151 COMPONENT core) 165 COMPONENT core)
152diff --git a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt 166diff --git a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
153index b35910f6..304d6d40 100644 167index bf30d127c..6ed8c4081 100644
154--- a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt 168--- a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
155+++ b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt 169+++ b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
156@@ -48,5 +48,5 @@ target_link_libraries(${TARGET_NAME} 170@@ -48,5 +48,5 @@ target_link_libraries(${TARGET_NAME}
@@ -161,7 +175,7 @@ index b35910f6..304d6d40 100644
161+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d 175+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
162 COMPONENT myriad) 176 COMPONENT myriad)
163diff --git a/inference-engine/tests/unit/cpu/CMakeLists.txt b/inference-engine/tests/unit/cpu/CMakeLists.txt 177diff --git a/inference-engine/tests/unit/cpu/CMakeLists.txt b/inference-engine/tests/unit/cpu/CMakeLists.txt
164index 9ec5ad02..45c62571 100644 178index 9ec5ad025..45c62571a 100644
165--- a/inference-engine/tests/unit/cpu/CMakeLists.txt 179--- a/inference-engine/tests/unit/cpu/CMakeLists.txt
166+++ b/inference-engine/tests/unit/cpu/CMakeLists.txt 180+++ b/inference-engine/tests/unit/cpu/CMakeLists.txt
167@@ -22,4 +22,6 @@ addIeTargetTest( 181@@ -22,4 +22,6 @@ addIeTargetTest(
@@ -174,23 +188,20 @@ index 9ec5ad02..45c62571 100644
174+ 188+
175+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR}) 189+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
176diff --git a/inference-engine/tests/unit/inference_engine/CMakeLists.txt b/inference-engine/tests/unit/inference_engine/CMakeLists.txt 190diff --git a/inference-engine/tests/unit/inference_engine/CMakeLists.txt b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
177index 55e52b59..9d383d74 100644 191index 3eb21a434..09ba9225a 100644
178--- a/inference-engine/tests/unit/inference_engine/CMakeLists.txt 192--- a/inference-engine/tests/unit/inference_engine/CMakeLists.txt
179+++ b/inference-engine/tests/unit/inference_engine/CMakeLists.txt 193+++ b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
180@@ -12,4 +12,6 @@ addIeTargetTest( 194@@ -15,3 +15,5 @@ addIeTargetTest(
181 ADD_CPPLINT
182 LABELS 195 LABELS
183 INFERENCE_ENGINE 196 IE
184-) 197 )
185\ No newline at end of file
186+)
187+ 198+
188+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR}) 199+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
189diff --git a/inference-engine/tests/unit/vpu/CMakeLists.txt b/inference-engine/tests/unit/vpu/CMakeLists.txt 200diff --git a/inference-engine/tests/unit/vpu/CMakeLists.txt b/inference-engine/tests/unit/vpu/CMakeLists.txt
190index 39fb1d5a..5ce82b5f 100644 201index 072103292..117cc9ee1 100644
191--- a/inference-engine/tests/unit/vpu/CMakeLists.txt 202--- a/inference-engine/tests/unit/vpu/CMakeLists.txt
192+++ b/inference-engine/tests/unit/vpu/CMakeLists.txt 203+++ b/inference-engine/tests/unit/vpu/CMakeLists.txt
193@@ -23,4 +23,6 @@ addIeTargetTest( 204@@ -26,4 +26,6 @@ addIeTargetTest(
194 LABELS 205 LABELS
195 VPU 206 VPU
196 MYRIAD 207 MYRIAD
@@ -200,5 +211,5 @@ index 39fb1d5a..5ce82b5f 100644
200+ 211+
201+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR}) 212+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
202-- 213--
2032.25.4 2142.26.2
204 215