summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch229
1 files changed, 0 insertions, 229 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
deleted file mode 100644
index 9c91ac4d..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
+++ /dev/null
@@ -1,229 +0,0 @@
1From 5bec3199ec6fd8f784cd688159f768a732c9ad69 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 11 Jun 2020 14:24:04 +0800
4Subject: [PATCH] cmake installation fixes
5
6Make sure that libraries/samples/binaries are installed correctly.
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 CMakeLists.txt | 14 --------------
11 cmake/developer_package.cmake | 10 ++++++----
12 .../samples/common/opencv_c_wraper/CMakeLists.txt | 2 ++
13 inference-engine/samples/CMakeLists.txt | 9 +++------
14 .../samples/common/format_reader/CMakeLists.txt | 2 ++
15 .../src/inference_engine/CMakeLists.txt | 4 ++--
16 .../src/vpu/myriad_plugin/CMakeLists.txt | 2 +-
17 inference-engine/tests/unit/cpu/CMakeLists.txt | 4 +++-
18 .../tests/unit/inference_engine/CMakeLists.txt | 2 ++
19 inference-engine/tests/unit/vpu/CMakeLists.txt | 4 +++-
20 inference-engine/tools/compile_tool/CMakeLists.txt | 2 +-
21 11 files changed, 25 insertions(+), 30 deletions(-)
22
23diff --git a/CMakeLists.txt b/CMakeLists.txt
24index 18ed02ee5..18f6094f3 100644
25--- a/CMakeLists.txt
26+++ b/CMakeLists.txt
27@@ -143,12 +143,8 @@ add_subdirectory(docs)
28
29 # install setupvars
30
31-ie_cpack_add_component(setupvars REQUIRED)
32
33 if(UNIX)
34- install(PROGRAMS scripts/setupvars/setupvars.sh
35- DESTINATION bin
36- COMPONENT setupvars)
37 elseif(WIN32)
38 install(PROGRAMS scripts/setupvars/setupvars.bat
39 DESTINATION bin
40@@ -158,22 +154,12 @@ endif()
41 # install install_dependencies
42
43 if(UNIX)
44- ie_cpack_add_component(install_dependencies REQUIRED)
45- install(DIRECTORY scripts/install_dependencies/
46- DESTINATION install_dependencies
47- COMPONENT install_dependencies)
48 endif()
49
50 # install files for demo
51
52-ie_cpack_add_component(demo_scripts REQUIRED DEPENDS core)
53
54 if(UNIX)
55- install(DIRECTORY scripts/demo/
56- DESTINATION deployment_tools/demo
57- COMPONENT demo_scripts
58- USE_SOURCE_PERMISSIONS
59- PATTERN *.bat EXCLUDE)
60 elseif(WIN32)
61 install(DIRECTORY scripts/demo/
62 DESTINATION deployment_tools/demo
63diff --git a/cmake/developer_package.cmake b/cmake/developer_package.cmake
64index 86137c384..af011c361 100644
65--- a/cmake/developer_package.cmake
66+++ b/cmake/developer_package.cmake
67@@ -10,7 +10,9 @@ list(APPEND CMAKE_MODULE_PATH
68 include(CPackComponent)
69 unset(IE_CPACK_COMPONENTS_ALL CACHE)
70
71-set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
72+if (NOT DEFINED IE_CPACK_IE_DIR)
73+ set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
74+endif()
75
76 # Search packages for the host system instead of packages for the target system
77 # in case of cross compilation these macros should be defined by the toolchain file
78@@ -43,8 +45,8 @@ function(ie_cpack_set_library_dir)
79 set(IE_CPACK_RUNTIME_PATH ${IE_CPACK_IE_DIR}/bin/${ARCH}/${CMAKE_BUILD_TYPE} PARENT_SCOPE)
80 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH}/${CMAKE_BUILD_TYPE} PARENT_SCOPE)
81 else()
82- set(IE_CPACK_LIBRARY_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
83- set(IE_CPACK_RUNTIME_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
84+ set(IE_CPACK_LIBRARY_PATH ${CMAKE_INSTALL_LIBDIR} PARENT_SCOPE)
85+ set(IE_CPACK_RUNTIME_PATH ${CMAKE_INSTALL_BINDIR} PARENT_SCOPE)
86 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
87 endif()
88 endfunction()
89@@ -147,7 +149,7 @@ endif()
90
91 # allow to override default OUTPUT_ROOT root
92 if(NOT DEFINED OUTPUT_ROOT)
93- set(OUTPUT_ROOT ${OpenVINO_MAIN_SOURCE_DIR})
94+ set(OUTPUT_ROOT ${CMAKE_CURRENT_BINARY_DIR})
95 endif()
96
97 # Enable postfixes for Debug/Release builds
98diff --git a/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt b/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt
99index b8d5ddf62..d086478f6 100644
100--- a/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt
101+++ b/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt
102@@ -29,3 +29,5 @@ set_target_properties(${TARGET_NAME} PROPERTIES FOLDER c_samples)
103 if(COMMAND add_cpplint_target)
104 add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
105 endif()
106+
107+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
108diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
109index 4dda7eecd..04e1b9c3e 100644
110--- a/inference-engine/samples/CMakeLists.txt
111+++ b/inference-engine/samples/CMakeLists.txt
112@@ -34,7 +34,7 @@ endif()
113
114 if(IE_MAIN_SOURCE_DIR)
115 # in case if samples are built from IE repo
116- set(IE_MAIN_SAMPLES_DIR ${OpenVINO_MAIN_SOURCE_DIR})
117+ set(IE_MAIN_SAMPLES_DIR ${CMAKE_BINARY_DIR})
118 # hint for find_package(InferenceEngine in the samples folder)
119 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}")
120 # hint for find_package(ngraph in the samples folder)
121@@ -122,11 +122,6 @@ set (HAVE_INTTYPES_H 1)
122 set (INTTYPES_FORMAT C99)
123 set (BUILD_TESTING OFF)
124
125-if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/gflags")
126- add_subdirectory(thirdparty/gflags)
127- set_target_properties(gflags_nothreads_static PROPERTIES FOLDER thirdparty)
128-endif()
129-
130 if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
131 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
132 endif()
133@@ -250,6 +245,8 @@ macro(ie_add_sample)
134 add_cpplint_target(${IE_SAMPLE_NAME}_cpplint FOR_TARGETS ${IE_SAMPLE_NAME}
135 CUSTOM_FILTERS ${custom_filters})
136 endif()
137+
138+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin)
139 endmacro()
140
141 # collect all samples subdirectories
142diff --git a/inference-engine/samples/common/format_reader/CMakeLists.txt b/inference-engine/samples/common/format_reader/CMakeLists.txt
143index 48dbed9f2..76532fd04 100644
144--- a/inference-engine/samples/common/format_reader/CMakeLists.txt
145+++ b/inference-engine/samples/common/format_reader/CMakeLists.txt
146@@ -41,3 +41,5 @@ target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}"
147
148 set_target_properties(${TARGET_NAME} PROPERTIES COMPILE_PDB_NAME ${TARGET_NAME}
149 FOLDER cpp_samples)
150+
151+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
152diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
153index 105e666a3..5c2f70575 100644
154--- a/inference-engine/src/inference_engine/CMakeLists.txt
155+++ b/inference-engine/src/inference_engine/CMakeLists.txt
156@@ -244,8 +244,8 @@ install(TARGETS ${TARGET_NAME}
157 install(FILES "${OpenVINO_BINARY_DIR}/share/ie_parallel.cmake"
158 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig.cmake"
159 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig-version.cmake"
160- DESTINATION ${IE_CPACK_IE_DIR}/share
161+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/InferenceEngine
162 COMPONENT core)
163 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
164- DESTINATION ${IE_CPACK_RUNTIME_PATH}
165+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
166 COMPONENT core)
167diff --git a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
168index aeebe4e04..310eb6231 100644
169--- a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
170+++ b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
171@@ -48,5 +48,5 @@ target_link_libraries(${TARGET_NAME}
172 # install
173
174 install(FILES ${IE_MAIN_SOURCE_DIR}/thirdparty/movidius/mvnc/src/97-myriad-usbboot.rules
175- DESTINATION ${IE_CPACK_IE_DIR}/external
176+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
177 COMPONENT myriad)
178diff --git a/inference-engine/tests/unit/cpu/CMakeLists.txt b/inference-engine/tests/unit/cpu/CMakeLists.txt
179index d7acf8908..be4ae4a76 100644
180--- a/inference-engine/tests/unit/cpu/CMakeLists.txt
181+++ b/inference-engine/tests/unit/cpu/CMakeLists.txt
182@@ -24,4 +24,6 @@ addIeTargetTest(
183 ADD_CPPLINT
184 LABELS
185 CPU
186-)
187\ No newline at end of file
188+)
189+
190+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
191diff --git a/inference-engine/tests/unit/inference_engine/CMakeLists.txt b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
192index e4613f032..5fe9e7089 100644
193--- a/inference-engine/tests/unit/inference_engine/CMakeLists.txt
194+++ b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
195@@ -26,3 +26,5 @@ addIeTargetTest(
196 LABELS
197 IE
198 )
199+
200+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
201diff --git a/inference-engine/tests/unit/vpu/CMakeLists.txt b/inference-engine/tests/unit/vpu/CMakeLists.txt
202index a4106753d..091339e17 100644
203--- a/inference-engine/tests/unit/vpu/CMakeLists.txt
204+++ b/inference-engine/tests/unit/vpu/CMakeLists.txt
205@@ -27,4 +27,6 @@ addIeTargetTest(
206 LABELS
207 VPU
208 MYRIAD
209-)
210\ No newline at end of file
211+)
212+
213+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
214diff --git a/inference-engine/tools/compile_tool/CMakeLists.txt b/inference-engine/tools/compile_tool/CMakeLists.txt
215index 58614d3ce..9dfa068e4 100644
216--- a/inference-engine/tools/compile_tool/CMakeLists.txt
217+++ b/inference-engine/tools/compile_tool/CMakeLists.txt
218@@ -49,7 +49,7 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
219 # install
220
221 install(TARGETS compile_tool
222- RUNTIME DESTINATION deployment_tools/tools/compile_tool
223+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
224 COMPONENT core)
225
226 install(FILES README.md
227--
2282.26.2
229