summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch215
1 files changed, 0 insertions, 215 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
deleted file mode 100644
index ac34fa4f..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
+++ /dev/null
@@ -1,215 +0,0 @@
1From d9adfdc9c802fdb880fb658085854384f90a88c2 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 11 Jun 2020 14:24:04 +0800
4Subject: [PATCH] cmake installation fixes
5
6Make sure that libraries/samples/binaries are installed correctly.
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 CMakeLists.txt | 14 --------------
11 cmake/developer_package.cmake | 10 ++++++----
12 .../ie_bridges/c/samples/common/CMakeLists.txt | 2 ++
13 inference-engine/samples/CMakeLists.txt | 9 +++------
14 .../samples/common/format_reader/CMakeLists.txt | 2 ++
15 .../src/inference_engine/CMakeLists.txt | 4 ++--
16 .../src/vpu/myriad_plugin/CMakeLists.txt | 2 +-
17 inference-engine/tests/unit/cpu/CMakeLists.txt | 4 +++-
18 .../tests/unit/inference_engine/CMakeLists.txt | 2 ++
19 inference-engine/tests/unit/vpu/CMakeLists.txt | 4 +++-
20 10 files changed, 24 insertions(+), 29 deletions(-)
21
22diff --git a/CMakeLists.txt b/CMakeLists.txt
23index 1f981ed25..2c014ca27 100644
24--- a/CMakeLists.txt
25+++ b/CMakeLists.txt
26@@ -121,12 +121,8 @@ add_subdirectory(docs)
27
28 # install setupvars
29
30-ie_cpack_add_component(setupvars REQUIRED)
31
32 if(UNIX)
33- install(PROGRAMS scripts/setupvars/setupvars.sh
34- DESTINATION bin
35- COMPONENT setupvars)
36 elseif(WIN32)
37 install(PROGRAMS scripts/setupvars/setupvars.bat
38 DESTINATION bin
39@@ -136,22 +132,12 @@ endif()
40 # install install_dependencies
41
42 if(UNIX)
43- ie_cpack_add_component(install_dependencies REQUIRED)
44- install(DIRECTORY scripts/install_dependencies/
45- DESTINATION install_dependencies
46- COMPONENT install_dependencies)
47 endif()
48
49 # install files for demo
50
51-ie_cpack_add_component(demo_scripts REQUIRED DEPENDS core)
52
53 if(UNIX)
54- install(DIRECTORY scripts/demo/
55- DESTINATION deployment_tools/demo
56- COMPONENT demo_scripts
57- USE_SOURCE_PERMISSIONS
58- PATTERN *.bat EXCLUDE)
59 elseif(WIN32)
60 install(DIRECTORY scripts/demo/
61 DESTINATION deployment_tools/demo
62diff --git a/cmake/developer_package.cmake b/cmake/developer_package.cmake
63index 5e022244b..6e2cbf44e 100644
64--- a/cmake/developer_package.cmake
65+++ b/cmake/developer_package.cmake
66@@ -10,7 +10,9 @@ list(APPEND CMAKE_MODULE_PATH
67 include(CPackComponent)
68 unset(IE_CPACK_COMPONENTS_ALL CACHE)
69
70-set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
71+if (NOT DEFINED IE_CPACK_IE_DIR)
72+ set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
73+endif()
74
75 # Search packages for the host system instead of packages for the target system
76 # in case of cross compilation these macros should be defined by the toolchain file
77@@ -43,8 +45,8 @@ function(ie_cpack_set_library_dir)
78 set(IE_CPACK_RUNTIME_PATH ${IE_CPACK_IE_DIR}/bin/${ARCH}/${CMAKE_BUILD_TYPE} PARENT_SCOPE)
79 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH}/${CMAKE_BUILD_TYPE} PARENT_SCOPE)
80 else()
81- set(IE_CPACK_LIBRARY_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
82- set(IE_CPACK_RUNTIME_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
83+ set(IE_CPACK_LIBRARY_PATH ${CMAKE_INSTALL_LIBDIR} PARENT_SCOPE)
84+ set(IE_CPACK_RUNTIME_PATH ${CMAKE_INSTALL_BINDIR} PARENT_SCOPE)
85 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
86 endif()
87 endfunction()
88@@ -147,7 +149,7 @@ endif()
89
90 # allow to override default OUTPUT_ROOT root
91 if(NOT DEFINED OUTPUT_ROOT)
92- set(OUTPUT_ROOT ${OpenVINO_MAIN_SOURCE_DIR})
93+ set(OUTPUT_ROOT ${CMAKE_CURRENT_BINARY_DIR})
94 endif()
95
96 # Enable postfixes for Debug/Release builds
97diff --git a/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt b/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt
98index b8d5ddf62..d086478f6 100644
99--- a/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt
100+++ b/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt
101@@ -29,3 +29,5 @@ set_target_properties(${TARGET_NAME} PROPERTIES FOLDER c_samples)
102 if(COMMAND add_cpplint_target)
103 add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
104 endif()
105+
106+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
107diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
108index 594e581b1..4e95a7808 100644
109--- a/inference-engine/samples/CMakeLists.txt
110+++ b/inference-engine/samples/CMakeLists.txt
111@@ -34,7 +34,7 @@ endif()
112
113 if(IE_MAIN_SOURCE_DIR)
114 # in case if samples are built from IE repo
115- set(IE_MAIN_SAMPLES_DIR ${OpenVINO_MAIN_SOURCE_DIR})
116+ set(IE_MAIN_SAMPLES_DIR ${CMAKE_BINARY_DIR})
117 # hint for find_package(InferenceEngine in the samples folder)
118 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}")
119 # hint for find_package(ngraph in the samples folder)
120@@ -118,11 +118,6 @@ set (HAVE_INTTYPES_H 1)
121 set (INTTYPES_FORMAT C99)
122 set (BUILD_TESTING OFF)
123
124-if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/gflags")
125- add_subdirectory(thirdparty/gflags)
126- set_target_properties(gflags_nothreads_static PROPERTIES FOLDER thirdparty)
127-endif()
128-
129 if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
130 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
131 endif()
132@@ -239,6 +234,8 @@ macro(ie_add_sample)
133 add_cpplint_target(${IE_SAMPLE_NAME}_cpplint FOR_TARGETS ${IE_SAMPLE_NAME}
134 CUSTOM_FILTERS ${custom_filters})
135 endif()
136+
137+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin)
138 endmacro()
139
140 # collect all samples subdirectories
141diff --git a/inference-engine/samples/common/format_reader/CMakeLists.txt b/inference-engine/samples/common/format_reader/CMakeLists.txt
142index 48dbed9f2..76532fd04 100644
143--- a/inference-engine/samples/common/format_reader/CMakeLists.txt
144+++ b/inference-engine/samples/common/format_reader/CMakeLists.txt
145@@ -41,3 +41,5 @@ target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}"
146
147 set_target_properties(${TARGET_NAME} PROPERTIES COMPILE_PDB_NAME ${TARGET_NAME}
148 FOLDER cpp_samples)
149+
150+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
151diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
152index 4ae0d5607..b9ee12498 100644
153--- a/inference-engine/src/inference_engine/CMakeLists.txt
154+++ b/inference-engine/src/inference_engine/CMakeLists.txt
155@@ -265,8 +265,8 @@ install(TARGETS ${TARGET_NAME}
156 install(FILES "${OpenVINO_BINARY_DIR}/share/ie_parallel.cmake"
157 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig.cmake"
158 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig-version.cmake"
159- DESTINATION ${IE_CPACK_IE_DIR}/share
160+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/InferenceEngine
161 COMPONENT core)
162 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
163- DESTINATION ${IE_CPACK_RUNTIME_PATH}
164+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
165 COMPONENT core)
166diff --git a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
167index bf30d127c..6ed8c4081 100644
168--- a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
169+++ b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
170@@ -48,5 +48,5 @@ target_link_libraries(${TARGET_NAME}
171 # install
172
173 install(FILES ${IE_MAIN_SOURCE_DIR}/thirdparty/movidius/mvnc/src/97-myriad-usbboot.rules
174- DESTINATION ${IE_CPACK_IE_DIR}/external
175+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
176 COMPONENT myriad)
177diff --git a/inference-engine/tests/unit/cpu/CMakeLists.txt b/inference-engine/tests/unit/cpu/CMakeLists.txt
178index 9ec5ad025..45c62571a 100644
179--- a/inference-engine/tests/unit/cpu/CMakeLists.txt
180+++ b/inference-engine/tests/unit/cpu/CMakeLists.txt
181@@ -22,4 +22,6 @@ addIeTargetTest(
182 ADD_CPPLINT
183 LABELS
184 CPU
185-)
186\ No newline at end of file
187+)
188+
189+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
190diff --git a/inference-engine/tests/unit/inference_engine/CMakeLists.txt b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
191index 3eb21a434..09ba9225a 100644
192--- a/inference-engine/tests/unit/inference_engine/CMakeLists.txt
193+++ b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
194@@ -15,3 +15,5 @@ addIeTargetTest(
195 LABELS
196 IE
197 )
198+
199+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
200diff --git a/inference-engine/tests/unit/vpu/CMakeLists.txt b/inference-engine/tests/unit/vpu/CMakeLists.txt
201index 072103292..117cc9ee1 100644
202--- a/inference-engine/tests/unit/vpu/CMakeLists.txt
203+++ b/inference-engine/tests/unit/vpu/CMakeLists.txt
204@@ -26,4 +26,6 @@ addIeTargetTest(
205 LABELS
206 VPU
207 MYRIAD
208-)
209\ No newline at end of file
210+)
211+
212+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
213--
2142.26.2
215