summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch54
1 files changed, 27 insertions, 27 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch
index 9e2b46fd..f80e45f8 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch
@@ -1,4 +1,4 @@
1From 07772636ef9b7207967395d22a869e204e8f485b Mon Sep 17 00:00:00 2001 1From 5b6c285b5398fd29cc541ccf92e13440537bb5e8 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 11 Apr 2022 11:11:23 +0800 3Date: Mon, 11 Apr 2022 11:11:23 +0800
4Subject: [PATCH] Fix installation of binaries and libraries 4Subject: [PATCH] Fix installation of binaries and libraries
@@ -31,10 +31,10 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
31 19 files changed, 37 insertions(+), 32 deletions(-) 31 19 files changed, 37 insertions(+), 32 deletions(-)
32 32
33diff --git a/CMakeLists.txt b/CMakeLists.txt 33diff --git a/CMakeLists.txt b/CMakeLists.txt
34index fe62c6318..344d9398f 100644 34index beb0214284..c9ffa7fcae 100644
35--- a/CMakeLists.txt 35--- a/CMakeLists.txt
36+++ b/CMakeLists.txt 36+++ b/CMakeLists.txt
37@@ -104,7 +104,7 @@ include(cmake/extra_modules.cmake) 37@@ -106,7 +106,7 @@ include(cmake/extra_modules.cmake)
38 add_subdirectory(docs) 38 add_subdirectory(docs)
39 add_subdirectory(tools) 39 add_subdirectory(tools)
40 add_subdirectory(scripts) 40 add_subdirectory(scripts)
@@ -44,7 +44,7 @@ index fe62c6318..344d9398f 100644
44 # 44 #
45 # CPack 45 # CPack
46diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake 46diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake
47index 39b23fe65..aa638c077 100644 47index 39b23fe655..aa638c0778 100644
48--- a/cmake/developer_package/frontends/frontends.cmake 48--- a/cmake/developer_package/frontends/frontends.cmake
49+++ b/cmake/developer_package/frontends/frontends.cmake 49+++ b/cmake/developer_package/frontends/frontends.cmake
50@@ -2,7 +2,7 @@ 50@@ -2,7 +2,7 @@
@@ -57,7 +57,7 @@ index 39b23fe65..aa638c077 100644
57 set(FRONTEND_NAME_SUFFIX "_frontend") 57 set(FRONTEND_NAME_SUFFIX "_frontend")
58 58
59diff --git a/cmake/developer_package/packaging.cmake b/cmake/developer_package/packaging.cmake 59diff --git a/cmake/developer_package/packaging.cmake b/cmake/developer_package/packaging.cmake
60index cc287ff1f..2daee6611 100644 60index cc287ff1f3..2daee6611e 100644
61--- a/cmake/developer_package/packaging.cmake 61--- a/cmake/developer_package/packaging.cmake
62+++ b/cmake/developer_package/packaging.cmake 62+++ b/cmake/developer_package/packaging.cmake
63@@ -20,8 +20,8 @@ function(ie_cpack_set_library_dir) 63@@ -20,8 +20,8 @@ function(ie_cpack_set_library_dir)
@@ -72,7 +72,7 @@ index cc287ff1f..2daee6611 100644
72 endif() 72 endif()
73 endfunction() 73 endfunction()
74diff --git a/cmake/developer_package/plugins/plugins.cmake b/cmake/developer_package/plugins/plugins.cmake 74diff --git a/cmake/developer_package/plugins/plugins.cmake b/cmake/developer_package/plugins/plugins.cmake
75index a630d6c35..779c43631 100644 75index a630d6c354..779c43631a 100644
76--- a/cmake/developer_package/plugins/plugins.cmake 76--- a/cmake/developer_package/plugins/plugins.cmake
77+++ b/cmake/developer_package/plugins/plugins.cmake 77+++ b/cmake/developer_package/plugins/plugins.cmake
78@@ -138,7 +138,7 @@ function(ie_add_plugin) 78@@ -138,7 +138,7 @@ function(ie_add_plugin)
@@ -85,7 +85,7 @@ index a630d6c35..779c43631 100644
85 else() 85 else()
86 ov_install_static_lib(${IE_PLUGIN_NAME} ${install_component}) 86 ov_install_static_lib(${IE_PLUGIN_NAME} ${install_component})
87diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt 87diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
88index 86b0e8652..4f31d3cc4 100644 88index 86b0e8652b..4f31d3cc4b 100644
89--- a/docs/CMakeLists.txt 89--- a/docs/CMakeLists.txt
90+++ b/docs/CMakeLists.txt 90+++ b/docs/CMakeLists.txt
91@@ -36,9 +36,10 @@ if(NOT ENABLE_DOCKER) 91@@ -36,9 +36,10 @@ if(NOT ENABLE_DOCKER)
@@ -101,7 +101,7 @@ index 86b0e8652..4f31d3cc4 100644
101 endforeach() 101 endforeach()
102 endif() 102 endif()
103diff --git a/samples/CMakeLists.txt b/samples/CMakeLists.txt 103diff --git a/samples/CMakeLists.txt b/samples/CMakeLists.txt
104index 8101b5e32..6abe8c20c 100644 104index 8101b5e328..6abe8c20ce 100644
105--- a/samples/CMakeLists.txt 105--- a/samples/CMakeLists.txt
106+++ b/samples/CMakeLists.txt 106+++ b/samples/CMakeLists.txt
107@@ -9,7 +9,7 @@ add_subdirectory(c) 107@@ -9,7 +9,7 @@ add_subdirectory(c)
@@ -114,7 +114,7 @@ index 8101b5e32..6abe8c20c 100644
114 114
115 openvino_developer_export_targets(COMPONENT openvino_common TARGETS format_reader ie_samples_utils) 115 openvino_developer_export_targets(COMPONENT openvino_common TARGETS format_reader ie_samples_utils)
116diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt 116diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
117index a8e6e5172..aa3d2fe0e 100644 117index 2755579a0f..4a5f5b424f 100644
118--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt 118--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt
119+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt 119+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
120@@ -34,3 +34,5 @@ install( 120@@ -34,3 +34,5 @@ install(
@@ -124,7 +124,7 @@ index a8e6e5172..aa3d2fe0e 100644
124+ 124+
125+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}) 125+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
126diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 126diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
127index 3433dee0e..0c0fa0723 100644 127index 9a73582a73..70c4147f3f 100644
128--- a/samples/cpp/CMakeLists.txt 128--- a/samples/cpp/CMakeLists.txt
129+++ b/samples/cpp/CMakeLists.txt 129+++ b/samples/cpp/CMakeLists.txt
130@@ -222,6 +222,8 @@ macro(ie_add_sample) 130@@ -222,6 +222,8 @@ macro(ie_add_sample)
@@ -137,7 +137,7 @@ index 3433dee0e..0c0fa0723 100644
137 if(NOT TARGET ie_samples) 137 if(NOT TARGET ie_samples)
138 add_custom_target(ie_samples ALL) 138 add_custom_target(ie_samples ALL)
139diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt 139diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
140index 9ad26ba95..0853e2370 100644 140index 9ad26ba952..0853e23706 100644
141--- a/scripts/CMakeLists.txt 141--- a/scripts/CMakeLists.txt
142+++ b/scripts/CMakeLists.txt 142+++ b/scripts/CMakeLists.txt
143@@ -28,7 +28,7 @@ ie_shellcheck_process(DIRECTORY "${OpenVINO_SOURCE_DIR}" 143@@ -28,7 +28,7 @@ ie_shellcheck_process(DIRECTORY "${OpenVINO_SOURCE_DIR}"
@@ -168,7 +168,7 @@ index 9ad26ba95..0853e2370 100644
168 install(DIRECTORY install_dependencies/ 168 install(DIRECTORY install_dependencies/
169 DESTINATION install_dependencies 169 DESTINATION install_dependencies
170diff --git a/src/bindings/c/src/CMakeLists.txt b/src/bindings/c/src/CMakeLists.txt 170diff --git a/src/bindings/c/src/CMakeLists.txt b/src/bindings/c/src/CMakeLists.txt
171index 9200d0bda..b3636e071 100644 171index 9200d0bda1..b3636e0716 100644
172--- a/src/bindings/c/src/CMakeLists.txt 172--- a/src/bindings/c/src/CMakeLists.txt
173+++ b/src/bindings/c/src/CMakeLists.txt 173+++ b/src/bindings/c/src/CMakeLists.txt
174@@ -43,8 +43,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets 174@@ -43,8 +43,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets
@@ -183,7 +183,7 @@ index 9200d0bda..b3636e071 100644
183+ DESTINATION include/ie 183+ DESTINATION include/ie
184 COMPONENT core_c_dev) 184 COMPONENT core_c_dev)
185diff --git a/src/cmake/openvino.cmake b/src/cmake/openvino.cmake 185diff --git a/src/cmake/openvino.cmake b/src/cmake/openvino.cmake
186index c46548468..3d65a20a5 100644 186index ddd016d14e..76db0f9927 100644
187--- a/src/cmake/openvino.cmake 187--- a/src/cmake/openvino.cmake
188+++ b/src/cmake/openvino.cmake 188+++ b/src/cmake/openvino.cmake
189@@ -59,8 +59,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets 189@@ -59,8 +59,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets
@@ -197,7 +197,7 @@ index c46548468..3d65a20a5 100644
197 197
198 # --------------- OpenVINO runtime library dev ------------------------------ 198 # --------------- OpenVINO runtime library dev ------------------------------
199 add_library(${TARGET_NAME}_dev INTERFACE) 199 add_library(${TARGET_NAME}_dev INTERFACE)
200@@ -96,7 +96,7 @@ ie_cpack_add_component(core_dev REQUIRED DEPENDS core ${core_dev_components}) 200@@ -95,7 +95,7 @@ ie_cpack_add_component(core_dev REQUIRED DEPENDS core ${core_dev_components})
201 201
202 if(BUILD_SHARED_LIBS) 202 if(BUILD_SHARED_LIBS)
203 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml 203 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
@@ -206,7 +206,7 @@ index c46548468..3d65a20a5 100644
206 COMPONENT core) 206 COMPONENT core)
207 207
208 # for InferenceEngineUnitTest 208 # for InferenceEngineUnitTest
209@@ -115,7 +115,7 @@ endif() 209@@ -114,7 +114,7 @@ endif()
210 install(EXPORT OpenVINOTargets 210 install(EXPORT OpenVINOTargets
211 FILE OpenVINOTargets.cmake 211 FILE OpenVINOTargets.cmake
212 NAMESPACE openvino:: 212 NAMESPACE openvino::
@@ -214,8 +214,8 @@ index c46548468..3d65a20a5 100644
214+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO 214+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO
215 COMPONENT core_dev) 215 COMPONENT core_dev)
216 216
217 set(OV_CORE_DIR "${CMAKE_BINARY_DIR}/src/core") 217 # Build tree
218@@ -161,10 +161,10 @@ configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cm 218@@ -160,10 +160,10 @@ configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cm
219 install(FILES "${CMAKE_BINARY_DIR}/share/InferenceEngineConfig.cmake" 219 install(FILES "${CMAKE_BINARY_DIR}/share/InferenceEngineConfig.cmake"
220 "${CMAKE_BINARY_DIR}/InferenceEngineConfig-version.cmake" 220 "${CMAKE_BINARY_DIR}/InferenceEngineConfig-version.cmake"
221 "${OpenVINO_SOURCE_DIR}/src/cmake/ie_parallel.cmake" 221 "${OpenVINO_SOURCE_DIR}/src/cmake/ie_parallel.cmake"
@@ -229,7 +229,7 @@ index c46548468..3d65a20a5 100644
229+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO 229+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO
230 COMPONENT core_dev) 230 COMPONENT core_dev)
231diff --git a/src/common/preprocessing/CMakeLists.txt b/src/common/preprocessing/CMakeLists.txt 231diff --git a/src/common/preprocessing/CMakeLists.txt b/src/common/preprocessing/CMakeLists.txt
232index e41e286c9..11aaffca6 100644 232index e41e286c95..11aaffca6a 100644
233--- a/src/common/preprocessing/CMakeLists.txt 233--- a/src/common/preprocessing/CMakeLists.txt
234+++ b/src/common/preprocessing/CMakeLists.txt 234+++ b/src/common/preprocessing/CMakeLists.txt
235@@ -202,7 +202,7 @@ openvino_developer_export_targets(COMPONENT core TARGETS ${TARGET_NAME}) 235@@ -202,7 +202,7 @@ openvino_developer_export_targets(COMPONENT core TARGETS ${TARGET_NAME})
@@ -242,7 +242,7 @@ index e41e286c9..11aaffca6 100644
242 ov_install_static_lib(${TARGET_NAME} core) 242 ov_install_static_lib(${TARGET_NAME} core)
243 endif() 243 endif()
244diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt 244diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
245index cc64b94ca..5f0dcf20c 100644 245index cc64b94ca3..5f0dcf20cf 100644
246--- a/src/core/CMakeLists.txt 246--- a/src/core/CMakeLists.txt
247+++ b/src/core/CMakeLists.txt 247+++ b/src/core/CMakeLists.txt
248@@ -114,7 +114,7 @@ target_include_directories(ngraph INTERFACE $<BUILD_INTERFACE:${OV_CORE_INCLUDE_ 248@@ -114,7 +114,7 @@ target_include_directories(ngraph INTERFACE $<BUILD_INTERFACE:${OV_CORE_INCLUDE_
@@ -262,10 +262,10 @@ index cc64b94ca..5f0dcf20c 100644
262+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph 262+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
263 COMPONENT core_dev) 263 COMPONENT core_dev)
264diff --git a/src/inference/CMakeLists.txt b/src/inference/CMakeLists.txt 264diff --git a/src/inference/CMakeLists.txt b/src/inference/CMakeLists.txt
265index ddd2fdcbc..f4ad1e623 100644 265index 767fbc1b81..f279a2ef7d 100644
266--- a/src/inference/CMakeLists.txt 266--- a/src/inference/CMakeLists.txt
267+++ b/src/inference/CMakeLists.txt 267+++ b/src/inference/CMakeLists.txt
268@@ -204,7 +204,7 @@ set_target_properties(${TARGET_NAME}_obj 268@@ -209,7 +209,7 @@ set_target_properties(${TARGET_NAME}_obj
269 269
270 openvino_developer_export_targets(COMPONENT core_legacy TARGETS ${TARGET_NAME}_plugin_api) 270 openvino_developer_export_targets(COMPONENT core_legacy TARGETS ${TARGET_NAME}_plugin_api)
271 271
@@ -275,7 +275,7 @@ index ddd2fdcbc..f4ad1e623 100644
275 275
276 # Install static libraries for case BUILD_SHARED_LIBS=OFF 276 # Install static libraries for case BUILD_SHARED_LIBS=OFF
277diff --git a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt 277diff --git a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
278index 3993bd973..99287bad5 100644 278index 3993bd9731..99287bad51 100644
279--- a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt 279--- a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
280+++ b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt 280+++ b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
281@@ -94,7 +94,7 @@ add_custom_command( 281@@ -94,7 +94,7 @@ add_custom_command(
@@ -288,7 +288,7 @@ index 3993bd973..99287bad5 100644
288 288
289 ov_install_static_lib(${TARGET_NAME} gpu) 289 ov_install_static_lib(${TARGET_NAME} gpu)
290diff --git a/src/plugins/intel_myriad/myriad_dependencies.cmake b/src/plugins/intel_myriad/myriad_dependencies.cmake 290diff --git a/src/plugins/intel_myriad/myriad_dependencies.cmake b/src/plugins/intel_myriad/myriad_dependencies.cmake
291index 5bba4235f..69c1470a7 100644 291index 5bba4235ff..69c1470a71 100644
292--- a/src/plugins/intel_myriad/myriad_dependencies.cmake 292--- a/src/plugins/intel_myriad/myriad_dependencies.cmake
293+++ b/src/plugins/intel_myriad/myriad_dependencies.cmake 293+++ b/src/plugins/intel_myriad/myriad_dependencies.cmake
294@@ -80,7 +80,7 @@ foreach(firmware_name IN LISTS VPU_SUPPORTED_FIRMWARES) 294@@ -80,7 +80,7 @@ foreach(firmware_name IN LISTS VPU_SUPPORTED_FIRMWARES)
@@ -301,7 +301,7 @@ index 5bba4235f..69c1470a7 100644
301 301
302 if(ENABLE_INTEL_MYRIAD AND ENABLE_BEH_TESTS) 302 if(ENABLE_INTEL_MYRIAD AND ENABLE_BEH_TESTS)
303diff --git a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt 303diff --git a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
304index 12a2f15e4..893146294 100644 304index 12a2f15e4a..893146294c 100644
305--- a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt 305--- a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
306+++ b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt 306+++ b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
307@@ -56,6 +56,6 @@ set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_REL 307@@ -56,6 +56,6 @@ set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_REL
@@ -313,7 +313,7 @@ index 12a2f15e4..893146294 100644
313 COMPONENT myriad) 313 COMPONENT myriad)
314 endif() 314 endif()
315diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt 315diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
316index c8638f7fd..ba30641c5 100644 316index c8638f7fd3..ba30641c5a 100644
317--- a/tools/CMakeLists.txt 317--- a/tools/CMakeLists.txt
318+++ b/tools/CMakeLists.txt 318+++ b/tools/CMakeLists.txt
319@@ -20,7 +20,7 @@ endif() 319@@ -20,7 +20,7 @@ endif()
@@ -326,7 +326,7 @@ index c8638f7fd..ba30641c5 100644
326 USE_SOURCE_PERMISSIONS) 326 USE_SOURCE_PERMISSIONS)
327 327
328diff --git a/tools/compile_tool/CMakeLists.txt b/tools/compile_tool/CMakeLists.txt 328diff --git a/tools/compile_tool/CMakeLists.txt b/tools/compile_tool/CMakeLists.txt
329index d19eb5cc1..9fc929cbb 100644 329index d19eb5cc14..9fc929cbb0 100644
330--- a/tools/compile_tool/CMakeLists.txt 330--- a/tools/compile_tool/CMakeLists.txt
331+++ b/tools/compile_tool/CMakeLists.txt 331+++ b/tools/compile_tool/CMakeLists.txt
332@@ -38,9 +38,9 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME}) 332@@ -38,9 +38,9 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
@@ -344,5 +344,5 @@ index d19eb5cc1..9fc929cbb 100644
344+# DESTINATION tools/compile_tool 344+# DESTINATION tools/compile_tool
345+# COMPONENT core_tools) 345+# COMPONENT core_tools)
346-- 346--
3472.35.1 3472.36.1
348 348