summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cldNN-disable-Werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cldNN-disable-Werror.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cldNN-disable-Werror.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cldNN-disable-Werror.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cldNN-disable-Werror.patch
new file mode 100644
index 00000000..a4e58b8e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cldNN-disable-Werror.patch
@@ -0,0 +1,30 @@
1From 65014a2703a6a3892fdebc86fe1c5a3a589dbf56 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:45:48 +0800
4Subject: [PATCH 2/5] cldNN: disable Werror
5
6Don't treat warnings as errors. This just leads to failures every time
7we upgrade the compiler.
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 inference-engine/thirdparty/clDNN/CMakeLists.txt | 1 -
14 1 file changed, 1 deletion(-)
15
16diff --git a/inference-engine/thirdparty/clDNN/CMakeLists.txt b/inference-engine/thirdparty/clDNN/CMakeLists.txt
17index 4b444eca..8610b9b8 100644
18--- a/inference-engine/thirdparty/clDNN/CMakeLists.txt
19+++ b/inference-engine/thirdparty/clDNN/CMakeLists.txt
20@@ -770,7 +770,6 @@ foreach(__CLDNN_CompilerFlagName IN ITEMS "CMAKE_CXX_FLAGS" "CMAKE_C_FLAGS")
21 MultiProcessorCompilation
22 DeadCodeEliminate
23 ExtensionsEnabled
24- TreatWarnAsErrorEnabled
25 WarnLevel4
26 NoFastMath
27 StackProtector
28--
292.25.4
30