summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch43
1 files changed, 0 insertions, 43 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch
deleted file mode 100644
index 5e7cfb38..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Disable-Werror.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 1a3f315323a0b1d1affed01e85cbbf0a677718e8 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:45:48 +0800
4Subject: [PATCH] Disable Werror
5
6Don't treat warnings as errors. This just leads to failures every time
7we upgrade the compiler.
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 inference-engine/thirdparty/clDNN/CMakeLists.txt | 1 -
14 ngraph/CMakeLists.txt | 1 -
15 2 files changed, 2 deletions(-)
16
17diff --git a/inference-engine/thirdparty/clDNN/CMakeLists.txt b/inference-engine/thirdparty/clDNN/CMakeLists.txt
18index d14da47860..08ed695c0d 100644
19--- a/inference-engine/thirdparty/clDNN/CMakeLists.txt
20+++ b/inference-engine/thirdparty/clDNN/CMakeLists.txt
21@@ -518,7 +518,6 @@ foreach(__CLDNN_CompilerFlagName IN ITEMS "CMAKE_CXX_FLAGS" "CMAKE_C_FLAGS")
22 MultiProcessorCompilation
23 DeadCodeEliminate
24 ExtensionsEnabled
25- TreatWarnAsErrorEnabled
26 WarnLevel4
27 NoFastMath
28 StackProtector
29diff --git a/ngraph/CMakeLists.txt b/ngraph/CMakeLists.txt
30index a05ca3b15c..ae888c4cb2 100644
31--- a/ngraph/CMakeLists.txt
32+++ b/ngraph/CMakeLists.txt
33@@ -197,7 +197,6 @@ if (WIN32)
34 endif()
35
36 if (NOT CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
37- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Werror")
38 endif()
39
40 if(WIN32)
41--
422.32.0
43