summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch200
1 files changed, 55 insertions, 145 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
index bbf186df..1f64ce21 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
@@ -1,42 +1,39 @@
1From 7e2525fbe9a051197d76fe1ceb94b857eae33409 Mon Sep 17 00:00:00 2001 1From a8b6a2e251c42a393218174c6737208760d2e1c1 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:43:55 +0800 3Date: Wed, 10 Jun 2020 09:43:55 +0800
4Subject: [PATCH] inference-engine: use system installed packages 4Subject: [PATCH] inference-engine: use system installed packages
5 5
6Use installed versions of pugixml, ade, protobuf and tbb. 6Use installed versions of ade, protobuf and tbb.
7 7
8Upstream-Status: Pending 8Upstream-Status: Pending
9 9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11--- 11---
12 cmake/dependencies.cmake | 17 -------------- 12 cmake/dependencies.cmake | 18 ------------------
13 inference-engine/CMakeLists.txt | 2 +- 13 inference-engine/CMakeLists.txt | 2 +-
14 inference-engine/cmake/ie_parallel.cmake | 7 +----- 14 inference-engine/cmake/ie_parallel.cmake | 7 +------
15 .../src/inference_engine/CMakeLists.txt | 23 +------------------ 15 .../src/inference_engine/CMakeLists.txt | 19 -------------------
16 .../src/legacy_api/CMakeLists.txt | 3 +-- 16 .../common_test_utils/CMakeLists.txt | 4 +---
17 .../src/vpu/graph_transformer/CMakeLists.txt | 1 -
18 .../common_test_utils/CMakeLists.txt | 7 ++----
19 .../unit_test_utils/CMakeLists.txt | 3 +-- 17 .../unit_test_utils/CMakeLists.txt | 3 +--
20 .../tests_deprecated/helpers/CMakeLists.txt | 1 - 18 inference-engine/thirdparty/CMakeLists.txt | 5 ++---
21 inference-engine/thirdparty/CMakeLists.txt | 14 +---------- 19 7 files changed, 6 insertions(+), 52 deletions(-)
22 10 files changed, 8 insertions(+), 70 deletions(-)
23 20
24diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake 21diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake
25index 2a5a74db6..9cc9a6c94 100644 22index 6a44c8769e..a128eb63a1 100644
26--- a/cmake/dependencies.cmake 23--- a/cmake/dependencies.cmake
27+++ b/cmake/dependencies.cmake 24+++ b/cmake/dependencies.cmake
28@@ -13,25 +13,8 @@ if(CMAKE_CROSSCOMPILING) 25@@ -13,25 +13,7 @@ if(CMAKE_CROSSCOMPILING AND NGRAPH_ONNX_IMPORT_ENABLE)
29 26
30 set(protoc_version "3.7.1") 27 set(protoc_version "3.7.1")
31 if(CMAKE_HOST_SYSTEM_NAME MATCHES Linux) 28 if(CMAKE_HOST_SYSTEM_NAME MATCHES Linux)
32- RESOLVE_DEPENDENCY(SYSTEM_PROTOC_ROOT 29- RESOLVE_DEPENDENCY(SYSTEM_PROTOC_ROOT
33- ARCHIVE_LIN "protoc-${protoc_version}-linux-x86_64.tar.gz" 30- ARCHIVE_LIN "protoc-${protoc_version}-linux-x86_64.tar.gz"
34- TARGET_PATH "${TEMP}/protoc-${protoc_version}-linux-x86_64") 31- TARGET_PATH "${TEMP}/protoc-${protoc_version}-linux-x86_64")
35- debug_message(STATUS "host protoc-${protoc_version} root path = " ${SYSTEM_PROTOC_ROOT}) 32- debug_message(STATUS "host protoc-${protoc_version} root path = " ${SYSTEM_PROTOC_ROOT})
36 else() 33 else()
37 message(FATAL_ERROR "Unsupported host system (${CMAKE_HOST_SYSTEM_NAME}) and arch (${CMAKE_HOST_SYSTEM_PROCESSOR}) for cross-compilation") 34 message(FATAL_ERROR "Unsupported host system (${CMAKE_HOST_SYSTEM_NAME}) and arch (${CMAKE_HOST_SYSTEM_PROCESSOR}) for cross-compilation")
38 endif() 35 endif()
39 36-
40- reset_deps_cache(SYSTEM_PROTOC) 37- reset_deps_cache(SYSTEM_PROTOC)
41- 38-
42- message("${SYSTEM_PROTOC_ROOT}/bin") 39- message("${SYSTEM_PROTOC_ROOT}/bin")
@@ -52,10 +49,10 @@ index 2a5a74db6..9cc9a6c94 100644
52- update_deps_cache(SYSTEM_PROTOC "${SYSTEM_PROTOC}" "Path to host protoc for ONNX Importer") 49- update_deps_cache(SYSTEM_PROTOC "${SYSTEM_PROTOC}" "Path to host protoc for ONNX Importer")
53 endif() 50 endif()
54diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt 51diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt
55index 7f45ab021..db85e8690 100644 52index a3e4f74c40..76b09683dd 100644
56--- a/inference-engine/CMakeLists.txt 53--- a/inference-engine/CMakeLists.txt
57+++ b/inference-engine/CMakeLists.txt 54+++ b/inference-engine/CMakeLists.txt
58@@ -57,7 +57,7 @@ function(ie_developer_export) 55@@ -56,7 +56,7 @@ function(ie_developer_export)
59 APPEND FILE "${CMAKE_BINARY_DIR}/targets_developer.cmake") 56 APPEND FILE "${CMAKE_BINARY_DIR}/targets_developer.cmake")
60 57
61 # Custom target to build only Inference Engine Developer Package targets 58 # Custom target to build only Inference Engine Developer Package targets
@@ -65,10 +62,10 @@ index 7f45ab021..db85e8690 100644
65 endfunction() 62 endfunction()
66 63
67diff --git a/inference-engine/cmake/ie_parallel.cmake b/inference-engine/cmake/ie_parallel.cmake 64diff --git a/inference-engine/cmake/ie_parallel.cmake b/inference-engine/cmake/ie_parallel.cmake
68index 7fd77ccc0..143dcf669 100644 65index f8988aa105..28e79417f4 100644
69--- a/inference-engine/cmake/ie_parallel.cmake 66--- a/inference-engine/cmake/ie_parallel.cmake
70+++ b/inference-engine/cmake/ie_parallel.cmake 67+++ b/inference-engine/cmake/ie_parallel.cmake
71@@ -62,13 +62,8 @@ function(set_ie_threading_interface_for TARGET_NAME) 68@@ -67,13 +67,8 @@ function(set_ie_threading_interface_for TARGET_NAME)
72 set(IE_THREAD_DEFINE "IE_THREAD_SEQ") 69 set(IE_THREAD_DEFINE "IE_THREAD_SEQ")
73 70
74 if (THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO") 71 if (THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO")
@@ -76,37 +73,19 @@ index 7fd77ccc0..143dcf669 100644
76 set(IE_THREAD_DEFINE "IE_THREAD_TBB") 73 set(IE_THREAD_DEFINE "IE_THREAD_TBB")
77- ie_target_link_libraries(${TARGET_NAME} ${LINK_TYPE} ${TBB_IMPORTED_TARGETS}) 74- ie_target_link_libraries(${TARGET_NAME} ${LINK_TYPE} ${TBB_IMPORTED_TARGETS})
78- else () 75- else ()
79- ext_message(WARNING "TBB was not found by the configured TBB_DIR path. \ 76- ext_message(WARNING "TBB was not found by the configured TBB_DIR path.\
80- SEQ method will be used for ${TARGET_NAME}") 77- SEQ method will be used for ${TARGET_NAME}")
81- endif () 78- endif ()
82+ target_link_libraries(${TARGET_NAME} INTERFACE tbb tbbmalloc) 79+ target_link_libraries(${TARGET_NAME} INTERFACE tbb tbbmalloc)
83 elseif (THREADING STREQUAL "OMP") 80 elseif (THREADING STREQUAL "OMP")
84 if (WIN32) 81 if (WIN32)
85 set(omp_lib_name libiomp5md) 82 set(omp_lib_name libiomp5md)
86diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt 83diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
87index 9ab888983..105e666a3 100644 84index f012a038a2..3bba22215e 100644
88--- a/inference-engine/src/inference_engine/CMakeLists.txt 85--- a/inference-engine/src/inference_engine/CMakeLists.txt
89+++ b/inference-engine/src/inference_engine/CMakeLists.txt 86+++ b/inference-engine/src/inference_engine/CMakeLists.txt
90@@ -127,7 +127,6 @@ target_include_directories(${TARGET_NAME}_common_obj PRIVATE 87@@ -216,25 +216,6 @@ list(APPEND core_components ngraph)
91 $<TARGET_PROPERTY:${TARGET_NAME}_plugin_api,INTERFACE_INCLUDE_DIRECTORIES>) 88 if((THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO") AND TBBROOT MATCHES ${TEMP})
92
93 target_include_directories(${TARGET_NAME}_common_obj SYSTEM PRIVATE
94- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>
95 $<TARGET_PROPERTY:ngraph::ngraph,INTERFACE_INCLUDE_DIRECTORIES>)
96
97 # Create object library
98@@ -139,8 +138,7 @@ add_library(${TARGET_NAME}_obj OBJECT
99
100 target_compile_definitions(${TARGET_NAME}_obj PRIVATE IMPLEMENT_INFERENCE_ENGINE_API)
101
102-target_include_directories(${TARGET_NAME}_obj SYSTEM PRIVATE $<TARGET_PROPERTY:ngraph::ngraph,INTERFACE_INCLUDE_DIRECTORIES>
103- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>)
104+target_include_directories(${TARGET_NAME}_obj SYSTEM PRIVATE $<TARGET_PROPERTY:ngraph::ngraph,INTERFACE_INCLUDE_DIRECTORIES>)
105
106 target_include_directories(${TARGET_NAME}_obj PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}"
107 "${IE_MAIN_SOURCE_DIR}/src/readers/ir_reader" # for ie_ir_version.hpp
108@@ -233,25 +231,6 @@ list(APPEND core_components ngraph)
109 if(THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO")
110 ie_cpack_add_component(tbb REQUIRED) 89 ie_cpack_add_component(tbb REQUIRED)
111 list(APPEND core_components tbb) 90 list(APPEND core_components tbb)
112- 91-
@@ -131,37 +110,11 @@ index 9ab888983..105e666a3 100644
131 endif() 110 endif()
132 111
133 ie_cpack_add_component(core REQUIRED DEPENDS ${core_components}) 112 ie_cpack_add_component(core REQUIRED DEPENDS ${core_components})
134diff --git a/inference-engine/src/legacy_api/CMakeLists.txt b/inference-engine/src/legacy_api/CMakeLists.txt
135index ed87a073a..adc970a09 100644
136--- a/inference-engine/src/legacy_api/CMakeLists.txt
137+++ b/inference-engine/src/legacy_api/CMakeLists.txt
138@@ -39,8 +39,7 @@ target_include_directories(${TARGET_NAME}_obj PRIVATE
139 ${IE_MAIN_SOURCE_DIR}/src/inference_engine # For CNNNetworkNGraphImpl
140 $<TARGET_PROPERTY:inference_engine_transformations,INTERFACE_INCLUDE_DIRECTORIES>
141 $<TARGET_PROPERTY:inference_engine_plugin_api,INTERFACE_INCLUDE_DIRECTORIES>
142- $<TARGET_PROPERTY:ngraph::ngraph,INTERFACE_INCLUDE_DIRECTORIES>
143- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>)
144+ $<TARGET_PROPERTY:ngraph::ngraph,INTERFACE_INCLUDE_DIRECTORIES>)
145
146 # Create shared library
147
148diff --git a/inference-engine/src/vpu/graph_transformer/CMakeLists.txt b/inference-engine/src/vpu/graph_transformer/CMakeLists.txt
149index a45437453..7a67a8226 100644
150--- a/inference-engine/src/vpu/graph_transformer/CMakeLists.txt
151+++ b/inference-engine/src/vpu/graph_transformer/CMakeLists.txt
152@@ -35,7 +35,6 @@ function(add_graph_transformer_target TARGET_NAME STATIC_IE)
153
154 target_include_directories(${TARGET_NAME}
155 SYSTEM PUBLIC
156- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>
157 $<TARGET_PROPERTY:inference_engine_plugin_api,INTERFACE_INCLUDE_DIRECTORIES>
158 "${IE_MAIN_SOURCE_DIR}/thirdparty/movidius/mvnc/include")
159
160diff --git a/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt b/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt 113diff --git a/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt b/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
161index efead7271..732abee2d 100644 114index ca58264bd5..11df150845 100644
162--- a/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt 115--- a/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
163+++ b/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt 116+++ b/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
164@@ -23,7 +23,7 @@ function(add_gtest_libraries) 117@@ -26,7 +26,7 @@ function(add_gtest_libraries)
165 PROPERTIES FOLDER thirdparty) 118 PROPERTIES FOLDER thirdparty)
166 endfunction() 119 endfunction()
167 120
@@ -170,93 +123,50 @@ index efead7271..732abee2d 100644
170 123
171 if (MSVC) 124 if (MSVC)
172 set(PUGI pugixml_mt) 125 set(PUGI pugixml_mt)
173@@ -32,10 +32,7 @@ else () 126@@ -37,8 +37,6 @@ endif ()
174 endif ()
175
176 list(APPEND EXPORT_DEPENDENCIES 127 list(APPEND EXPORT_DEPENDENCIES
177- ${PUGI} 128 ${PUGI}
178 ${NGRAPH_LIBRARIES} 129 ${NGRAPH_LIBRARIES}
179- gtest 130- gtest
180- gtest_main 131- gtest_main
181 ) 132 )
182 133
183 set(TARGET_NAME commonTestUtils) 134 set(TARGET_NAME commonTestUtils)
184@@ -74,7 +71,6 @@ function(add_common_utils ADD_TARGET_NAME)
185 PUBLIC
186 ${IE_TESTS_ROOT}/ie_test_utils
187 $<TARGET_PROPERTY:inference_engine,INTERFACE_INCLUDE_DIRECTORIES>
188- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>
189 PRIVATE
190 $<TARGET_PROPERTY:inference_engine_plugin_api,INTERFACE_INCLUDE_DIRECTORIES>
191 )
192@@ -84,6 +80,7 @@ function(add_common_utils ADD_TARGET_NAME)
193 target_link_libraries(${ADD_TARGET_NAME}
194 PUBLIC
195 ${EXPORT_DEPENDENCIES}
196+ pugixml
197 )
198 endfunction()
199
200diff --git a/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt b/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt 135diff --git a/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt b/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
201index dbb0f4e5b..9586d651d 100644 136index 5413d13895..3f2803750f 100644
202--- a/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt 137--- a/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
203+++ b/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt 138+++ b/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
204@@ -9,8 +9,7 @@ add_subdirectory(mocks/mock_engine) 139@@ -8,8 +8,7 @@ add_subdirectory(mocks/mock_engine)
140
205 list(APPEND EXPORT_DEPENDENCIES 141 list(APPEND EXPORT_DEPENDENCIES
206 commonTestUtils_s 142 commonTestUtils_s
207 inference_engine_s 143- inference_engine_s
208- inference_engine_lp_transformations
209- gmock) 144- gmock)
210+ inference_engine_lp_transformations) 145+ inference_engine_s)
211 146
212 addIeTarget( 147 addIeTarget(
213 NAME ${TARGET_NAME} 148 NAME ${TARGET_NAME}
214diff --git a/inference-engine/tests_deprecated/helpers/CMakeLists.txt b/inference-engine/tests_deprecated/helpers/CMakeLists.txt
215index 2bc668965..e44ab9d5d 100644
216--- a/inference-engine/tests_deprecated/helpers/CMakeLists.txt
217+++ b/inference-engine/tests_deprecated/helpers/CMakeLists.txt
218@@ -22,7 +22,6 @@ function(add_helpers target_name)
219 target_include_directories(${target_name} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}"
220 "${IE_MAIN_SOURCE_DIR}/src/inference_engine"
221 $<TARGET_PROPERTY:inference_engine_lp_transformations,INTERFACE_INCLUDE_DIRECTORIES>
222- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>
223 "${IE_MAIN_SOURCE_DIR}/src/vpu/"
224 PRIVATE "${CMAKE_CURRENT_BINARY_DIR}")
225
226diff --git a/inference-engine/thirdparty/CMakeLists.txt b/inference-engine/thirdparty/CMakeLists.txt 149diff --git a/inference-engine/thirdparty/CMakeLists.txt b/inference-engine/thirdparty/CMakeLists.txt
227index a2550bfaa..0eb616415 100644 150index fa2a4d02d8..67d3b7ad05 100644
228--- a/inference-engine/thirdparty/CMakeLists.txt 151--- a/inference-engine/thirdparty/CMakeLists.txt
229+++ b/inference-engine/thirdparty/CMakeLists.txt 152+++ b/inference-engine/thirdparty/CMakeLists.txt
230@@ -51,28 +51,16 @@ function(build_with_lto) 153@@ -62,14 +62,13 @@ else()
231 function(ie_build_pugixml) 154 endif()
232 set(BUILD_TESTS_current ${BUILD_TESTS})
233 set(BUILD_TESTS OFF CACHE BOOL "Build tests" FORCE)
234- add_subdirectory(pugixml)
235 set(BUILD_TESTS ${BUILD_TESTS_current} CACHE BOOL "Build tests" FORCE)
236 endfunction()
237 155
238 ie_build_pugixml() 156 add_subdirectory(stb_lib)
239 add_subdirectory(stb_lib) 157-add_subdirectory(ade)
240- add_subdirectory(ade) 158 add_subdirectory(fluid/modules/gapi)
241 add_subdirectory(fluid/modules/gapi)
242 159
243- target_include_directories(pugixml INTERFACE "$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/pugixml/src>") 160-set_target_properties(ade fluid stb_image PROPERTIES FOLDER thirdparty)
244- 161+set_target_properties(fluid stb_image PROPERTIES FOLDER thirdparty)
245- set_target_properties(pugixml ade fluid stb_image
246+ set_target_properties(fluid stb_image
247 PROPERTIES FOLDER thirdparty)
248 162
249- # developer package 163 # developer package
250- 164
251- ie_developer_export_targets(ade fluid pugixml) 165-ie_developer_export_targets(ade fluid)
252- if(TARGET pugixml_mt) 166+ie_developer_export_targets(fluid)
253- ie_developer_export_targets(pugixml_mt) 167
254- set_target_properties(pugixml_mt PROPERTIES FOLDER thirdparty) 168 if (NOT USE_SYSTEM_PUGIXML)
255- endif() 169 set_target_properties(pugixml PROPERTIES FOLDER thirdparty)
256-
257 if(ENABLE_MKL_DNN)
258 set(SDL_cmake_included ON)
259 include(mkldnn.cmake)
260-- 170--
2612.26.2 1712.29.2
262 172