summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch333
1 files changed, 0 insertions, 333 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
deleted file mode 100644
index b16135ee..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
+++ /dev/null
@@ -1,333 +0,0 @@
1From 47ff7f056d219a8a9f02a8b533e1d32972b84589 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 8 Apr 2021 14:19:51 +0800
4Subject: [PATCH] inference-engine: use system installed packages
5
6Use installed versions of ade, protobuf, zlib and tbb.
7
8Don't fetch pybind11 at runtime and use the one that we have fetched while
9running do_fetch.
10
11Upstream-Status: Inappropriate
12
13Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
14---
15 cmake/dependencies.cmake | 19 --------
16 inference-engine/CMakeLists.txt | 6 +--
17 inference-engine/cmake/dependencies.cmake | 45 -------------------
18 inference-engine/cmake/ie_parallel.cmake | 2 +-
19 .../templates/InferenceEngineConfig.cmake.in | 10 -----
20 inference-engine/samples/CMakeLists.txt | 3 +-
21 .../src/inference_engine/CMakeLists.txt | 4 +-
22 .../common_test_utils/CMakeLists.txt | 4 +-
23 .../unit_test_utils/CMakeLists.txt | 3 +-
24 inference-engine/thirdparty/CMakeLists.txt | 5 +--
25 ngraph/python/CMakeLists.txt | 12 +----
26 tests/fuzz/src/CMakeLists.txt | 1 -
27 thirdparty/CMakeLists.txt | 1 -
28 thirdparty/cnpy/CMakeLists.txt | 4 +-
29 14 files changed, 14 insertions(+), 105 deletions(-)
30
31diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake
32index 6cb15a077e..74d4ac4124 100644
33--- a/cmake/dependencies.cmake
34+++ b/cmake/dependencies.cmake
35@@ -7,23 +7,4 @@ set_temp_directory(TEMP "${IE_MAIN_SOURCE_DIR}")
36 if(CMAKE_CROSSCOMPILING AND CMAKE_HOST_SYSTEM_NAME MATCHES Linux AND CMAKE_HOST_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*")
37 set(protoc_version "3.7.1")
38
39- RESOLVE_DEPENDENCY(SYSTEM_PROTOC_ROOT
40- ARCHIVE_LIN "protoc-${protoc_version}-linux-x86_64.tar.gz"
41- TARGET_PATH "${TEMP}/protoc-${protoc_version}-linux-x86_64"
42- SHA256 "a1bedd5c05ca51e49f8f254faa3d7331e05b3a806c151fb111d582f154d0fee8"
43- )
44- debug_message(STATUS "host protoc-${protoc_version} root path = " ${SYSTEM_PROTOC_ROOT})
45-
46- reset_deps_cache(SYSTEM_PROTOC)
47-
48- find_program(
49- SYSTEM_PROTOC
50- NAMES protoc
51- PATHS "${SYSTEM_PROTOC_ROOT}/bin"
52- NO_DEFAULT_PATH)
53- if(NOT SYSTEM_PROTOC)
54- message(FATAL_ERROR "[ONNX IMPORTER] Missing host protoc binary")
55- endif()
56-
57- update_deps_cache(SYSTEM_PROTOC "${SYSTEM_PROTOC}" "Path to host protoc for ONNX Importer")
58 endif()
59diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt
60index 1ac7fd8bf6..0615873110 100644
61--- a/inference-engine/CMakeLists.txt
62+++ b/inference-engine/CMakeLists.txt
63@@ -18,7 +18,7 @@ function(ie_developer_export_targets)
64 endfunction()
65
66 function(ie_developer_export)
67- set(all_dev_targets gflags ie_libraries)
68+ set(all_dev_targets ie_libraries)
69 foreach(component IN LISTS openvino_export_components)
70 export(TARGETS ${${component}} NAMESPACE IE::
71 APPEND FILE "${CMAKE_BINARY_DIR}/${component}_dev_targets.cmake")
72@@ -142,7 +142,7 @@ endif()
73 # Developer package
74 #
75
76-openvino_developer_export_targets(COMPONENT openvino_common TARGETS format_reader gflags ie_samples_utils)
77+openvino_developer_export_targets(COMPONENT openvino_common TARGETS format_reader ie_samples_utils)
78
79 # for Template plugin
80 if(NGRAPH_INTERPRETER_ENABLE)
81@@ -158,7 +158,7 @@ function(ie_generate_dev_package_config)
82 configure_package_config_file("${InferenceEngine_SOURCE_DIR}/cmake/templates/InferenceEngineDeveloperPackageConfig.cmake.in"
83 "${CMAKE_BINARY_DIR}/InferenceEngineDeveloperPackageConfig.cmake"
84 INSTALL_DESTINATION share # not used
85- PATH_VARS "OpenVINO_MAIN_SOURCE_DIR;IE_MAIN_SOURCE_DIR;gflags_BINARY_DIR"
86+ PATH_VARS "OpenVINO_MAIN_SOURCE_DIR;IE_MAIN_SOURCE_DIR"
87 NO_CHECK_REQUIRED_COMPONENTS_MACRO)
88
89 configure_file("${IE_MAIN_SOURCE_DIR}/cmake/templates/InferenceEngineConfig-version.cmake.in"
90diff --git a/inference-engine/cmake/dependencies.cmake b/inference-engine/cmake/dependencies.cmake
91index b270c46f2d..5f85197a85 100644
92--- a/inference-engine/cmake/dependencies.cmake
93+++ b/inference-engine/cmake/dependencies.cmake
94@@ -81,51 +81,6 @@ endif ()
95 if (THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO")
96 reset_deps_cache(TBBROOT TBB_DIR)
97
98- if (WIN32 AND X86_64)
99- #TODO: add target_path to be platform specific as well, to avoid following if
100- RESOLVE_DEPENDENCY(TBB
101- ARCHIVE_WIN "tbb2020_20200415_win.zip"
102- TARGET_PATH "${TEMP}/tbb"
103- ENVIRONMENT "TBBROOT"
104- SHA256 "f1c9b9e2861efdaa01552bd25312ccbc5feeb45551e5f91ae61e29221c5c1479")
105- RESOLVE_DEPENDENCY(TBBBIND_2_4
106- ARCHIVE_WIN "tbbbind_2_4_static_win_v2.zip"
107- TARGET_PATH "${TEMP}/tbbbind_2_4"
108- ENVIRONMENT "TBBBIND_2_4_ROOT"
109- SHA256 "90dc165652f6ac2ed3014c71e57f797fcc4b11e1498a468e3d2c85deb2a4186a")
110- elseif(ANDROID) # Should be before LINUX due LINUX is detected as well
111- RESOLVE_DEPENDENCY(TBB
112- ARCHIVE_ANDROID "tbb2020_20200404_android.tgz"
113- TARGET_PATH "${TEMP}/tbb"
114- ENVIRONMENT "TBBROOT"
115- SHA256 "f42d084224cc2d643314bd483ad180b081774608844000f132859fca3e9bf0ce")
116- elseif(LINUX AND X86_64)
117- RESOLVE_DEPENDENCY(TBB
118- ARCHIVE_LIN "tbb2020_20200415_lin_strip.tgz"
119- TARGET_PATH "${TEMP}/tbb"
120- ENVIRONMENT "TBBROOT"
121- SHA256 "95b2f3b0b70c7376a0c7de351a355c2c514b42c4966e77e3e34271a599501008")
122- RESOLVE_DEPENDENCY(TBBBIND_2_4
123- ARCHIVE_LIN "tbbbind_2_4_static_lin_v2.tgz"
124- TARGET_PATH "${TEMP}/tbbbind_2_4"
125- ENVIRONMENT "TBBBIND_2_4_ROOT"
126- SHA256 "6dc926258c6cd3cba0f5c2cc672fd2ad599a1650fe95ab11122e8f361a726cb6")
127- elseif(LINUX AND AARCH64)
128- RESOLVE_DEPENDENCY(TBB
129- ARCHIVE_LIN "keembay/tbb2020_38404_kmb_lic.tgz"
130- TARGET_PATH "${TEMP}/tbb_yocto"
131- ENVIRONMENT "TBBROOT"
132- SHA256 "321261ff2eda6d4568a473cb883262bce77a93dac599f7bd65d2918bdee4d75b")
133- elseif(APPLE AND X86_64)
134- RESOLVE_DEPENDENCY(TBB
135- ARCHIVE_MAC "tbb2020_20200404_mac.tgz"
136- TARGET_PATH "${TEMP}/tbb"
137- ENVIRONMENT "TBBROOT"
138- SHA256 "ad9cf52e657660058aa6c6844914bc0fc66241fec89a392d8b79a7ff69c3c7f6")
139- else()
140- message(FATAL_ERROR "TBB is not available on current platform")
141- endif()
142-
143 update_deps_cache(TBBROOT "${TBB}" "Path to TBB root folder")
144 update_deps_cache(TBB_DIR "${TBB}/cmake" "Path to TBB cmake folder")
145
146diff --git a/inference-engine/cmake/ie_parallel.cmake b/inference-engine/cmake/ie_parallel.cmake
147index edf3d2f2b2..6579d0f7ea 100644
148--- a/inference-engine/cmake/ie_parallel.cmake
149+++ b/inference-engine/cmake/ie_parallel.cmake
150@@ -26,7 +26,7 @@ function(set_ie_threading_interface_for TARGET_NAME)
151 find_dependency(TBB COMPONENTS tbb tbbmalloc)
152 endif()
153 set(TBB_FOUND ${TBB_FOUND} PARENT_SCOPE)
154- set(TBB_IMPORTED_TARGETS ${TBB_IMPORTED_TARGETS} PARENT_SCOPE)
155+ set(TBB_IMPORTED_TARGETS "tbb;tbbmalloc" PARENT_SCOPE)
156 set(TBB_VERSION ${TBB_VERSION} PARENT_SCOPE)
157 if (NOT TBB_FOUND)
158 ext_message(WARNING "TBB was not found by the configured TBB_DIR/TBBROOT path.\
159diff --git a/inference-engine/cmake/templates/InferenceEngineConfig.cmake.in b/inference-engine/cmake/templates/InferenceEngineConfig.cmake.in
160index 261edbf3d7..bf217a789a 100644
161--- a/inference-engine/cmake/templates/InferenceEngineConfig.cmake.in
162+++ b/inference-engine/cmake/templates/InferenceEngineConfig.cmake.in
163@@ -86,16 +86,6 @@ endfunction()
164 set(IE_PACKAGE_PREFIX_DIR "${PACKAGE_PREFIX_DIR}")
165
166 set(THREADING "@THREADING@")
167-if(THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO" AND NOT TBB_FOUND)
168- set_and_check(_tbb_dir "@PACKAGE_IE_TBB_DIR@")
169- _ie_find_dependency(TBB
170- COMPONENTS tbb tbbmalloc
171- CONFIG
172- PATHS ${TBBROOT}/cmake
173- ${_tbb_dir}
174- NO_CMAKE_FIND_ROOT_PATH
175- NO_DEFAULT_PATH)
176-endif()
177
178 set_and_check(_ngraph_dir "@PACKAGE_IE_NGRAPH_DIR@")
179 _ie_find_dependency(ngraph
180diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
181index 7924c56779..ae93857944 100644
182--- a/inference-engine/samples/CMakeLists.txt
183+++ b/inference-engine/samples/CMakeLists.txt
184@@ -126,11 +126,10 @@ if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/gflags")
185 add_subdirectory(thirdparty/gflags EXCLUDE_FROM_ALL)
186 set_target_properties(gflags_nothreads_static PROPERTIES FOLDER thirdparty)
187 endfunction()
188- add_gflags()
189+ #add_gflags()
190 endif()
191
192 if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/zlib")
193- add_subdirectory(thirdparty/zlib EXCLUDE_FROM_ALL)
194 endif()
195
196 if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/cnpy")
197diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
198index e8ed1a5c4c..2fcb0bed4a 100644
199--- a/inference-engine/src/inference_engine/CMakeLists.txt
200+++ b/inference-engine/src/inference_engine/CMakeLists.txt
201@@ -290,8 +290,8 @@ configure_package_config_file("${InferenceEngine_SOURCE_DIR}/cmake/templates/Inf
202 INSTALL_DESTINATION "${CMAKE_INSTALL_PREFIX}"
203 PATH_VARS ${PATH_VARS})
204
205-set(IE_INCLUDE_DIR "include")
206-set(IE_NGRAPH_DIR "../ngraph/cmake")
207+set(IE_INCLUDE_DIR "../../include")
208+set(IE_NGRAPH_DIR "ngraph")
209 set(IE_TBB_DIR "${IE_TBB_DIR_INSTALL}")
210 set(IE_PARALLEL_CMAKE "share/ie_parallel.cmake")
211
212diff --git a/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt b/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
213index 5e8643dc5d..031557efc3 100644
214--- a/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
215+++ b/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
216@@ -43,7 +43,7 @@ function(add_gtest_libraries)
217 PROPERTIES FOLDER thirdparty)
218 endfunction()
219
220-add_gtest_libraries()
221+#add_gtest_libraries()
222
223 if (MSVC)
224 set(PUGI pugixml_mt)
225@@ -52,8 +52,6 @@ else ()
226 endif ()
227
228 list(APPEND EXPORT_DEPENDENCIES
229- gtest
230- gtest_main
231 )
232
233 set(TARGET_NAME commonTestUtils)
234diff --git a/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt b/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
235index 7c1d89eabf..2fbd8fc324 100644
236--- a/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
237+++ b/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
238@@ -8,8 +8,7 @@ add_subdirectory(mocks/mock_engine)
239
240 list(APPEND EXPORT_DEPENDENCIES
241 commonTestUtils_s
242- inference_engine_s
243- gmock)
244+ inference_engine_s)
245
246 addIeTarget(
247 NAME ${TARGET_NAME}
248diff --git a/inference-engine/thirdparty/CMakeLists.txt b/inference-engine/thirdparty/CMakeLists.txt
249index f028ebdd8a..9c5bd53466 100644
250--- a/inference-engine/thirdparty/CMakeLists.txt
251+++ b/inference-engine/thirdparty/CMakeLists.txt
252@@ -62,14 +62,13 @@ else()
253 target_include_directories(pugixml INTERFACE "$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/pugixml/src>")
254 endif()
255
256-add_subdirectory(ade EXCLUDE_FROM_ALL)
257 add_subdirectory(fluid/modules/gapi)
258
259-set_target_properties(ade fluid PROPERTIES FOLDER thirdparty)
260+set_target_properties(fluid PROPERTIES FOLDER thirdparty)
261
262 # developer package
263
264-openvino_developer_export_targets(COMPONENT openvino_common TARGETS ade fluid)
265+openvino_developer_export_targets(COMPONENT openvino_common TARGETS fluid)
266
267 if (NOT USE_SYSTEM_PUGIXML)
268 set_target_properties(pugixml PROPERTIES FOLDER thirdparty)
269diff --git a/ngraph/python/CMakeLists.txt b/ngraph/python/CMakeLists.txt
270index 501bfffb4b..b45612c19c 100644
271--- a/ngraph/python/CMakeLists.txt
272+++ b/ngraph/python/CMakeLists.txt
273@@ -17,17 +17,7 @@ endif()
274
275 include(FetchContent)
276
277-FetchContent_Declare(
278- pybind11
279- GIT_REPOSITORY "https://github.com/pybind/pybind11.git"
280- GIT_TAG "v2.5.0"
281-)
282-
283-FetchContent_GetProperties(pybind11)
284-if(NOT pybind11_POPULATED)
285- FetchContent_Populate(pybind11)
286- add_subdirectory(${pybind11_SOURCE_DIR} ${pybind11_BINARY_DIR})
287-endif()
288+add_subdirectory(pybind11)
289
290 # PYTHON_VERSION_MAJOR and PYTHON_VERSION_MINOR are defined inside pybind11
291 set(PYTHON_VERSION python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR})
292diff --git a/tests/fuzz/src/CMakeLists.txt b/tests/fuzz/src/CMakeLists.txt
293index b9400d9e7e..669938526c 100644
294--- a/tests/fuzz/src/CMakeLists.txt
295+++ b/tests/fuzz/src/CMakeLists.txt
296@@ -10,7 +10,6 @@ add_custom_target(fuzz)
297 FILE(GLOB tests "*-fuzzer.cc")
298
299 add_subdirectory(../../../thirdparty/cnpy ${CMAKE_CURRENT_BINARY_DIR}/cnpy)
300-add_subdirectory(../../../thirdparty/zlib ${CMAKE_CURRENT_BINARY_DIR}/zlib)
301
302 foreach(test_source ${tests})
303 get_filename_component(test_name ${test_source} NAME_WE)
304diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
305index 2c6b656408..4e86bd21ef 100644
306--- a/thirdparty/CMakeLists.txt
307+++ b/thirdparty/CMakeLists.txt
308@@ -5,6 +5,5 @@
309 add_subdirectory(ittapi)
310 add_subdirectory(itt_collector)
311 add_subdirectory(xbyak EXCLUDE_FROM_ALL)
312-add_subdirectory(zlib EXCLUDE_FROM_ALL)
313 add_subdirectory(cnpy EXCLUDE_FROM_ALL)
314 openvino_developer_export_targets(COMPONENT openvino_common TARGETS xbyak)
315diff --git a/thirdparty/cnpy/CMakeLists.txt b/thirdparty/cnpy/CMakeLists.txt
316index 5571cd5f78..e30604927a 100644
317--- a/thirdparty/cnpy/CMakeLists.txt
318+++ b/thirdparty/cnpy/CMakeLists.txt
319@@ -14,8 +14,8 @@ if(NOT ${CMAKE_CXX_COMPILER_ID} STREQUAL "MSVC")
320 target_compile_options(${TARGET_NAME} PUBLIC -Wno-unused-variable)
321 endif()
322
323-target_link_libraries(${TARGET_NAME} PUBLIC zlib)
324+target_link_libraries(${TARGET_NAME} PUBLIC z)
325 target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}"
326 "${CMAKE_CURRENT_SOURCE_DIR}/..")
327
328-set_target_properties(cnpy PROPERTIES FOLDER thirdparty)
329\ No newline at end of file
330+set_target_properties(cnpy PROPERTIES FOLDER thirdparty)
331--
3322.32.0
333