summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch256
1 files changed, 0 insertions, 256 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
deleted file mode 100644
index 3fff5607..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
+++ /dev/null
@@ -1,256 +0,0 @@
1From cc44429f0e55efa0fa142cc043e83123e3b376e4 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:43:55 +0800
4Subject: [PATCH] inference-engine: use system installed packages
5
6Use installed versions of pugixml, ade, protobuf and tbb.
7
8Upstream-Status: Pending
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 cmake/dependencies.cmake | 17 --------------
13 inference-engine/CMakeLists.txt | 2 +-
14 inference-engine/cmake/ie_parallel.cmake | 10 ++-------
15 .../src/inference_engine/CMakeLists.txt | 22 +------------------
16 .../src/legacy_api/CMakeLists.txt | 3 +--
17 .../src/vpu/graph_transformer/CMakeLists.txt | 1 -
18 .../common_test_utils/CMakeLists.txt | 7 ++----
19 .../unit_test_utils/CMakeLists.txt | 3 +--
20 .../tests_deprecated/helpers/CMakeLists.txt | 1 -
21 inference-engine/thirdparty/CMakeLists.txt | 14 +-----------
22 10 files changed, 9 insertions(+), 71 deletions(-)
23
24diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake
25index 2a5a74db6..9cc9a6c94 100644
26--- a/cmake/dependencies.cmake
27+++ b/cmake/dependencies.cmake
28@@ -13,25 +13,8 @@ if(CMAKE_CROSSCOMPILING)
29
30 set(protoc_version "3.7.1")
31 if(CMAKE_HOST_SYSTEM_NAME MATCHES Linux)
32- RESOLVE_DEPENDENCY(SYSTEM_PROTOC_ROOT
33- ARCHIVE_LIN "protoc-${protoc_version}-linux-x86_64.tar.gz"
34- TARGET_PATH "${TEMP}/protoc-${protoc_version}-linux-x86_64")
35- debug_message(STATUS "host protoc-${protoc_version} root path = " ${SYSTEM_PROTOC_ROOT})
36 else()
37 message(FATAL_ERROR "Unsupported host system (${CMAKE_HOST_SYSTEM_NAME}) and arch (${CMAKE_HOST_SYSTEM_PROCESSOR}) for cross-compilation")
38 endif()
39
40- reset_deps_cache(SYSTEM_PROTOC)
41-
42- message("${SYSTEM_PROTOC_ROOT}/bin")
43- find_program(
44- SYSTEM_PROTOC
45- NAMES protoc
46- PATHS "${SYSTEM_PROTOC_ROOT}/bin"
47- NO_DEFAULT_PATH)
48- if(NOT SYSTEM_PROTOC)
49- message(FATAL_ERROR "[ONNX IMPORTER] Missing host protoc binary")
50- endif()
51-
52- update_deps_cache(SYSTEM_PROTOC "${SYSTEM_PROTOC}" "Path to host protoc for ONNX Importer")
53 endif()
54diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt
55index 39ff413bc..ba8ed354c 100644
56--- a/inference-engine/CMakeLists.txt
57+++ b/inference-engine/CMakeLists.txt
58@@ -54,7 +54,7 @@ function(ie_developer_export)
59 APPEND FILE "${CMAKE_BINARY_DIR}/targets_developer.cmake")
60
61 # Custom target to build only Inference Engine Developer Package targets
62- add_custom_target(ie_dev_targets ALL DEPENDS ${IEDeveloperPackageTargets} gflags)
63+ add_custom_target(ie_dev_targets ALL DEPENDS ${IEDeveloperPackageTargets})
64 endfunction()
65
66 add_subdirectory(thirdparty)
67diff --git a/inference-engine/cmake/ie_parallel.cmake b/inference-engine/cmake/ie_parallel.cmake
68index 0f3c41e0a..b3b2dfdab 100644
69--- a/inference-engine/cmake/ie_parallel.cmake
70+++ b/inference-engine/cmake/ie_parallel.cmake
71@@ -48,14 +48,8 @@ function(set_ie_threading_interface_for TARGET_NAME)
72 set(IE_THREAD_DEFINE "IE_THREAD_SEQ")
73
74 if (THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO")
75- find_package(TBB COMPONENTS tbb tbbmalloc)
76- if (TBB_FOUND)
77- set(IE_THREAD_DEFINE "IE_THREAD_TBB")
78- ie_target_link_libraries(${TARGET_NAME} ${LINK_TYPE} ${TBB_IMPORTED_TARGETS})
79- else ()
80- ext_message(WARNING "TBB was not found by the configured TBB_DIR path. \
81- SEQ method will be used for ${TARGET_NAME}")
82- endif ()
83+ set(IE_THREAD_DEFINE "IE_THREAD_TBB")
84+ target_link_libraries(${TARGET_NAME} INTERFACE tbb tbbmalloc)
85 elseif (THREADING STREQUAL "OMP")
86 if (WIN32)
87 set(omp_lib_name libiomp5md)
88diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
89index 4ae0d5607..4106cf8b4 100644
90--- a/inference-engine/src/inference_engine/CMakeLists.txt
91+++ b/inference-engine/src/inference_engine/CMakeLists.txt
92@@ -124,8 +124,7 @@ if(NGRAPH_ONNX_IMPORT_ENABLE)
93 target_compile_definitions(${TARGET_NAME}_obj PRIVATE ONNX_IMPORT_ENABLE)
94 endif()
95
96-target_include_directories(${TARGET_NAME}_obj SYSTEM PRIVATE $<TARGET_PROPERTY:ngraph::ngraph,INTERFACE_INCLUDE_DIRECTORIES>
97- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>)
98+target_include_directories(${TARGET_NAME}_obj SYSTEM PRIVATE $<TARGET_PROPERTY:ngraph::ngraph,INTERFACE_INCLUDE_DIRECTORIES>)
99
100 target_include_directories(${TARGET_NAME}_obj PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}"
101 $<TARGET_PROPERTY:${TARGET_NAME}_reader_api,INTERFACE_INCLUDE_DIRECTORIES>
102@@ -233,25 +232,6 @@ list(APPEND core_components ngraph)
103 if(THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO")
104 ie_cpack_add_component(tbb REQUIRED)
105 list(APPEND core_components tbb)
106-
107- install(DIRECTORY "${TBB}/include"
108- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
109- COMPONENT tbb)
110- install(DIRECTORY "${TBB}/lib"
111- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
112- COMPONENT tbb)
113- if(EXISTS "${TBB}/bin")
114- install(DIRECTORY "${TBB}/bin"
115- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
116- COMPONENT tbb)
117- endif()
118- install(FILES "${TBB}/LICENSE"
119- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
120- COMPONENT tbb)
121- install(FILES "${TBB}/cmake/TBBConfig.cmake"
122- "${TBB}/cmake/TBBConfigVersion.cmake"
123- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb/cmake
124- COMPONENT tbb)
125 endif()
126
127 ie_cpack_add_component(core REQUIRED DEPENDS ${core_components})
128diff --git a/inference-engine/src/legacy_api/CMakeLists.txt b/inference-engine/src/legacy_api/CMakeLists.txt
129index 85524310b..dc25cae2f 100644
130--- a/inference-engine/src/legacy_api/CMakeLists.txt
131+++ b/inference-engine/src/legacy_api/CMakeLists.txt
132@@ -33,8 +33,7 @@ target_include_directories(${TARGET_NAME}_obj PRIVATE ${PUBLIC_HEADERS_DIR} ${CM
133 ${IE_MAIN_SOURCE_DIR}/src/inference_engine # For CNNNetworkNGraphImpl
134 $<TARGET_PROPERTY:inference_engine_transformations,INTERFACE_INCLUDE_DIRECTORIES>
135 $<TARGET_PROPERTY:inference_engine_plugin_api,INTERFACE_INCLUDE_DIRECTORIES>
136- $<TARGET_PROPERTY:ngraph::ngraph,INTERFACE_INCLUDE_DIRECTORIES>
137- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>)
138+ $<TARGET_PROPERTY:ngraph::ngraph,INTERFACE_INCLUDE_DIRECTORIES>)
139
140 # Create shared library
141
142diff --git a/inference-engine/src/vpu/graph_transformer/CMakeLists.txt b/inference-engine/src/vpu/graph_transformer/CMakeLists.txt
143index 982d3c7fa..db881246c 100644
144--- a/inference-engine/src/vpu/graph_transformer/CMakeLists.txt
145+++ b/inference-engine/src/vpu/graph_transformer/CMakeLists.txt
146@@ -35,7 +35,6 @@ function(add_graph_transformer_target TARGET_NAME STATIC_IE)
147
148 target_include_directories(${TARGET_NAME}
149 SYSTEM PUBLIC
150- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>
151 $<TARGET_PROPERTY:inference_engine_plugin_api,INTERFACE_INCLUDE_DIRECTORIES>
152 "${IE_MAIN_SOURCE_DIR}/thirdparty/movidius/mvnc/include")
153
154diff --git a/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt b/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
155index efead7271..732abee2d 100644
156--- a/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
157+++ b/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
158@@ -23,7 +23,7 @@ function(add_gtest_libraries)
159 PROPERTIES FOLDER thirdparty)
160 endfunction()
161
162-add_gtest_libraries()
163+#add_gtest_libraries()
164
165 if (MSVC)
166 set(PUGI pugixml_mt)
167@@ -32,10 +32,7 @@ else ()
168 endif ()
169
170 list(APPEND EXPORT_DEPENDENCIES
171- ${PUGI}
172 ${NGRAPH_LIBRARIES}
173- gtest
174- gtest_main
175 )
176
177 set(TARGET_NAME commonTestUtils)
178@@ -74,7 +71,6 @@ function(add_common_utils ADD_TARGET_NAME)
179 PUBLIC
180 ${IE_TESTS_ROOT}/ie_test_utils
181 $<TARGET_PROPERTY:inference_engine,INTERFACE_INCLUDE_DIRECTORIES>
182- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>
183 PRIVATE
184 $<TARGET_PROPERTY:inference_engine_plugin_api,INTERFACE_INCLUDE_DIRECTORIES>
185 )
186@@ -84,6 +80,7 @@ function(add_common_utils ADD_TARGET_NAME)
187 target_link_libraries(${ADD_TARGET_NAME}
188 PUBLIC
189 ${EXPORT_DEPENDENCIES}
190+ pugixml
191 )
192 endfunction()
193
194diff --git a/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt b/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
195index df611c700..06bd911ae 100644
196--- a/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
197+++ b/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
198@@ -10,8 +10,7 @@ list(APPEND EXPORT_DEPENDENCIES
199 commonTestUtils_s
200 inference_engine_s
201 inference_engine_lp_transformations
202- inference_engine_ir_reader
203- gmock)
204+ inference_engine_ir_reader)
205
206 addIeTarget(
207 NAME ${TARGET_NAME}
208diff --git a/inference-engine/tests_deprecated/helpers/CMakeLists.txt b/inference-engine/tests_deprecated/helpers/CMakeLists.txt
209index bf915e52d..9e7173db6 100644
210--- a/inference-engine/tests_deprecated/helpers/CMakeLists.txt
211+++ b/inference-engine/tests_deprecated/helpers/CMakeLists.txt
212@@ -23,7 +23,6 @@ function(add_helpers target_name)
213 "${IE_MAIN_SOURCE_DIR}/src/inference_engine"
214 $<TARGET_PROPERTY:inference_engine_ir_reader,INTERFACE_INCLUDE_DIRECTORIES>
215 $<TARGET_PROPERTY:inference_engine_lp_transformations,INTERFACE_INCLUDE_DIRECTORIES>
216- $<TARGET_PROPERTY:pugixml,INTERFACE_INCLUDE_DIRECTORIES>
217 "${IE_MAIN_SOURCE_DIR}/src/vpu/"
218 PRIVATE "${CMAKE_CURRENT_BINARY_DIR}")
219
220diff --git a/inference-engine/thirdparty/CMakeLists.txt b/inference-engine/thirdparty/CMakeLists.txt
221index f94453e06..b3c25daf4 100644
222--- a/inference-engine/thirdparty/CMakeLists.txt
223+++ b/inference-engine/thirdparty/CMakeLists.txt
224@@ -38,28 +38,16 @@ function(build_with_lto)
225 function(ie_build_pugixml)
226 set(BUILD_TESTS_current ${BUILD_TESTS})
227 set(BUILD_TESTS OFF CACHE BOOL "Build tests" FORCE)
228- add_subdirectory(pugixml)
229 set(BUILD_TESTS ${BUILD_TESTS_current} CACHE BOOL "Build tests" FORCE)
230 endfunction()
231
232 ie_build_pugixml()
233 add_subdirectory(stb_lib)
234- add_subdirectory(ade)
235 add_subdirectory(fluid/modules/gapi)
236
237- target_include_directories(pugixml INTERFACE "$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/pugixml/src>")
238-
239- set_target_properties(pugixml ade fluid stb_image
240+ set_target_properties(fluid stb_image
241 PROPERTIES FOLDER thirdparty)
242
243- # developer package
244-
245- ie_developer_export_targets(ade fluid pugixml)
246- if(TARGET pugixml_mt)
247- ie_developer_export_targets(pugixml_mt)
248- set_target_properties(pugixml_mt PROPERTIES FOLDER thirdparty)
249- endif()
250-
251 if(ENABLE_MKL_DNN)
252 set(SDL_cmake_included ON)
253 include(mkldnn.cmake)
254--
2552.26.2
256