summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch
deleted file mode 100644
index 3c265652..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1From 419070322898381885b0ffa286905a3b08a23aa6 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 9 Jun 2020 11:35:59 +0800
4Subject: [PATCH] don't install licenses and version
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 ngraph/CMakeLists.txt | 8 ++------
11 ngraph/test/runtime/CMakeLists.txt | 2 ++
12 2 files changed, 4 insertions(+), 6 deletions(-)
13
14diff --git a/ngraph/CMakeLists.txt b/ngraph/CMakeLists.txt
15index a05ca3b15c..9bc507b4c7 100644
16--- a/ngraph/CMakeLists.txt
17+++ b/ngraph/CMakeLists.txt
18@@ -272,7 +272,7 @@ if (NGRAPH_EXPORT_TARGETS_ENABLE)
19 install(EXPORT ngraphTargets
20 FILE ngraphTargets.cmake
21 NAMESPACE ngraph::
22- DESTINATION "deployment_tools/ngraph/cmake"
23+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
24 COMPONENT ngraph_dev)
25 endif()
26
27@@ -286,7 +286,7 @@ if (NGRAPH_EXPORT_TARGETS_ENABLE)
28
29 install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ngraphConfig.cmake
30 ${CMAKE_CURRENT_BINARY_DIR}/ngraphConfigVersion.cmake
31- DESTINATION "deployment_tools/ngraph/cmake"
32+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
33 COMPONENT ngraph_dev)
34 endif()
35
36@@ -337,7 +337,3 @@ add_subdirectory(test)
37 if (NGRAPH_PYTHON_BUILD_ENABLE)
38 add_subdirectory(python)
39 endif()
40-
41-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/VERSION
42- DESTINATION "deployment_tools/ngraph"
43- COMPONENT ngraph)
44diff --git a/ngraph/test/runtime/CMakeLists.txt b/ngraph/test/runtime/CMakeLists.txt
45index be84499ee0..f65357b751 100644
46--- a/ngraph/test/runtime/CMakeLists.txt
47+++ b/ngraph/test/runtime/CMakeLists.txt
48@@ -66,3 +66,5 @@ target_include_directories(ngraph_backend PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
49
50 add_subdirectory(interpreter)
51 add_subdirectory(ie)
52+
53+install(TARGETS ngraph_backend DESTINATION ${NGRAPH_INSTALL_LIB})
54--
552.32.0
56