summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-werror.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-werror.patch82
1 files changed, 82 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-werror.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-werror.patch
new file mode 100644
index 00000000..5ba1e763
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-werror.patch
@@ -0,0 +1,82 @@
1From 434cf332e8c368b626d230b79e8dccecf2b0525b Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 20 Aug 2019 19:39:37 +0800
4Subject: [PATCH] disable werror
5
6This shouldn't be enabled and leads to multiple errors when compiling cldnn.
7
8Upstream-Status: Submitted
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11
12---
13 inference-engine/cmake/os_flags.cmake | 2 +-
14 inference-engine/samples/CMakeLists.txt | 1 -
15 inference-engine/thirdparty/clDNN/CMakeLists.txt | 2 --
16 inference-engine/thirdparty/mkl-dnn/cmake/platform.cmake | 1 -
17 inference-engine/tools/CMakeLists.txt | 2 --
18 5 files changed, 1 insertion(+), 7 deletions(-)
19
20diff --git a/inference-engine/cmake/os_flags.cmake b/inference-engine/cmake/os_flags.cmake
21index 29608ea..2c189d8 100644
22--- a/inference-engine/cmake/os_flags.cmake
23+++ b/inference-engine/cmake/os_flags.cmake
24@@ -28,7 +28,7 @@ if (WIN32)
25 endif()
26
27 else()
28- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Werror=return-type ")
29+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=return-type ")
30 if (APPLE)
31 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=unused-command-line-argument")
32 elseif(UNIX)
33diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
34index a8a9946..8ac5454 100644
35--- a/inference-engine/samples/CMakeLists.txt
36+++ b/inference-engine/samples/CMakeLists.txt
37@@ -68,7 +68,6 @@ if (WIN32)
38 set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4251 /wd4275 /wd4267") #disable some warnings
39 endif()
40 else()
41- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror") #treating warnings as errors
42 if (APPLE)
43 set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=unused-command-line-argument")
44 elseif(UNIX)
45diff --git a/inference-engine/thirdparty/clDNN/CMakeLists.txt b/inference-engine/thirdparty/clDNN/CMakeLists.txt
46index 624d95c..5646ff1 100644
47--- a/inference-engine/thirdparty/clDNN/CMakeLists.txt
48+++ b/inference-engine/thirdparty/clDNN/CMakeLists.txt
49@@ -757,8 +757,6 @@ foreach(__CLDNN_CompilerFlagName IN ITEMS "CMAKE_CXX_FLAGS" "CMAKE_C_FLAGS")
50 MultiProcessorCompilation
51 DeadCodeEliminate
52 ExtensionsEnabled
53- TreatWarnAsErrorEnabled
54- WarnLevel4
55 NoFastMath
56 StackProtector
57 )
58diff --git a/inference-engine/thirdparty/mkl-dnn/cmake/platform.cmake b/inference-engine/thirdparty/mkl-dnn/cmake/platform.cmake
59index a541215..bed8a59 100644
60--- a/inference-engine/thirdparty/mkl-dnn/cmake/platform.cmake
61+++ b/inference-engine/thirdparty/mkl-dnn/cmake/platform.cmake
62@@ -63,7 +63,6 @@ if(MSVC)
63 endif()
64 elseif(UNIX OR MINGW)
65 append(CMAKE_CCXX_FLAGS "-Wall -Wno-unknown-pragmas")
66- append_if_product(CMAKE_CCXX_FLAGS "-Werror")
67 append(CMAKE_CCXX_FLAGS "-fvisibility=internal")
68 append(CMAKE_C_FLAGS "-std=c99")
69 append(CMAKE_CXX_FLAGS "-std=c++11 -fvisibility-inlines-hidden")
70diff --git a/inference-engine/tools/CMakeLists.txt b/inference-engine/tools/CMakeLists.txt
71index 13ab365..feacf33 100644
72--- a/inference-engine/tools/CMakeLists.txt
73+++ b/inference-engine/tools/CMakeLists.txt
74@@ -23,8 +23,6 @@ endif()
75
76 if (WIN32)
77 # add_compile_options("/WX")
78-else()
79- add_compile_options("-Werror")
80 endif()
81
82 add_subdirectory(vpu)