summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch86
1 files changed, 86 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch
new file mode 100644
index 00000000..7f5b46c6
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch
@@ -0,0 +1,86 @@
1From e4edbdae9a2dbfec6fd0706bdfff8abdfe3363fc Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 29 Nov 2023 12:42:57 +0530
4Subject: [PATCH] cmake: yocto specific tweaks to the build process
5
6* Dont try to detect glibc version as that doesn't work when cross compiling.
7* Dont try to detect CXX11_ABI
8* Install sample binaries as well.
9* Dont try to write triggers for CPack. We package ourselves.
10* Fix the installation path for Python modules when baselib = lib64.
11
12Upstream-Status: Inappropriate
13
14Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
15---
16 cmake/developer_package/packaging/rpm/rpm.cmake | 2 +-
17 cmake/developer_package/target_flags.cmake | 4 ++--
18 samples/cpp/CMakeLists.txt | 6 +++---
19 src/bindings/python/CMakeLists.txt | 2 +-
20 4 files changed, 7 insertions(+), 7 deletions(-)
21
22diff --git a/cmake/developer_package/packaging/rpm/rpm.cmake b/cmake/developer_package/packaging/rpm/rpm.cmake
23index 99f11730983..1a1f61fcd3d 100644
24--- a/cmake/developer_package/packaging/rpm/rpm.cmake
25+++ b/cmake/developer_package/packaging/rpm/rpm.cmake
26@@ -156,7 +156,7 @@ ov_rpm_specific_settings()
27 # needed to add triggers for packages with libraries
28 set(def_triggers "${OpenVINO_BINARY_DIR}/_CPack_Packages/triggers")
29 set(triggers_content "# /bin/sh -p\n/sbin/ldconfig\n")
30-file(WRITE "${def_triggers}" "${triggers_content}")
31+#file(WRITE "${def_triggers}" "${triggers_content}")
32
33 #
34 # Functions helpful for packaging your modules with RPM cpack
35diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
36index d047a1aebd9..4e8ca68c60f 100644
37--- a/cmake/developer_package/target_flags.cmake
38+++ b/cmake/developer_package/target_flags.cmake
39@@ -149,7 +149,7 @@ function(ov_glibc_version)
40 endif()
41 endfunction()
42
43-ov_glibc_version()
44+#ov_glibc_version()
45
46 #
47 # Detects default value for _GLIBCXX_USE_CXX11_ABI for current compiler
48@@ -160,4 +160,4 @@ macro(ov_get_glibcxx_use_cxx11_abi)
49 endif()
50 endmacro()
51
52-ov_get_glibcxx_use_cxx11_abi()
53+#ov_get_glibcxx_use_cxx11_abi()
54diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
55index 4d33bff944e..3e7f1458578 100644
56--- a/samples/cpp/CMakeLists.txt
57+++ b/samples/cpp/CMakeLists.txt
58@@ -206,9 +206,9 @@ macro(ov_add_sample)
59 target_link_libraries(${SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${SAMPLE_DEPENDENCIES})
60
61 install(TARGETS ${SAMPLE_NAME}
62- RUNTIME DESTINATION samples_bin/
63- COMPONENT samples_bin
64- EXCLUDE_FROM_ALL)
65+ DESTINATION ${CMAKE_INSTALL_BINDIR}
66+ COMPONENT samples_bin)
67+
68
69 # create global target with all samples / demo apps
70 if(NOT TARGET ov_samples)
71diff --git a/src/bindings/python/CMakeLists.txt b/src/bindings/python/CMakeLists.txt
72index 6cf43ec3fed..d539b9d003f 100644
73--- a/src/bindings/python/CMakeLists.txt
74+++ b/src/bindings/python/CMakeLists.txt
75@@ -320,7 +320,7 @@ if(ENABLE_PYTHON_PACKAGING)
76 # install OpenVINO Python API
77
78 set(python_package_prefix "${CMAKE_CURRENT_BINARY_DIR}/install_${pyversion}")
79- set(install_lib "${python_package_prefix}/lib/${python_versioned_folder}/${ov_site_packages}")
80+ set(install_lib "${python_package_prefix}/${CMAKE_INSTALL_LIBDIR}/${python_versioned_folder}/${ov_site_packages}")
81 set(openvino_meta_info_subdir "openvino-${OpenVINO_VERSION}-py${python_xy}.egg-info")
82 set(openvino_meta_info_file "${install_lib}/${openvino_meta_info_subdir}/PKG-INFO")
83
84--
852.34.1
86