summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Installation-and-build-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Installation-and-build-fixes.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Installation-and-build-fixes.patch383
1 files changed, 0 insertions, 383 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Installation-and-build-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Installation-and-build-fixes.patch
deleted file mode 100644
index c4c7bd01..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Installation-and-build-fixes.patch
+++ /dev/null
@@ -1,383 +0,0 @@
1From 1c78ff3ff1f77c78a618f7a780985cef1933bb2b Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 13 Apr 2020 15:20:28 +0800
4Subject: [PATCH] Installation and build fixes
5
6- Install libs, samples and binaries at appropriate places.
7- Use system installed pugixml, ade, gflags, ngraph, opencl-headers
8and icd-loader.
9- Disable usage of Werror.
10- Use find_library to look for tbb instead of looking for cmake module.
11
12Upstream-Status: Inappropriate [OS-specific]
13
14Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
15---
16 CMakeLists.txt | 2 --
17 cmake/developer_package.cmake | 8 +++++---
18 cmake/os_flags.cmake | 1 -
19 inference-engine/CMakeLists.txt | 7 ++-----
20 inference-engine/cmake/ie_parallel.cmake | 10 ++--------
21 .../include/gpu/gpu_ocl_wrapper.hpp | 2 +-
22 inference-engine/samples/CMakeLists.txt | 8 +++-----
23 .../samples/common/format_reader/CMakeLists.txt | 2 ++
24 .../src/cldnn_engine/CMakeLists.txt | 1 +
25 .../src/inference_engine/CMakeLists.txt | 17 +----------------
26 .../src/vpu/myriad_plugin/CMakeLists.txt | 2 +-
27 .../tests/mock_engine/CMakeLists.txt | 2 ++
28 inference-engine/tests/unit/CMakeLists.txt | 2 ++
29 inference-engine/thirdparty/CMakeLists.txt | 4 +---
30 .../clDNN/CMakeCompilerLinkerOpts.txt | 2 --
31 .../thirdparty/clDNN/CMakeLists.txt | 1 -
32 .../clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp | 2 +-
33 .../tools/compile_tool/CMakeLists.txt | 2 +-
34 .../tools/vpu/vpu_compile/CMakeLists.txt | 4 ++--
35 .../tools/vpu/vpu_perfcheck/CMakeLists.txt | 2 +-
36 20 files changed, 28 insertions(+), 53 deletions(-)
37
38diff --git a/CMakeLists.txt b/CMakeLists.txt
39index e48cee57..e9598455 100644
40--- a/CMakeLists.txt
41+++ b/CMakeLists.txt
42@@ -120,8 +120,6 @@ function(build_ngraph)
43 endif()
44
45 ie_cpack_add_component(ngraph)
46-
47- add_subdirectory(ngraph)
48 endfunction()
49
50 build_ngraph()
51diff --git a/cmake/developer_package.cmake b/cmake/developer_package.cmake
52index e59edb2b..35672cac 100644
53--- a/cmake/developer_package.cmake
54+++ b/cmake/developer_package.cmake
55@@ -5,7 +5,9 @@
56 include(CPackComponent)
57 unset(IE_CPACK_COMPONENTS_ALL CACHE)
58
59-set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
60+if (NOT DEFINED IE_CPACK_IE_DIR)
61+ set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
62+endif()
63
64 function(ie_cpack_set_library_dir)
65 string(TOLOWER ${CMAKE_SYSTEM_PROCESSOR} ARCH)
66@@ -18,7 +20,7 @@ function(ie_cpack_set_library_dir)
67 if(WIN32)
68 set(IE_CPACK_LIBRARY_PATH ${IE_CPACK_IE_DIR}/lib/$<CONFIG>/${ARCH} PARENT_SCOPE)
69 else()
70- set(IE_CPACK_LIBRARY_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
71+ set(IE_CPACK_LIBRARY_PATH ${CMAKE_INSTALL_LIBDIR} PARENT_SCOPE)
72 endif()
73 endfunction()
74
75@@ -99,7 +101,7 @@ if(UNIX)
76 SET(LIB_DL ${CMAKE_DL_LIBS})
77 endif()
78
79-set(OUTPUT_ROOT ${OpenVINO_MAIN_SOURCE_DIR})
80+set(OUTPUT_ROOT ${CMAKE_CURRENT_BINARY_DIR})
81
82 # Enable postfixes for Debug/Release builds
83 set(IE_DEBUG_POSTFIX_WIN "d")
84diff --git a/cmake/os_flags.cmake b/cmake/os_flags.cmake
85index 6f70768f..40141aca 100644
86--- a/cmake/os_flags.cmake
87+++ b/cmake/os_flags.cmake
88@@ -139,7 +139,6 @@ if(WIN32)
89 else()
90 # TODO: enable for C sources as well
91 # ie_add_compiler_flags(-Werror)
92- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
93 ie_add_compiler_flags(-ffunction-sections -fdata-sections)
94 ie_add_compiler_flags(-fvisibility=hidden)
95 ie_add_compiler_flags(-fdiagnostics-show-option)
96diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt
97index d5feedb4..1ee656a1 100644
98--- a/inference-engine/CMakeLists.txt
99+++ b/inference-engine/CMakeLists.txt
100@@ -123,12 +123,13 @@ install(FILES samples/CMakeLists.txt
101
102 # install Python samples
103
104+if (ENABLE_PYTHON)
105 ie_cpack_add_component(python_samples REQUIRED DEPENDS core)
106
107 install(DIRECTORY ${ie_python_api_SOURCE_DIR}/sample/
108 DESTINATION ${IE_CPACK_IE_DIR}/samples/python
109 COMPONENT python_samples)
110-
111+endif()
112 # Custom target to build only Inference Engine Developer Package targets
113
114 add_custom_target(ie_dev_targets ALL DEPENDS inference_engine HeteroPlugin)
115@@ -136,10 +137,6 @@ add_custom_target(ie_dev_targets ALL DEPENDS inference_engine HeteroPlugin)
116 # Developer package
117 ie_developer_export_targets(format_reader)
118
119-if (ENABLE_NGRAPH)
120- ie_developer_export_targets(${NGRAPH_LIBRARIES})
121-endif()
122-
123 export(TARGETS ${IEDeveloperPackageTargets} NAMESPACE IE::
124 APPEND FILE "${CMAKE_BINARY_DIR}/targets_developer.cmake")
125
126diff --git a/inference-engine/cmake/ie_parallel.cmake b/inference-engine/cmake/ie_parallel.cmake
127index 9ea885be..71733fd9 100644
128--- a/inference-engine/cmake/ie_parallel.cmake
129+++ b/inference-engine/cmake/ie_parallel.cmake
130@@ -42,14 +42,8 @@ function(set_ie_threading_interface_for TARGET_NAME)
131 set(IE_THREAD_DEFINE "IE_THREAD_SEQ")
132
133 if (THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO")
134- find_package(TBB COMPONENTS tbb tbbmalloc)
135- if (TBB_FOUND)
136- set(IE_THREAD_DEFINE "IE_THREAD_TBB")
137- ie_target_link_libraries(${TARGET_NAME} PUBLIC ${TBB_IMPORTED_TARGETS})
138- else ()
139- ext_message(WARNING "TBB was not found by the configured TBB_DIR path. \
140- SEQ method will be used for ${TARGET_NAME}")
141- endif ()
142+ set(IE_THREAD_DEFINE "IE_THREAD_TBB")
143+ target_link_libraries(${TARGET_NAME} PUBLIC tbb tbbmalloc)
144 elseif (THREADING STREQUAL "OMP")
145 if (WIN32)
146 set(omp_lib_name libiomp5md)
147diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
148index fce7d8f1..827e5764 100644
149--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
150+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
151@@ -21,4 +21,4 @@
152 # pragma GCC system_header
153 #endif
154
155-#include <CL/cl2.hpp>
156+#include <cl2.hpp>
157diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
158index f355e7b9..d24c7c78 100644
159--- a/inference-engine/samples/CMakeLists.txt
160+++ b/inference-engine/samples/CMakeLists.txt
161@@ -24,7 +24,7 @@ endif()
162
163 if(IE_MAIN_SOURCE_DIR)
164 # in case if samples are built from IE repo
165- set(IE_MAIN_SAMPLES_DIR ${OpenVINO_MAIN_SOURCE_DIR})
166+ set(IE_MAIN_SAMPLES_DIR ${CMAKE_BINARY_DIR})
167 # hint for find_package(InferenceEngine in the samples folder)
168 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}")
169 else()
170@@ -91,10 +91,6 @@ set (HAVE_INTTYPES_H 1)
171 set (INTTYPES_FORMAT C99)
172 set (BUILD_TESTING OFF)
173
174-if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/gflags")
175- add_subdirectory(thirdparty/gflags)
176-endif()
177-
178 if (CMAKE_CXX_COMPILER_ID STREQUAL GNU)
179 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
180 endif()
181@@ -203,6 +199,8 @@ macro(ie_add_sample)
182 if(COMMAND add_cpplint_target AND NOT IE_SAMPLE_EXCLUDE_CPPLINT)
183 add_cpplint_target(${IE_SAMPLE_NAME}_cpplint FOR_TARGETS ${IE_SAMPLE_NAME})
184 endif()
185+
186+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin)
187 endmacro()
188
189 # collect all samples subdirectories
190diff --git a/inference-engine/samples/common/format_reader/CMakeLists.txt b/inference-engine/samples/common/format_reader/CMakeLists.txt
191index 6d935135..fe12eeb7 100644
192--- a/inference-engine/samples/common/format_reader/CMakeLists.txt
193+++ b/inference-engine/samples/common/format_reader/CMakeLists.txt
194@@ -40,3 +40,5 @@ target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}"
195 "${CMAKE_CURRENT_SOURCE_DIR}/..")
196
197 set_target_properties(${TARGET_NAME} PROPERTIES COMPILE_PDB_NAME ${TARGET_NAME})
198+
199+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
200diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
201index 43344e7f..50beda23 100644
202--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
203+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
204@@ -32,6 +32,7 @@ target_include_directories(${TARGET_NAME} PRIVATE
205 ${CMAKE_CURRENT_SOURCE_DIR}
206 ${CLDNN__IOCL_ICD_INCDIRS}
207 ${CLDNN_TOP_FOLDER}
208+ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp
209 ${IE_MAIN_SOURCE_DIR}/thirdparty/pugixml/src)
210
211 # copy default global xml file describing the custom kernels and the *.cl files
212diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
213index 54e264c8..e3809654 100644
214--- a/inference-engine/src/inference_engine/CMakeLists.txt
215+++ b/inference-engine/src/inference_engine/CMakeLists.txt
216@@ -292,20 +292,6 @@ if(threading_tbb)
217 ie_cpack_add_component(tbb REQUIRED)
218 list(APPEND core_components tbb)
219
220- install(DIRECTORY "${TBB}/include"
221- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
222- COMPONENT tbb)
223- install(DIRECTORY "${TBB}/lib"
224- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
225- COMPONENT tbb)
226- if(EXISTS "${TBB}/bin")
227- install(DIRECTORY "${TBB}/bin"
228- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
229- COMPONENT tbb)
230- endif()
231- install(FILES "${TBB}/LICENSE"
232- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
233- COMPONENT tbb)
234 endif()
235
236 ie_cpack_add_component(core REQUIRED DEPENDS ${core_components})
237@@ -318,10 +304,9 @@ install(TARGETS ${TARGET_NAME} ${TARGET_NAME}_nn_builder
238 LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH}
239 COMPONENT core)
240 install(FILES "${OpenVINO_BINARY_DIR}/share/ie_parallel.cmake"
241- "${OpenVINO_BINARY_DIR}/share/ie_rh_decoder.cmake"
242 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig.cmake"
243 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig-version.cmake"
244- DESTINATION ${IE_CPACK_IE_DIR}/share
245+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/InferenceEngine
246 COMPONENT core)
247 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
248 DESTINATION ${IE_CPACK_LIBRARY_PATH}
249diff --git a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
250index 32cb534a..858ffefc 100644
251--- a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
252+++ b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
253@@ -41,5 +41,5 @@ target_link_libraries(${TARGET_NAME}
254 # install
255
256 install(FILES ${IE_MAIN_SOURCE_DIR}/thirdparty/movidius/mvnc/src/97-myriad-usbboot.rules
257- DESTINATION deployment_tools/inference_engine/external
258+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
259 COMPONENT myriad)
260diff --git a/inference-engine/tests/mock_engine/CMakeLists.txt b/inference-engine/tests/mock_engine/CMakeLists.txt
261index f3fb53e1..09fb66ce 100644
262--- a/inference-engine/tests/mock_engine/CMakeLists.txt
263+++ b/inference-engine/tests/mock_engine/CMakeLists.txt
264@@ -38,3 +38,5 @@ target_compile_definitions(${TARGET_NAME} PRIVATE IMPLEMENT_INFERENCE_ENGINE_PLU
265 set_property(TARGET ${TARGET_NAME} PROPERTY CXX_STANDARD 11)
266 set_property(TARGET ${TARGET_NAME} PROPERTY CXX_STANDARD_REQUIRED ON)
267 set_property(TARGET ${TARGET_NAME} PROPERTY COMPILE_PDB_NAME ${TARGET_NAME})
268+
269+install(TARGETS ${TARGET_NAME} EXPORT ${TARGET_NAME} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
270diff --git a/inference-engine/tests/unit/CMakeLists.txt b/inference-engine/tests/unit/CMakeLists.txt
271index a5c945ae..eabe70d3 100644
272--- a/inference-engine/tests/unit/CMakeLists.txt
273+++ b/inference-engine/tests/unit/CMakeLists.txt
274@@ -187,3 +187,5 @@ add_test(NAME ${TARGET_NAME}
275 COMMAND ${TARGET_NAME})
276
277 add_dependencies(${TARGET_NAME} mock_engine)
278+
279+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
280diff --git a/inference-engine/thirdparty/CMakeLists.txt b/inference-engine/thirdparty/CMakeLists.txt
281index ec22761d..3962d924 100644
282--- a/inference-engine/thirdparty/CMakeLists.txt
283+++ b/inference-engine/thirdparty/CMakeLists.txt
284@@ -35,14 +35,12 @@ function(build_with_lto)
285 add_subdirectory(clDNN)
286 endif()
287
288- add_subdirectory(pugixml)
289 add_subdirectory(stb_lib)
290- add_subdirectory(ade)
291 add_subdirectory(fluid/modules/gapi)
292
293 # developer package
294
295- ie_developer_export_targets(ade fluid pugixml)
296+ ie_developer_export_targets(fluid)
297 if(TARGET pugixml_mt)
298 ie_developer_export_targets(pugixml_mt)
299 endif()
300diff --git a/inference-engine/thirdparty/clDNN/CMakeCompilerLinkerOpts.txt b/inference-engine/thirdparty/clDNN/CMakeCompilerLinkerOpts.txt
301index 6b799cdd..91755b35 100644
302--- a/inference-engine/thirdparty/clDNN/CMakeCompilerLinkerOpts.txt
303+++ b/inference-engine/thirdparty/clDNN/CMakeCompilerLinkerOpts.txt
304@@ -206,7 +206,6 @@ elseif(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
305 ALIAS RttiDisabled "-fno-rtti"
306 ALIAS RttiEnabled "-frtti"
307 ALIAS TreatWarnAsErrorDisabled TreatWarnAsError REMOVE_GROUP
308- ALIAS TreatWarnAsErrorEnabled "-Werror" "-pedantic-errors"
309 ALIAS WarnLevel0 "-w"
310 ALIAS WarnLevel1 WarnLevels REMOVE_GROUP
311 ALIAS WarnLevel2 "-Wall"
312@@ -290,7 +289,6 @@ elseif((CMAKE_C_COMPILER_ID MATCHES "^Clang$") OR (CMAKE_CXX_COMPILER_ID MATCHES
313 ALIAS RttiDisabled "-fno-rtti"
314 ALIAS RttiEnabled Rtti REMOVE_GROUP
315 ALIAS TreatWarnAsErrorDisabled TreatWarnAsError REMOVE_GROUP
316- ALIAS TreatWarnAsErrorEnabled "-Werror"
317 ALIAS WarnLevel0 "-w"
318 ALIAS WarnLevel1 WarnLevels REMOVE_GROUP
319 ALIAS WarnLevel2 "-Wall"
320diff --git a/inference-engine/thirdparty/clDNN/CMakeLists.txt b/inference-engine/thirdparty/clDNN/CMakeLists.txt
321index b08c2744..42ca79e6 100644
322--- a/inference-engine/thirdparty/clDNN/CMakeLists.txt
323+++ b/inference-engine/thirdparty/clDNN/CMakeLists.txt
324@@ -767,7 +767,6 @@ foreach(__CLDNN_CompilerFlagName IN ITEMS "CMAKE_CXX_FLAGS" "CMAKE_C_FLAGS")
325 MultiProcessorCompilation
326 DeadCodeEliminate
327 ExtensionsEnabled
328- TreatWarnAsErrorEnabled
329 WarnLevel4
330 NoFastMath
331 StackProtector
332diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
333index a9e379bd..8b822223 100644
334--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
335+++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
336@@ -30,7 +30,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel;
337 typedef cl_va_api_device_source_intel cl_device_source_intel;
338 typedef cl_va_api_device_set_intel cl_device_set_intel;
339 #endif
340-#include <CL/cl_intel_planar_yuv.h>
341+#include <CL/cl_ext_intel.h>
342
343 namespace cl {
344 typedef CL_API_ENTRY cl_int(CL_API_CALL *PFN_clEnqueueAcquireMediaSurfacesINTEL)(
345diff --git a/inference-engine/tools/compile_tool/CMakeLists.txt b/inference-engine/tools/compile_tool/CMakeLists.txt
346index 25168bac..1c57116f 100644
347--- a/inference-engine/tools/compile_tool/CMakeLists.txt
348+++ b/inference-engine/tools/compile_tool/CMakeLists.txt
349@@ -48,5 +48,5 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
350 # install
351
352 install(TARGETS compile_tool
353- RUNTIME DESTINATION ${IE_CPACK_LIBRARY_PATH}
354+ RUNTIME DESTINATION bin
355 COMPONENT core)
356diff --git a/inference-engine/tools/vpu/vpu_compile/CMakeLists.txt b/inference-engine/tools/vpu/vpu_compile/CMakeLists.txt
357index 4123de6f..52179fac 100644
358--- a/inference-engine/tools/vpu/vpu_compile/CMakeLists.txt
359+++ b/inference-engine/tools/vpu/vpu_compile/CMakeLists.txt
360@@ -50,5 +50,5 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
361 # install
362
363 install(TARGETS ${TARGET_NAME}
364- RUNTIME DESTINATION ${IE_CPACK_LIBRARY_PATH}
365- COMPONENT myriad)
366\ No newline at end of file
367+ RUNTIME DESTINATION bin
368+ COMPONENT myriad)
369diff --git a/inference-engine/tools/vpu/vpu_perfcheck/CMakeLists.txt b/inference-engine/tools/vpu/vpu_perfcheck/CMakeLists.txt
370index a7a801d4..b8f9e26f 100644
371--- a/inference-engine/tools/vpu/vpu_perfcheck/CMakeLists.txt
372+++ b/inference-engine/tools/vpu/vpu_perfcheck/CMakeLists.txt
373@@ -55,6 +55,6 @@ if(ENABLE_MYRIAD)
374 add_perfcheck_target(myriad_perfcheck myriadPlugin)
375
376 install(TARGETS myriad_perfcheck
377- RUNTIME DESTINATION ${IE_CPACK_LIBRARY_PATH}
378+ RUNTIME DESTINATION bin
379 COMPONENT myriad)
380 endif()
381--
3822.25.2
383