summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb86
1 files changed, 86 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb
new file mode 100644
index 00000000..21b5198d
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb
@@ -0,0 +1,86 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Deep Learning Deployment Toolkit"
2HOMEPAGE = "https://github.com/opencv/dldt"
3DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic."
6
7SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
8 file://0001-R2-Build-fixes.patch;patchdir=../ \
9 file://0002-R2-Install-DLDT-headers-libs-sample-Apps.patch;patchdir=../ \
10 file://0003-use-GNUInstallDirs-on-nix.patch;patchdir=../ \
11 file://0004-disable-werror.patch;patchdir=../ \
12 file://0005-point-to-correct-location-of-ngraph-headers.patch;patchdir=../ \
13 file://0006-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch;patchdir=../ \
14 file://0007-Install-mock_engine-to-CMAKE_INSTALL_LIBDIR.patch;patchdir=../ \
15 file://run-ptest \
16 "
17SRCREV = "1c794d971cdd3c94de5ea4a6c9588eac63f4cc57"
18
19LICENSE = "Apache-2.0"
20LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
21
22inherit cmake ptest python3native
23
24S = "${WORKDIR}/git/inference-engine"
25
26EXTRA_OECMAKE += " \
27 -DENABLE_VPU=OFF \
28 -DENABLE_OPENCV=0 \
29 -DENABLE_SAMPLES_CORE=1 \
30 -DENABLE_PLUGIN_RPATH=0 \
31 -DENABLE_GNA=0 \
32 -DPYTHON_EXECUTABLE=${PYTHON} \
33 -DTHREADING=TBB \
34 -DCMAKE_INSTALL_LOCAL_ONLY=OFF \
35 -DCMAKE_BUILD_TYPE=DebugWithRelInfo \
36 -DNGRAPH_INCLUDES=${STAGING_INCDIR}/ngraph \
37 -DENABLE_TESTS="${@bb.utils.contains('PTEST_ENABLED', '1', '1', '0', d)}" \
38 -DBUILD_GMOCK=1 \
39 -DBUILD_GTEST=0 \
40 -DINSTALL_GMOCK=0 \
41 -DINSTALL_GTEST=0 \
42 "
43
44DEPENDS += "libusb1 \
45 ade \
46 opencv \
47 pugixml \
48 ngraph \
49 tbb \
50 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gflags', '0', d)} \
51 "
52
53COMPATIBLE_HOST = '(x86_64).*-linux'
54COMPATIBLE_HOST_libc-musl = "null"
55
56PACKAGECONFIG ?= ""
57PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime"
58PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native, python3"
59
60do_install_ptest_base_prepend() {
61 # While not a Makefile based project that strictly falls into the category of
62 # what ptest helps with, adding the unit tests here as ptest would help.
63 # Create a dummy Makefile so installation doesn't fail.
64 touch ${WORKDIR}/Makefile
65 mv ${D}${bindir}/InferenceEngineUnitTests ${D}${PTEST_PATH}/
66 mv ${D}${libdir}/libmock_engine.so ${D}${PTEST_PATH}/
67}
68
69FILES_${PN}-dev = "${includedir} \
70 ${libdir}/cmake \
71 ${libdir}/libinference_engine.so \
72 "
73
74FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \
75 ${datadir}/openvino \
76 "
77
78# Move inference engine samples into a separate package
79PACKAGES =+ "${PN}-samples"
80
81FILES_${PN}-samples = "${bindir}"
82
83# Package for inference engine python API
84PACKAGES =+ "${PN}-${PYTHON_PN}"
85
86FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}/openvino"