summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0369.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0369.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0369.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0369.bb b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0369.bb
new file mode 100644
index 00000000..48140a65
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0369.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Utility for managing Intel Optane DC persistent memory modules"
2DESCRIPTION = "Utility for configuring and managing Intel Optane Persistent \
3Memory modules (PMem). It supports functionality to: \
4Discover DCPMMs on the platform. \
5Provision the platform memory configuration. \
6View and update the firmware on DCPMMs. \
7Configure data-at-rest security on DCPMMs. \
8Track health and performance of DCPMMs. \
9Debug and troubleshoot DCPMMs."
10
11HOMEPAGE = "https://github.com/intel/ipmctl"
12BUGTRACKER = "https://github.com/intel/ipmctl/issues"
13
14LICENSE = "BSD-3-Clause | BSD-2-Clause"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=72b9da60da6219d612ce30b746a0fe71 \
16 file://edk2/License.txt;md5=6123e5bf044a66db96c4ce88a36b2d08"
17
18SRC_URI = "git://github.com/intel/ipmctl.git;protocol=https;branch=development;name=ipmctl; \
19 git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=git/edk2; \
20 file://0001-Ignore-STATIC_ASSERT-and-NULL-definition-so-we-can-c.patch;patchdir=edk2 \
21"
22
23SRCREV_ipmctl = "b7541dfeeca1cfdd9f9c9551d7039d3e9809245d"
24#tag: edk2-stable202102
25SRCREV_edk2 = "ef91b07388e1c0a50c604e5350eeda98428ccea6"
26
27S = "${WORKDIR}/git"
28
29inherit cmake dos2unix
30
31DEPENDS = "ndctl"
32
33EXTRA_OECMAKE = "-DRELEASE=ON"
34
35do_configure:prepend() {
36 for dir in BaseTools MdeModulePkg MdePkg ShellPkg ; do
37 ln -sf edk2/${dir} ${S}
38 done
39}