summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.7.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.7.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.7.0.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.7.0.bb
new file mode 100644
index 00000000..fecbe102
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.7.0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Intel OSPray, Ray Tracing based Rendering Engine"
2DESCRIPTION = "Intel OSPRay is an open source, scalable, and portable ray \
3tracing engine for high-performance, high-fidelity visualization on \
4Intel Architecture CPUs."
5HOMEPAGE = "https://www.ospray.org/"
6
7LICENSE = "Apache-2.0 & BSD-3-Clause & MIT & Zlib"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1dece7821bf3fd70fe1309eaa37d52a2 \
9 file://third-party-programs.txt;md5=d0b3d9b55b2ccd6a3bffc374cf2d5563"
10
11inherit pkgconfig cmake
12
13S = "${WORKDIR}/git"
14
15SRC_URI = "git://github.com/ospray/ospray.git;protocol=https \
16 "
17SRCREV = "a783bf987cff6a2d70a2dfce6732d7f2572703bd"
18
19COMPATIBLE_HOST = '(x86_64).*-linux'
20
21DEPENDS = "rkcommon ispc-native openvkl embree"
22
23EXTRA_OECMAKE += " \
24 -DISPC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/ispc \
25 -DOSPRAY_APPS_BENCHMARK=OFF \
26 -DOSPRAY_APPS_TESTING=OFF \
27 "
28
29PACKAGES =+ "${PN}-apps"
30FILES:${PN}-apps = "\
31 ${bindir} \
32 "
33
34UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"