summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-oneapi/embree/embree_3.13.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-oneapi/embree/embree_3.13.4.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/embree/embree_3.13.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/embree/embree_3.13.4.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/embree/embree_3.13.4.bb
new file mode 100644
index 00000000..98652e07
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/embree/embree_3.13.4.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Collection of high-performance ray tracing kernels"
2DESCRIPTION = "A collection of high-performance ray tracing kernels \
3intended to graphics application engineers that want to improve the \
4performance of their application."
5HOMEPAGE = "https://github.com/embree/embree"
6
7LICENSE = "Apache-2.0 & syrah"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \
9 file://third-party-programs.txt;md5=86f6028ba2138fe41ac5c121d0a3518e \
10 file://common/math/transcendental.h;beginline=6;endline=8;md5=73380bb2ab6613b30b8464f114bd0ca8"
11
12inherit pkgconfig cmake
13
14S = "${WORKDIR}/git"
15
16SRC_URI = "git://github.com/embree/embree.git;protocol=https;branch=master \
17 "
18SRCREV = "489b746c0d5010e0da10345e9dc96768bec9a037"
19
20COMPATIBLE_HOST = '(x86_64).*-linux'
21COMPATIBLE_HOST:libc-musl = "null"
22
23DEPENDS = "tbb jpeg libpng glfw ispc-native"
24
25EXTRA_OECMAKE += " \
26 -DEMBREE_ISPC_SUPPORT=OFF \
27 -DEMBREE_IGNORE_CMAKE_CXX_FLAGS=OFF \
28 -DEMBREE_MAX_ISA=DEFAULT \
29 -DEMBREE_TUTORIALS=OFF \
30 -DEMBREE_ISPC_SUPPORT=ON \
31 "