summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-oneapi/dpcpp-compiler/intel-oneapi-dpcpp-cpp_2022.1.0-3768.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-oneapi/dpcpp-compiler/intel-oneapi-dpcpp-cpp_2022.1.0-3768.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/dpcpp-compiler/intel-oneapi-dpcpp-cpp_2022.1.0-3768.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/dpcpp-compiler/intel-oneapi-dpcpp-cpp_2022.1.0-3768.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/dpcpp-compiler/intel-oneapi-dpcpp-cpp_2022.1.0-3768.bb
new file mode 100644
index 00000000..e396f1e7
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/dpcpp-compiler/intel-oneapi-dpcpp-cpp_2022.1.0-3768.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Intel® oneAPI DPC++/C++ Compiler"
2DESCRIPTION = "The Intel® oneAPI DPC++/C++ Compiler provides optimizations \
3that help your applications run faster on Intel® 64 architectures with support \
4for the latest C, C++, and SYCL language standards. This compiler produces \
5optimized code that can run significantly faster by taking advantage of the \
6ever-increasing core count and vector register width in Intel® Xeon® processors \
7and compatible processors."
8
9HOMEPAGE = "https://www.intel.com/content/www/us/en/developer/tools/oneapi/dpc-compiler.html"
10
11LICENSE="EULA"
12
13LIC_FILES_CHKSUM = " \
14 file://opt/intel/oneapi/compiler/2022.1.0/licensing/credist.txt;md5=f772f43824318f221f6363883e44201f \
15 "
16
17SRC_URI = " \
18 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-dpcpp-cpp-2022.1.0-${PV}_amd64.deb;subdir=${BPN};name=icx-compiler \
19 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-compiler-shared-2022.1.0-${PV}_amd64.deb;subdir=${BPN};name=compiler-linker \
20 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-compiler-shared-common-2022.1.0-${PV}_all.deb;subdir=${BPN};name=shared-common \
21 "
22
23SRC_URI[icx-compiler.sha256sum] = "c525c416c61cac9aa4e22fec78be95b88d33bca13360d0444c22da52eb8dd318"
24SRC_URI[compiler-linker.sha256sum] = "3185dc02473b3d3a34234dd82a17c285e43701455636f93be235b52c2ac6f2c6"
25SRC_URI[shared-common.sha256sum] = "c9961b90a9c4f4636c78292b5ba3d6cf6bbd7081f1ce4a4690bb7db94596226e"
26
27S = "${WORKDIR}/${BPN}"
28
29inherit bin_package
30
31RDEPENDS:${PN} += "intel-oneapi-dpcpp-cpp-runtime"
32SKIP_FILEDEPS:${PN} = '1'
33
34INHIBIT_PACKAGE_STRIP = "1"
35INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
36
37# doesn't have GNU_HASH (didn't pass LDFLAGS?)
38INSANE_SKIP:${PN} += "textrel dev-so dev-elf ldflags already-stripped file-rdeps staticdev rpaths arch useless-rpaths"
39
40FILES_SOLIBSDEV = ""
41
42EXCLUDE_FROM_SHLIBS = "1"
43BBCLASSEXTEND = "native nativesdk"