summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-core/levelzero
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-core/levelzero')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.15.8.bb (renamed from dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.2.3.bb)20
1 files changed, 11 insertions, 9 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.2.3.bb b/dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.15.8.bb
index 9ab0804f..8bade9f4 100644
--- a/dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.2.3.bb
+++ b/dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.15.8.bb
@@ -1,10 +1,10 @@
1SUMMARY = "oneAPI Level Zero Specification Headers and Loader" 1SUMMARY = "oneAPI Level Zero Specification Headers and Loader"
2HOMEPAGE = "https://github.com/oneapi-src/level-zero" 2HOMEPAGE = "https://github.com/oneapi-src/level-zero"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8956dfdba7f8169c4005d1e9753ffddc" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=97957beb2f7808ffa247e5d93e6442cc"
5 5
6SRC_URI = "git://github.com/oneapi-src/level-zero.git;protocol=https" 6SRC_URI = "git://github.com/oneapi-src/level-zero.git;protocol=https;branch=master"
7SRCREV = "0d30b1fa712253c68bfdfa3863d380df4301b8a4" 7SRCREV = "1685d01497428ca4d8b99200972b64685424d5c9"
8S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
9 9
10inherit cmake 10inherit cmake
@@ -14,7 +14,7 @@ UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"
14 14
15PACKAGES =+ "${PN}-headers ${PN}-samples ${PN}-loader" 15PACKAGES =+ "${PN}-headers ${PN}-samples ${PN}-loader"
16 16
17do_install_append () { 17do_install:append () {
18 install -d ${D}${bindir} ${D}${libdir} 18 install -d ${D}${bindir} ${D}${libdir}
19 install -m 755 ${B}/bin/zello* ${D}${bindir} 19 install -m 755 ${B}/bin/zello* ${D}${bindir}
20 20
@@ -22,10 +22,12 @@ do_install_append () {
22} 22}
23 23
24 24
25FILES_${PN}-headers = "${includedir}" 25FILES:${PN}-headers = "${includedir}"
26FILES_${PN}-samples = "${bindir} ${libdir}/libze_null* ${libdir}/libze_validation*" 26FILES:${PN}-samples = "${bindir} ${libdir}/libze_null* ${libdir}/libze_validation*"
27FILES_${PN}-loader = "${libdir}" 27FILES:${PN}-loader = "${libdir}"
28 28
29# PN-loader (non -dev/-dbg/nativesdk- package) contains symlink .so 29# PN-loader (non -dev/-dbg/nativesdk- package) contains symlink .so
30INSANE_SKIP_${PN}-loader = "dev-so" 30INSANE_SKIP:${PN}-loader = "dev-so"
31INSANE_SKIP_${PN}-samples = "dev-so" 31INSANE_SKIP:${PN}-samples = "dev-so"
32ALLOW_EMPTY:${PN} = "1"
33BBCLASSEXTEND = "native nativesdk"