summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.7.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.7.15.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.7.15.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.7.15.bb b/dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.7.15.bb
new file mode 100644
index 00000000..3a46a41e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-core/levelzero/level-zero_1.7.15.bb
@@ -0,0 +1,53 @@
1# FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'.
2# The following is the difference between the old and the new license text.
3# Please update the LICENSE value if needed, and summarize the changes in
4# the commit message via 'License-Update:' tag.
5# (example: 'License-Update: copyright years updated.')
6#
7# The changes:
8#
9# --- LICENSE
10# +++ LICENSE
11# @@ -1,6 +1,6 @@
12# MIT License
13#
14# -Copyright (c) 2019 Intel Corporation
15# +Copyright (C) 2019-2021 Intel Corporation
16#
17# Permission is hereby granted, free of charge, to any person obtaining a copy
18# of this software and associated documentation files (the "Software"), to deal
19#
20#
21
22SUMMARY = "oneAPI Level Zero Specification Headers and Loader"
23HOMEPAGE = "https://github.com/oneapi-src/level-zero"
24LICENSE = "MIT"
25LIC_FILES_CHKSUM = "file://LICENSE;md5=97957beb2f7808ffa247e5d93e6442cc"
26
27SRC_URI = "git://github.com/oneapi-src/level-zero.git;protocol=https;branch=master"
28SRCREV = "bb7fff05b801e26c3d7858e03e509d1089914d59"
29S = "${WORKDIR}/git"
30
31inherit cmake
32DEPENDS += "opencl-headers"
33
34UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"
35
36PACKAGES =+ "${PN}-headers ${PN}-samples ${PN}-loader"
37
38do_install:append () {
39 install -d ${D}${bindir} ${D}${libdir}
40 install -m 755 ${B}/bin/zello* ${D}${bindir}
41
42 oe_libinstall -C lib libze_null ${D}${libdir}
43}
44
45
46FILES:${PN}-headers = "${includedir}"
47FILES:${PN}-samples = "${bindir} ${libdir}/libze_null* ${libdir}/libze_validation*"
48FILES:${PN}-loader = "${libdir}"
49
50# PN-loader (non -dev/-dbg/nativesdk- package) contains symlink .so
51INSANE_SKIP:${PN}-loader = "dev-so"
52INSANE_SKIP:${PN}-samples = "dev-so"
53ALLOW_EMPTY:${PN} = "1"