summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-bsp')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb44
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch35
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb45
3 files changed, 124 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb
new file mode 100644
index 00000000..bdf32576
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Intel(R) Local Managability Service"
2DESCRIPTION = "Intel Local Manageability Service allows applications \
3to access the Intel Active Management Technology (AMT) firmware via \
4the Intel Management Engine Interface (MEI)."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
8
9COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10
11COMPATIBLE_HOST:libc-musl = "null"
12
13inherit cmake systemd features_check python3native
14
15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native pkgconfig-native python3-packaging-native"
16
17# Enable either connman or networkmanager or none but not both.
18PACKAGECONFIG ??= "connman"
19PACKAGECONFIG[connman] = "-DNETWORK_CN=ON, -DNETWORK_CN=OFF, connman"
20PACKAGECONFIG[networkmanager] = "-DNETWORK_NM=ON, -DNETWORK_NM=OFF, networkmanager"
21
22REQUIRED_DISTRO_FEATURES= "systemd"
23
24FILES:${PN} += "${datadir}/dbus-1/system-services/*.service"
25
26S = "${WORKDIR}/git"
27
28SYSTEMD_SERVICE:${PN} = "lms.service"
29
30SRC_URI = "git://github.com/intel/lms.git;branch=master;protocol=https \
31 "
32SRCREV = "388f115b2aeb3ea11499971c65f828daefd32c47"
33
34do_install:append() {
35 install -d ${D}${sysconfdir}/lms
36 install -d ${D}${systemd_system_unitdir}
37 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
38 install -d ${D}${sysconfdir}/udev/rules.d
39 install -m 0644 ${S}/UNS/linux_scripts/70-mei-wdt.rules ${D}${sysconfdir}/udev/rules.d/70-mei-wdt.rules
40}
41
42RDEPENDS:${PN} += "ace"
43
44CVE_STATUS[CVE-2018-1000535] = "cpe-incorrect: This CVE is for a different LMS - Lan Management System."
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch
new file mode 100644
index 00000000..ea86bc31
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch
@@ -0,0 +1,35 @@
1From 1f6f4e29769adb9d49a3c4831dd2ba61f6ccbdce Mon Sep 17 00:00:00 2001
2From: Yogesh Tyagi <yogesh.tyagi@intel.com>
3Date: Mon, 11 Mar 2024 13:13:32 +0800
4Subject: [PATCH] Makefile: Fix build Issue
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9In case build directory is different from source, make sure make is able to find the correct input files.
10
11Fixes:
12| dbus-binding-tool --prefix=thd_dbus_interface --mode=glib-server --output=thd_dbus_interface.h ../git/src/thd_dbus_interface.xml
13| glib-compile-resources --generate-source thermald-resource.gresource.xml
14| Failed to open file “thermald-resource.gresource.xml”: No such file or directory
15
16Upstream-Status: Submitted
17https://github.com/intel/thermal_daemon/pull/436
18
19Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
20---
21 Makefile.am | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/Makefile.am b/Makefile.am
25index dd2ef10..cb19e17 100644
26--- a/Makefile.am
27+++ b/Makefile.am
28@@ -97,6 +97,6 @@ thd_dbus_interface.h: $(top_srcdir)/src/thd_dbus_interface.xml
29 $(AM_V_GEN) dbus-binding-tool --prefix=thd_dbus_interface --mode=glib-server --output=$@ $<
30
31 thermald-resource.c: $(top_srcdir)/thermald-resource.gresource.xml
32- $(AM_V_GEN) glib-compile-resources --generate-source thermald-resource.gresource.xml
33+ $(AM_V_GEN) glib-compile-resources --generate-source --sourcedir=${top_srcdir} $<
34
35 CLEANFILES = $(BUILT_SOURCES)
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb
new file mode 100644
index 00000000..66765e56
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native upower libevdev"
10DEPENDS += "autoconf-archive-native"
11
12LICENSE = "GPL-2.0-only"
13LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
14
15SRC_URI = "git://github.com/intel/thermal_daemon/;branch=master;protocol=https \
16 file://0001-Makefile-Fix-build-Issue.patch \
17 "
18
19SRCREV = "ea8b773f76641a7a49d6584669e17371c22ad03e"
20S = "${WORKDIR}/git"
21
22inherit pkgconfig autotools systemd gtk-doc
23
24# gtkdocsize runs before autotools do_configure and it copies gtk-doc.m4 and fails
25# to copy becuase there is no m4 dir yet.
26do_configure:prepend () {
27 mkdir -p ${S}/m4
28}
29
30EXTRA_OECONF = " \
31 --with-systemdsystemunitdir=${systemd_system_unitdir} \
32 "
33
34FILES:${PN} += "${datadir}/dbus-1"
35
36SYSTEMD_SERVICE:${PN} = "thermald.service"
37
38COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
39
40CONFFILES:${PN} = " \
41 ${sysconfdir}/thermald/thermal-conf.xml \
42 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
43 "
44
45UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"