summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-bsp')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2109.0.0.0.bb)25
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch35
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb (renamed from dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.4.4.bb)17
3 files changed, 59 insertions, 18 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2109.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb
index af5a2314..bdf32576 100644
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2109.0.0.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb
@@ -8,13 +8,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
8 8
9COMPATIBLE_HOST = '(i.86|x86_64).*-linux' 9COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10 10
11COMPATIBLE_HOST_libc-musl = "null" 11COMPATIBLE_HOST:libc-musl = "null"
12 12
13inherit cmake systemd features_check 13inherit cmake systemd features_check python3native
14 14
15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native" 15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native pkgconfig-native python3-packaging-native"
16
17EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
18 16
19# Enable either connman or networkmanager or none but not both. 17# Enable either connman or networkmanager or none but not both.
20PACKAGECONFIG ??= "connman" 18PACKAGECONFIG ??= "connman"
@@ -23,19 +21,24 @@ PACKAGECONFIG[networkmanager] = "-DNETWORK_NM=ON, -DNETWORK_NM=OFF, networkmanag
23 21
24REQUIRED_DISTRO_FEATURES= "systemd" 22REQUIRED_DISTRO_FEATURES= "systemd"
25 23
26FILES_${PN} += "${datadir}/dbus-1/system-services/*.service" 24FILES:${PN} += "${datadir}/dbus-1/system-services/*.service"
27 25
28S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
29 27
30SYSTEMD_SERVICE_${PN} = "lms.service" 28SYSTEMD_SERVICE:${PN} = "lms.service"
31 29
32SRC_URI = "git://github.com/intel/lms.git \ 30SRC_URI = "git://github.com/intel/lms.git;branch=master;protocol=https \
33 " 31 "
34SRCREV = "e0ebda9d1e7884b51293b71c1bcda511a7942e1a" 32SRCREV = "388f115b2aeb3ea11499971c65f828daefd32c47"
35 33
36do_install_append() { 34do_install:append() {
35 install -d ${D}${sysconfdir}/lms
37 install -d ${D}${systemd_system_unitdir} 36 install -d ${D}${systemd_system_unitdir}
38 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir} 37 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
38 install -d ${D}${sysconfdir}/udev/rules.d
39 install -m 0644 ${S}/UNS/linux_scripts/70-mei-wdt.rules ${D}${sysconfdir}/udev/rules.d/70-mei-wdt.rules
39} 40}
40 41
41RDEPENDS_${PN} += "ace" 42RDEPENDS:${PN} += "ace"
43
44CVE_STATUS[CVE-2018-1000535] = "cpe-incorrect: This CVE is for a different LMS - Lan Management System."
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch
new file mode 100644
index 00000000..ea86bc31
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch
@@ -0,0 +1,35 @@
1From 1f6f4e29769adb9d49a3c4831dd2ba61f6ccbdce Mon Sep 17 00:00:00 2001
2From: Yogesh Tyagi <yogesh.tyagi@intel.com>
3Date: Mon, 11 Mar 2024 13:13:32 +0800
4Subject: [PATCH] Makefile: Fix build Issue
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9In case build directory is different from source, make sure make is able to find the correct input files.
10
11Fixes:
12| dbus-binding-tool --prefix=thd_dbus_interface --mode=glib-server --output=thd_dbus_interface.h ../git/src/thd_dbus_interface.xml
13| glib-compile-resources --generate-source thermald-resource.gresource.xml
14| Failed to open file “thermald-resource.gresource.xml”: No such file or directory
15
16Upstream-Status: Submitted
17https://github.com/intel/thermal_daemon/pull/436
18
19Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
20---
21 Makefile.am | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/Makefile.am b/Makefile.am
25index dd2ef10..cb19e17 100644
26--- a/Makefile.am
27+++ b/Makefile.am
28@@ -97,6 +97,6 @@ thd_dbus_interface.h: $(top_srcdir)/src/thd_dbus_interface.xml
29 $(AM_V_GEN) dbus-binding-tool --prefix=thd_dbus_interface --mode=glib-server --output=$@ $<
30
31 thermald-resource.c: $(top_srcdir)/thermald-resource.gresource.xml
32- $(AM_V_GEN) glib-compile-resources --generate-source thermald-resource.gresource.xml
33+ $(AM_V_GEN) glib-compile-resources --generate-source --sourcedir=${top_srcdir} $<
34
35 CLEANFILES = $(BUILT_SOURCES)
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.4.4.bb b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb
index efad2fe3..66765e56 100644
--- a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.4.4.bb
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb
@@ -7,20 +7,23 @@ compensation using available cooling methods."
7HOMEPAGE = "https://github.com/01org/thermal_daemon" 7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8 8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native upower libevdev" 9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native upower libevdev"
10LICENSE = "GPLv2" 10DEPENDS += "autoconf-archive-native"
11
12LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848" 13LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
12 14
13SRC_URI = "git://github.com/intel/thermal_daemon/ \ 15SRC_URI = "git://github.com/intel/thermal_daemon/;branch=master;protocol=https \
16 file://0001-Makefile-Fix-build-Issue.patch \
14 " 17 "
15 18
16SRCREV = "d6f89c9e8afdb449a442646da46f3140634175c1" 19SRCREV = "ea8b773f76641a7a49d6584669e17371c22ad03e"
17S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
18 21
19inherit pkgconfig autotools systemd gtk-doc 22inherit pkgconfig autotools systemd gtk-doc
20 23
21# gtkdocsize runs before autotools do_configure and it copies gtk-doc.m4 and fails 24# gtkdocsize runs before autotools do_configure and it copies gtk-doc.m4 and fails
22# to copy becuase there is no m4 dir yet. 25# to copy becuase there is no m4 dir yet.
23do_configure_prepend () { 26do_configure:prepend () {
24 mkdir -p ${S}/m4 27 mkdir -p ${S}/m4
25} 28}
26 29
@@ -28,13 +31,13 @@ EXTRA_OECONF = " \
28 --with-systemdsystemunitdir=${systemd_system_unitdir} \ 31 --with-systemdsystemunitdir=${systemd_system_unitdir} \
29 " 32 "
30 33
31FILES_${PN} += "${datadir}/dbus-1/system-services/*.service" 34FILES:${PN} += "${datadir}/dbus-1"
32 35
33SYSTEMD_SERVICE_${PN} = "thermald.service" 36SYSTEMD_SERVICE:${PN} = "thermald.service"
34 37
35COMPATIBLE_HOST = '(i.86|x86_64).*-linux' 38COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
36 39
37CONFFILES_${PN} = " \ 40CONFFILES:${PN} = " \
38 ${sysconfdir}/thermald/thermal-conf.xml \ 41 ${sysconfdir}/thermald/thermal-conf.xml \
39 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \ 42 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
40 " 43 "