summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-bsp/amt
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-bsp/amt')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2003.0.0.0.diff30
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2003.0.0.0.bb37
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb44
3 files changed, 44 insertions, 67 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2003.0.0.0.diff b/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2003.0.0.0.diff
deleted file mode 100644
index e000a160..00000000
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2003.0.0.0.diff
+++ /dev/null
@@ -1,30 +0,0 @@
1From ec7d732a6a23e90be34840b0f1a57e5199d393cf Mon Sep 17 00:00:00 2001
2From: Alexander Usyskin <alexander.usyskin@intel.com>
3Date: Mon, 17 Jun 2019 13:27:33 +0300
4Subject: [PATCH] lms: drop rpath definitions
5
6Yocto fail to compile with this definitions.
7
8Upstream-Status: Inappropriate [configuration]
9Signed-off-by: Alexander Usyskin <alexander.usyskin@intel.com>
10---
11 CMakeLists.txt | 3 ---
12 1 file changed, 3 deletions(-)
13
14diff --git a/CMakeLists.txt b/CMakeLists.txt
15index e22ff05..14d5dd1 100644
16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt
18@@ -112,9 +112,6 @@ install (DIRECTORY Docs/Licenses
19 FILES_MATCHING PATTERN "LICENSE.*"
20 )
21
22-list (APPEND CMAKE_INSTALL_RPATH "${PROJECT_BINARY_DIR}/UNS/GMS_COMMON")
23-list (APPEND CMAKE_INSTALL_RPATH "${PROJECT_BINARY_DIR}/WsmanClient")
24-
25 if (BUILD_TESTS)
26 include (gtest.cmake)
27 endif (BUILD_TESTS)
28--
292.7.4
30
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2003.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2003.0.0.0.bb
deleted file mode 100644
index 1067ccbd..00000000
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2003.0.0.0.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1SUMMARY = "Intel(R) Local Managability Service"
2DESCRIPTION = "Intel Local Manageability Service allows applications \
3to access the Intel Active Management Technology (AMT) firmware via \
4the Intel Management Engine Interface (MEI)."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
8
9COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10
11COMPATIBLE_HOST_libc-musl = "null"
12
13inherit cmake systemd
14
15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native connman"
16
17EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
18
19REQUIRED_DISTRO_FEATURES= "systemd"
20
21FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
22
23S = "${WORKDIR}/git"
24
25SYSTEMD_SERVICE_${PN} = "lms.service"
26
27SRC_URI = "git://github.com/intel/lms.git"
28SRCREV = "e425f34fadf9bb71228ffa23c6459331d86a0ab2"
29
30SRC_URI_append = " file://lms_drop_rpath_${PV}.diff"
31
32do_install_append() {
33 install -d ${D}${systemd_system_unitdir}
34 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
35}
36
37RDEPENDS_${PN} += "ace"
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb
new file mode 100644
index 00000000..bdf32576
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Intel(R) Local Managability Service"
2DESCRIPTION = "Intel Local Manageability Service allows applications \
3to access the Intel Active Management Technology (AMT) firmware via \
4the Intel Management Engine Interface (MEI)."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
8
9COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10
11COMPATIBLE_HOST:libc-musl = "null"
12
13inherit cmake systemd features_check python3native
14
15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native pkgconfig-native python3-packaging-native"
16
17# Enable either connman or networkmanager or none but not both.
18PACKAGECONFIG ??= "connman"
19PACKAGECONFIG[connman] = "-DNETWORK_CN=ON, -DNETWORK_CN=OFF, connman"
20PACKAGECONFIG[networkmanager] = "-DNETWORK_NM=ON, -DNETWORK_NM=OFF, networkmanager"
21
22REQUIRED_DISTRO_FEATURES= "systemd"
23
24FILES:${PN} += "${datadir}/dbus-1/system-services/*.service"
25
26S = "${WORKDIR}/git"
27
28SYSTEMD_SERVICE:${PN} = "lms.service"
29
30SRC_URI = "git://github.com/intel/lms.git;branch=master;protocol=https \
31 "
32SRCREV = "388f115b2aeb3ea11499971c65f828daefd32c47"
33
34do_install:append() {
35 install -d ${D}${sysconfdir}/lms
36 install -d ${D}${systemd_system_unitdir}
37 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
38 install -d ${D}${sysconfdir}/udev/rules.d
39 install -m 0644 ${S}/UNS/linux_scripts/70-mei-wdt.rules ${D}${sysconfdir}/udev/rules.d/70-mei-wdt.rules
40}
41
42RDEPENDS:${PN} += "ace"
43
44CVE_STATUS[CVE-2018-1000535] = "cpe-incorrect: This CVE is for a different LMS - Lan Management System."