summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb
new file mode 100644
index 00000000..36e45dd5
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Intel(R) Local Managability Service"
2DESCRIPTION = "Intel Local Manageability Service allows applications \
3to access the Intel Active Management Technology (AMT) firmware via \
4the Intel Management Engine Interface (MEI)."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
8
9COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10
11COMPATIBLE_HOST:libc-musl = "null"
12
13inherit cmake systemd features_check
14
15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native pkgconfig-native"
16
17EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
18
19# Enable either connman or networkmanager or none but not both.
20PACKAGECONFIG ??= "connman"
21PACKAGECONFIG[connman] = "-DNETWORK_CN=ON, -DNETWORK_CN=OFF, connman"
22PACKAGECONFIG[networkmanager] = "-DNETWORK_NM=ON, -DNETWORK_NM=OFF, networkmanager"
23
24REQUIRED_DISTRO_FEATURES= "systemd"
25
26FILES:${PN} += "${datadir}/dbus-1/system-services/*.service"
27
28S = "${WORKDIR}/git"
29
30SYSTEMD_SERVICE:${PN} = "lms.service"
31
32SRC_URI = "git://github.com/intel/lms.git;branch=master;protocol=https \
33 "
34SRCREV = "4db4ceb3f70cd1b907747646dda6785db7b247d7"
35
36do_install:append() {
37 install -d ${D}${systemd_system_unitdir}
38 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
39 install -d ${D}${sysconfdir}/udev/rules.d
40 install -m 0644 ${S}/UNS/linux_scripts/70-mei-wdt.rules ${D}${sysconfdir}/udev/rules.d/70-mei-wdt.rules
41}
42
43RDEPENDS:${PN} += "ace"
44
45# This CVE is for Lan Management System software and not this lms.
46CVE_CHECK_IGNORE += "CVE-2018-1000535"