summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2003.0.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2003.0.0.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2003.0.0.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2003.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2003.0.0.0.bb
new file mode 100644
index 00000000..1067ccbd
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2003.0.0.0.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Intel(R) Local Managability Service"
2DESCRIPTION = "Intel Local Manageability Service allows applications \
3to access the Intel Active Management Technology (AMT) firmware via \
4the Intel Management Engine Interface (MEI)."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
8
9COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10
11COMPATIBLE_HOST_libc-musl = "null"
12
13inherit cmake systemd
14
15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native connman"
16
17EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
18
19REQUIRED_DISTRO_FEATURES= "systemd"
20
21FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
22
23S = "${WORKDIR}/git"
24
25SYSTEMD_SERVICE_${PN} = "lms.service"
26
27SRC_URI = "git://github.com/intel/lms.git"
28SRCREV = "e425f34fadf9bb71228ffa23c6459331d86a0ab2"
29
30SRC_URI_append = " file://lms_drop_rpath_${PV}.diff"
31
32do_install_append() {
33 install -d ${D}${systemd_system_unitdir}
34 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
35}
36
37RDEPENDS_${PN} += "ace"