summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-bsp/amt/files
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-bsp/amt/files')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/files/0001-CIM_Framework-CMakeLists.txt-turn-OFF-BUILD_LIBCIM.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/0001-CIM_Framework-CMakeLists.txt-turn-OFF-BUILD_LIBCIM.patch b/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/0001-CIM_Framework-CMakeLists.txt-turn-OFF-BUILD_LIBCIM.patch
new file mode 100644
index 00000000..d3b10319
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/0001-CIM_Framework-CMakeLists.txt-turn-OFF-BUILD_LIBCIM.patch
@@ -0,0 +1,34 @@
1From 7f24e190bde4ee120e284cbdb59eed36ef8818f8 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 10 Sep 2020 15:44:09 +0800
4Subject: [PATCH] CIM_Framework/CMakeLists.txt: turn OFF BUILD_LIBCIM
5
6BUILD_LIBCIM forces a check for libcmpisfcc in the top level makefile
7for openwsman while the cim plugin itself isn't built if DISABLE_PLUGINS
8is turned ON. This leads to an error when that library isn't present
9even though we're not building that part of the code at all.
10
11Turn OFF BUILD_LIBCIM in addition to DISABLE_PLUGINS.
12
13Upstream-Status: Submitted [https://github.com/intel/lms/pull/4]
14
15Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
16---
17 CIM_Framework/CMakeLists.txt | 1 +
18 1 file changed, 1 insertion(+)
19
20diff --git a/CIM_Framework/CMakeLists.txt b/CIM_Framework/CMakeLists.txt
21index 9d287f9..60219b3 100644
22--- a/CIM_Framework/CMakeLists.txt
23+++ b/CIM_Framework/CMakeLists.txt
24@@ -53,6 +53,7 @@ externalproject_add (openwsman
25 -DUSE_PAM=OFF
26 -DENABLE_EVENTING_SUPPORT=OFF
27 -DBUILD_SHARED_LIBS=OFF
28+ -DBUILD_LIBCIM=OFF
29 ${WSMAN_STATIC_RUNTIME}
30 ${WSMAN_ARCH}
31 ${USE_TOOLCHAIN}
32--
332.26.2
34