summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-opencv
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/meta-python/recipes-opencv')
-rw-r--r--dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2024.1.0.bb (renamed from dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb)24
1 files changed, 12 insertions, 12 deletions
diff --git a/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb b/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2024.1.0.bb
index 56705f63..de765d6c 100644
--- a/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r3.1.bb
+++ b/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2024.1.0.bb
@@ -5,29 +5,29 @@ environment, performs static model analysis, and adjusts deep \
5learning models for optimal execution on end-point target devices." 5learning models for optimal execution on end-point target devices."
6HOMEPAGE = "https://01.org/openvinotoolkit" 6HOMEPAGE = "https://01.org/openvinotoolkit"
7 7
8SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \ 8SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2024/1;lfs=0 \
9 " 9 "
10SRCREV = "fe3f978b98c86eaeed3cbdc280e1ffd0bc50d278" 10SRCREV = "f4afc983258bcb2592d999ed6700043fdb58ad78"
11 11
12LICENSE = "Apache-2.0" 12LICENSE = "Apache-2.0"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" 13LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
14 14
15CVE_PRODUCT = "intel:openvino" 15CVE_PRODUCT = "intel:openvino"
16
17S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
18 17
19do_install() { 18inherit setuptools3
20 mkdir -p ${D}${datadir}/openvino/model-optimizer
21 cp -r model-optimizer ${D}${datadir}/openvino/
22}
23 19
24RDEPENDS_${PN} += " \ 20SETUPTOOLS_SETUP_PATH = "${WORKDIR}/git/tools/mo"
25 python3-numpy \ 21
26 python3-protobuf \ 22RDEPENDS:${PN} += " \
27 python3-defusedxml \ 23 python3-defusedxml \
24 python3-fastjsonschema \
28 python3-networkx \ 25 python3-networkx \
29 python3-test-generator \ 26 python3-numpy \
27 python3-protobuf \
28 python3-requests \
29 python3-urllib3 \
30 bash \ 30 bash \
31 " 31 "
32 32
33FILES_${PN} += "${datadir}/openvino" 33UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+\.\d+\.\d+))$"