summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2022.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2022.1.1.bb')
-rw-r--r--dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2022.1.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2022.1.1.bb b/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2022.1.1.bb
new file mode 100644
index 00000000..bd98b82b
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2022.1.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "OpenVINO Model Optimzer"
2DESCRIPTION = "Model Optimizer is a cross-platform command-line tool that \
3facilitates the transition between the training and deployment \
4environment, performs static model analysis, and adjusts deep \
5learning models for optimal execution on end-point target devices."
6HOMEPAGE = "https://01.org/openvinotoolkit"
7
8SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2022/1.1;lfs=0 \
9 "
10SRCREV = "39aba80957e10b66a6c8f3f590c2d90e8238ca75"
11
12LICENSE = "Apache-2.0"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
14
15CVE_PRODUCT = "intel:openvino"
16S = "${WORKDIR}/git"
17
18inherit setuptools3
19
20SETUPTOOLS_SETUP_PATH = "${WORKDIR}/git/tools/mo"
21
22RDEPENDS:${PN} += " \
23 python3-numpy \
24 python3-protobuf \
25 python3-defusedxml \
26 python3-networkx \
27 python3-requests \
28 python3-urllib3 \
29 bash \
30 "
31
32UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"