summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2021.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2021.4.bb')
-rw-r--r--dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2021.4.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2021.4.bb b/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2021.4.bb
new file mode 100644
index 00000000..b38d419b
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2021.4.bb
@@ -0,0 +1,35 @@
1SUMMARY = "OpenVINO Model Optimzer"
2DESCRIPTION = "Model Optimizer is a cross-platform command-line tool that \
3facilitates the transition between the training and deployment \
4environment, performs static model analysis, and adjusts deep \
5learning models for optimal execution on end-point target devices."
6HOMEPAGE = "https://01.org/openvinotoolkit"
7
8SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2021/4;lfs=0 \
9 "
10SRCREV = "5cee8bbf29797f4544b343e803de957e9f041f92"
11
12LICENSE = "Apache-2.0"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
14
15CVE_PRODUCT = "intel:openvino"
16
17S = "${WORKDIR}/git"
18
19do_install() {
20 mkdir -p ${D}${datadir}/openvino/model-optimizer
21 cp -r model-optimizer ${D}${datadir}/openvino/
22}
23
24RDEPENDS:${PN} += " \
25 python3-numpy \
26 python3-protobuf \
27 python3-defusedxml \
28 python3-networkx \
29 python3-test-generator \
30 python3-requests \
31 python3-urllib3 \
32 bash \
33 "
34
35FILES:${PN} += "${datadir}/openvino"