summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb63
1 files changed, 0 insertions, 63 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb
deleted file mode 100644
index 8a09934d..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb
+++ /dev/null
@@ -1,63 +0,0 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=23;md5=4a985f2545dd5a846e205b1e60a51cd9 \
9 file://NOTICES.txt;md5=db621145dfb627436bc90ad600386801"
10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;name=igc;branch=master \
12 git://github.com/intel/vc-intrinsics.git;protocol=https;destsuffix=git/vc-intrinsics;name=vc;branch=master \
13 file://0001-llvm_deps.cmake-don-t-copy-header-file-when-building.patch \
14 file://0003-Improve-Reproducibility-for-src-package.patch \
15 file://0004-find-external-llvm-tblgen.patch \
16 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \
17 "
18
19SRCREV_igc = "3ba8dde8c414a0e47df58b1bba12a64f8ba2089e"
20SRCREV_vc = "e5ad7e02aa4aa21a3cd7b3e5d1f3ec9b95f58872"
21
22# Used to replace with relative path in reproducibility patch
23export B
24
25S = "${WORKDIR}/git"
26
27inherit cmake pkgconfig
28
29CXXFLAGS:append = " -Wno-error=nonnull"
30
31COMPATIBLE_HOST = '(x86_64).*-linux'
32COMPATIBLE_HOST:libc-musl = "null"
33
34DEPENDS += " flex-native bison-native clang opencl-clang"
35DEPENDS:append:class-target = " clang-cross-x86_64 intel-graphics-compiler-native"
36
37RDEPENDS:${PN} += "opencl-clang"
38
39PACKAGECONFIG ??= "vc"
40PACKAGECONFIG[vc] = "-DIGC_BUILD__VC_ENABLED=ON -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR=ON -DIGC_OPTION__USE_KHRONOS_SPIRV_TRANSLATOR_IN_VC=ON -DIGC_OPTION__SPIRV_TRANSLATOR_MODE=Prebuilds,-DIGC_BUILD__VC_ENABLED=OFF,"
41
42EXTRA_OECMAKE = " \
43 -DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} \
44 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
45 -DVC_INTRINSICS_SRC="${S}/vc-intrinsics" \
46 -DIGC_OPTION__LLVM_MODE=Prebuilds \
47 "
48
49do_install:append:class-native () {
50 install -d ${D}${bindir}
51 install ${B}/IGC/Release/elf_packager ${D}${bindir}/
52 if ${@bb.utils.contains('PACKAGECONFIG', 'vc', 'true', 'false', d)}; then
53 install ${B}/IGC/Release/CMCLTranslatorTool ${D}${bindir}/
54 fi
55}
56
57BBCLASSEXTEND = "native nativesdk"
58
59UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$"
60
61FILES:${PN} += " \
62 ${libdir}/igc/NOTICES.txt \
63 "