summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.2714.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.2714.1.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.2714.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.2714.1.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.2714.1.bb
new file mode 100644
index 00000000..7070223d
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.2714.1.bb
@@ -0,0 +1,33 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=25;md5=4abf1738ff96b18e34186eb763e28eeb"
9
10SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;branch=releases/igc-1.0.2714 \
11 file://0001-skip-execution-of-ElfPackager.patch \
12 file://0002-comment-out-dump-functions.patch \
13 "
14
15SRCREV = "710e6273dd1698e8b11763e9ff74c0dd57dddb83"
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21COMPATIBLE_HOST = '(x86_64).*-linux'
22COMPATIBLE_HOST_libc-musl = "null"
23
24DEPENDS += " flex-native bison-native clang opencl-clang"
25DEPENDS_append_class-target = " clang-cross-x86_64"
26
27RDEPENDS_${PN} += "opencl-clang"
28
29EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=9.0.0 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
30
31BBCLASSEXTEND = "native nativesdk"
32
33UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$"