summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.13463.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.13463.18.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.13463.18.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.13463.18.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.13463.18.bb
new file mode 100644
index 00000000..34cf9a6b
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.13463.18.bb
@@ -0,0 +1,77 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & Apache-2.0"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://LICENSE.md;md5=488d74376edf2765f6e78d271543dde3 \
9 file://NOTICES.txt;md5=7f4fbc3eb2c34807465e63b1ec3c9d1a"
10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;name=igc;branch=releases/igc-1.0.13463 \
12 git://github.com/intel/vc-intrinsics.git;protocol=https;destsuffix=git/vc-intrinsics;name=vc;nobranch=1 \
13 git://github.com/KhronosGroup/SPIRV-Tools.git;protocol=https;destsuffix=git/SPIRV-Tools;name=spirv-tools;branch=main \
14 git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=git/SPIRV-Headers;name=spirv-headers;branch=main \
15 file://0003-Improve-Reproducibility-for-src-package.patch \
16 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \
17 file://0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch \
18 "
19
20SRC_URI:append:class-native = " file://0001-fix-tblgen.patch"
21
22SRCREV_igc = "0efd329d2def513556b06f3138fec3766087c6da"
23SRCREV_vc = "dd72efa3b4aafdbbf599e6f3c6f8c55450e348de"
24SRCREV_spirv-tools = "44d72a9b36702f093dd20815561a56778b2d181e"
25SRCREV_spirv-headers = "1feaf4414eb2b353764d01d88f8aa4bcc67b60db"
26
27SRCREV_FORMAT = "igc_vc_spirv-tools_spirv-headers"
28
29# Used to replace with relative path in reproducibility patch
30export B
31
32S = "${WORKDIR}/git"
33
34inherit cmake pkgconfig
35
36CXXFLAGS:append = " -Wno-error=nonnull"
37
38COMPATIBLE_HOST = '(x86_64).*-linux'
39COMPATIBLE_HOST:libc-musl = "null"
40
41DEPENDS += " flex-native bison-native clang opencl-clang"
42DEPENDS:append:class-target = " clang-cross-x86_64 intel-graphics-compiler-native"
43
44RDEPENDS:${PN} += "opencl-clang"
45
46PACKAGECONFIG ??= "vc"
47PACKAGECONFIG[vc] = "-DIGC_BUILD__VC_ENABLED=ON -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR=ON -DIGC_OPTION__SPIRV_TRANSLATOR_MODE=Prebuilds,-DIGC_BUILD__VC_ENABLED=OFF,"
48
49EXTRA_OECMAKE = " \
50 -DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} \
51 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
52 -DVC_INTRINSICS_SRC="${S}/vc-intrinsics" \
53 -DIGC_OPTION__LLVM_MODE=Prebuilds \
54 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
55 -DLLVM_LINK_EXE=${STAGING_BINDIR_NATIVE}/llvm-link \
56 -DCLANG_EXE=${STAGING_BINDIR_NATIVE}/clang \
57 "
58
59do_install:append:class-native () {
60 install -d ${D}${bindir}
61 install ${B}/IGC/Release/elf_packager ${D}${bindir}/
62 if ${@bb.utils.contains('PACKAGECONFIG', 'vc', 'true', 'false', d)}; then
63 install ${B}/IGC/Release/CMCLTranslatorTool ${D}${bindir}/
64 install ${B}/IGC/Release/vcb ${D}${bindir}/
65 fi
66}
67
68BBCLASSEXTEND = "native nativesdk"
69
70UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$"
71
72FILES:${PN} += " \
73 ${libdir}/igc/NOTICES.txt \
74 "
75
76# libigc.so contains buildpaths
77INSANE_SKIP:${PN} += "buildpaths"