summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch25
1 files changed, 14 insertions, 11 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch
index b886b95d..6f7cdff8 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch
@@ -1,6 +1,6 @@
1From 2475dfc1350f73a243c9fc223a9f06af85321d56 Mon Sep 17 00:00:00 2001 1From ad3e325c1af4d6533fd9b3dfc5208267b678327a Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Tue, 2 Jul 2019 08:36:34 +0800 3Date: Thu, 6 Feb 2020 18:25:19 +0800
4Subject: [PATCH] don't use LD_LIBRARY_PATH for native offline compiler 4Subject: [PATCH] don't use LD_LIBRARY_PATH for native offline compiler
5 5
6Let us supply the correct path for it to be able to find the correct 6Let us supply the correct path for it to be able to find the correct
@@ -9,19 +9,19 @@ libraries.
9Upstream-Status: Inappropriate 9Upstream-Status: Inappropriate
10 10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12 12Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
13--- 13---
14 runtime/built_ins/kernels/CMakeLists.txt | 2 +- 14 runtime/built_ins/kernels/CMakeLists.txt | 2 +-
15 runtime/scheduler/scheduler_binary.cmake | 2 +- 15 runtime/scheduler/scheduler_binary.cmake | 2 +-
16 2 files changed, 2 insertions(+), 2 deletions(-) 16 2 files changed, 2 insertions(+), 2 deletions(-)
17 17
18diff --git a/runtime/built_ins/kernels/CMakeLists.txt b/runtime/built_ins/kernels/CMakeLists.txt 18diff --git a/runtime/built_ins/kernels/CMakeLists.txt b/runtime/built_ins/kernels/CMakeLists.txt
19index 5dc9fe1b..e258847d 100644 19index 863dba145..a385cf768 100644
20--- a/runtime/built_ins/kernels/CMakeLists.txt 20--- a/runtime/built_ins/kernels/CMakeLists.txt
21+++ b/runtime/built_ins/kernels/CMakeLists.txt 21+++ b/runtime/built_ins/kernels/CMakeLists.txt
22@@ -51,7 +51,7 @@ function(compile_builtin gen_type platform_type builtin) 22@@ -66,7 +66,7 @@ function(compile_builtin gen_type platform_type builtin bits builtin_options)
23 if(DEFINED IGDRCL__IGC_LIBRARY_PATH) 23 if(DEFINED NEO__IGC_LIBRARY_PATH)
24 set(cloc_cmd_prefix LD_LIBRARY_PATH=${IGDRCL__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>) 24 set(cloc_cmd_prefix LD_LIBRARY_PATH=${NEO__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>)
25 else() 25 else()
26- set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>) 26- set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>)
27+ set(cloc_cmd_prefix ocloc) 27+ set(cloc_cmd_prefix ocloc)
@@ -29,15 +29,18 @@ index 5dc9fe1b..e258847d 100644
29 endif() 29 endif()
30 list(APPEND __cloc__options__ "-cl-kernel-arg-info") 30 list(APPEND __cloc__options__ "-cl-kernel-arg-info")
31diff --git a/runtime/scheduler/scheduler_binary.cmake b/runtime/scheduler/scheduler_binary.cmake 31diff --git a/runtime/scheduler/scheduler_binary.cmake b/runtime/scheduler/scheduler_binary.cmake
32index 1b12592b..ed9f375d 100644 32index a7015b909..a720d2f5c 100644
33--- a/runtime/scheduler/scheduler_binary.cmake 33--- a/runtime/scheduler/scheduler_binary.cmake
34+++ b/runtime/scheduler/scheduler_binary.cmake 34+++ b/runtime/scheduler/scheduler_binary.cmake
35@@ -37,7 +37,7 @@ function(compile_kernel target gen_type platform_type kernel) 35@@ -37,7 +37,7 @@ function(compile_kernel target gen_type platform_type kernel)
36 if(DEFINED IGDRCL__IGC_LIBRARY_PATH) 36 if(DEFINED NEO__IGC_LIBRARY_PATH)
37 set(cloc_cmd_prefix LD_LIBRARY_PATH=${IGDRCL__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>) 37 set(cloc_cmd_prefix LD_LIBRARY_PATH=${NEO__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>)
38 else() 38 else()
39- set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>) 39- set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>)
40+ set(cloc_cmd_prefix ocloc) 40+ set(cloc_cmd_prefix ocloc)
41 endif() 41 endif()
42 endif() 42 endif()
43 list(APPEND __cloc__options__ "-cl-kernel-arg-info") 43 list(APPEND __cloc__options__ "-cl-kernel-arg-info")
44--
452.17.1
46