summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-core')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/dnn/onednn_3.4.1.bb (renamed from dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.7.1.bb)11
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch28
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch37
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch64
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/6a1b2ffae0cc12467838bc671e3b089924de90a6.patch33
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/ec35a6f8e60ba77e59a6f2bfec27011e0ab34dda.patch63
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb49
7 files changed, 7 insertions, 278 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.7.1.bb b/dynamic-layers/clang-layer/recipes-core/dnn/onednn_3.4.1.bb
index ad3c1638..2fa3f627 100644
--- a/dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.7.1.bb
+++ b/dynamic-layers/clang-layer/recipes-core/dnn/onednn_3.4.1.bb
@@ -3,7 +3,7 @@ SUMMARY = "Deep Neural Network Library"
3DESCRIPTION = "This software is a user mode library that accelerates\ 3DESCRIPTION = "This software is a user mode library that accelerates\
4deep-learning applications and frameworks on Intel architecture." 4deep-learning applications and frameworks on Intel architecture."
5LICENSE = "Apache-2.0 & BSD-3-Clause & BSL-1.0" 5LICENSE = "Apache-2.0 & BSD-3-Clause & BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=b48e3de3bfd47c27882a0d85b20823f5 \ 6LIC_FILES_CHKSUM = "file://LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \
7 file://tests/gtests/gtest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \ 7 file://tests/gtests/gtest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
8 file://src/cpu/x64/xbyak/COPYRIGHT;md5=3b9bf048d063d54cdb28964db558bcc7 \ 8 file://src/cpu/x64/xbyak/COPYRIGHT;md5=3b9bf048d063d54cdb28964db558bcc7 \
9 file://src/common/ittnotify/LICENSE.BSD;md5=e671ff178b24a95a382ba670503c66fb \ 9 file://src/common/ittnotify/LICENSE.BSD;md5=e671ff178b24a95a382ba670503c66fb \
@@ -12,9 +12,11 @@ SECTION = "lib"
12 12
13inherit pkgconfig cmake ptest 13inherit pkgconfig cmake ptest
14 14
15DNN_BRANCH = "rls-v${@'.'.join(d.getVar('PV').split('.')[0:2])}"
16
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
16SRCREV = "a96c94f39773df35760d037d1ebe580dcf79c137" 18SRCREV = "f5ff0a6de16c130053bec1a1aec3a9b826c66f78"
17SRC_URI = "git://github.com/oneapi-src/oneDNN.git;branch=rls-v2.7;protocol=https \ 19SRC_URI = "git://github.com/oneapi-src/oneDNN.git;branch=${DNN_BRANCH};protocol=https \
18 file://run-ptest \ 20 file://run-ptest \
19 " 21 "
20 22
@@ -32,10 +34,11 @@ EXTRA_OECMAKE += " \
32 -DDNNL_CPU_RUNTIME=OMP \ 34 -DDNNL_CPU_RUNTIME=OMP \
33 -DDNNL_ARCH_OPT_FLAGS="" \ 35 -DDNNL_ARCH_OPT_FLAGS="" \
34 -DCMAKE_SKIP_RPATH=ON \ 36 -DCMAKE_SKIP_RPATH=ON \
37 -DONEDNN_BUILD_GRAPH=OFF \
35 " 38 "
36 39
37PACKAGECONFIG ??= "gpu" 40PACKAGECONFIG ??= "gpu"
38PACKAGECONFIG[gpu] = "-DDNNL_GPU_RUNTIME=OCL, , opencl-headers ocl-icd, intel-compute-runtime" 41PACKAGECONFIG[gpu] = "-DDNNL_GPU_RUNTIME=OCL, , opencl-headers virtual/opencl-icd, intel-compute-runtime"
39 42
40do_install:append () { 43do_install:append () {
41 install -d ${D}${bindir}/mkl-dnn/tests/benchdnn/inputs 44 install -d ${D}${bindir}/mkl-dnn/tests/benchdnn/inputs
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch
deleted file mode 100644
index 4e25420c..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From b9bc0df996d1e65fd70d5eb2d40866693f23bb67 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 24 Jun 2021 17:53:27 +0800
4Subject: [PATCH] CMakeLists.txt: link with libclang-cpp library instead
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10 CMakeLists.txt | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/CMakeLists.txt b/CMakeLists.txt
14index ef88317e..7507d6a5 100644
15--- a/CMakeLists.txt
16+++ b/CMakeLists.txt
17@@ -281,7 +281,7 @@ if (WASM_ENABLED)
18 list(APPEND ISPC_TARGETS wasm-i32x4)
19 endif()
20
21-set(CLANG_LIBRARY_LIST clangFrontend clangDriver clangSerialization clangParse clangSema clangAnalysis clangAST clangBasic clangEdit clangLex)
22+set(CLANG_LIBRARY_LIST clang-cpp)
23 set(LLVM_COMPONENTS engine ipo bitreader bitwriter instrumentation linker option frontendopenmp)
24
25 if (X86_ENABLED)
26--
272.17.1
28
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch
deleted file mode 100644
index e7bb599e..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 139b94a7fb72114c31a2a6ab3f7e6024b4a738ec Mon Sep 17 00:00:00 2001
2From: Yogesh Tyagi <yogesh.tyagi@intel.com>
3Date: Tue, 26 Jul 2022 15:25:10 +0800
4Subject: [PATCH] Fix QA Issues
5
6Stop ispc from inserting host file path in generated headers which leads to reproducibility problems.
7
8Upstream-Status: Inappropriate [OE build specific]
9
10Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
11
12---
13 src/module.cpp | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/src/module.cpp b/src/module.cpp
17index 58a2ae83..82673052 100644
18--- a/src/module.cpp
19+++ b/src/module.cpp
20@@ -2105,7 +2105,7 @@ bool Module::writeHeader(const char *fn) {
21 perror("fopen");
22 return false;
23 }
24- fprintf(f, "//\n// %s\n// (Header automatically generated by the ispc compiler.)\n", fn);
25+ fprintf(f, "//\n// \n// (Header automatically generated by the ispc compiler.)\n");
26 fprintf(f, "// DO NOT EDIT THIS FILE.\n//\n\n");
27
28 // Create a nice guard string from the filename, turning any
29@@ -2219,7 +2219,7 @@ bool Module::writeDispatchHeader(DispatchHeaderInfo *DHI) {
30 FILE *f = DHI->file;
31
32 if (DHI->EmitFrontMatter) {
33- fprintf(f, "//\n// %s\n// (Header automatically generated by the ispc compiler.)\n", DHI->fn);
34+ fprintf(f, "//\n// \n// (Header automatically generated by the ispc compiler.)\n");
35 fprintf(f, "// DO NOT EDIT THIS FILE.\n//\n\n");
36 }
37 // Create a nice guard string from the filename, turning any
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
deleted file mode 100644
index a13ade9f..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
+++ /dev/null
@@ -1,64 +0,0 @@
1From 493e886d6dae2ed7bdc12ed03f717ee0e98dfe09 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 24 Feb 2022 20:01:11 +0530
4Subject: [PATCH] cmake: don't build for 32-bit targets
5
6Error log:
7| tmp/work/corei7-64-poky-linux/ispc/1.16.0-r0/recipe-sysroot/usr/include/bits/long-double.h:23:10: fatal error: 'bits/long-double-32.h' file not found
8| #include <bits/long-double-32.h>
9| ^~~~~~~~~~~~~~~~~~~~~~~
10| 1 error generated.
11
12Remove SYSTEM include search path and set -isysroot dir path
13for root dir for cross compilation.
14
15Upstream-Status: Inappropriate
16
17Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
18---
19 cmake/GenerateBuiltins.cmake | 8 ++++----
20 1 file changed, 4 insertions(+), 4 deletions(-)
21
22diff --git a/cmake/GenerateBuiltins.cmake b/cmake/GenerateBuiltins.cmake
23index fa228247..7adc7e52 100644
24--- a/cmake/GenerateBuiltins.cmake
25+++ b/cmake/GenerateBuiltins.cmake
26@@ -272,7 +272,7 @@ function(builtin_to_cpp bit os_name arch supported_archs supported_oses resultFi
27 # In this case headers will be installed in /usr/arm-linux-gnueabihf/include and will not be picked up
28 # by clang by default. So the following line adds such path explicitly. If this path doesn't exist and
29 # the headers can be found in other locations, this should not be a problem.
30- set(includePath -isystem/usr/${debian_triple}/include)
31+ set(includePath -isysroot${SYSROOT_DIR})
32 endif()
33 endif()
34
35@@ -354,7 +354,7 @@ function (generate_target_builtins resultList)
36 set(regular_targets ${ARGN})
37 list(FILTER regular_targets EXCLUDE REGEX wasm)
38 foreach (ispc_target ${regular_targets})
39- foreach (bit 32 64)
40+ foreach (bit 64)
41 foreach (os_name ${TARGET_OS_LIST_FOR_LL})
42 target_ll_to_cpp(target-${ispc_target} ${bit} ${os_name} output${os_name}${bit})
43 list(APPEND tmpList ${output${os_name}${bit}})
44@@ -415,7 +415,7 @@ function (generate_common_builtins resultList)
45 endif()
46
47 message (STATUS "ISPC will be built with support of ${supported_oses} for ${supported_archs}")
48- foreach (bit 32 64)
49+ foreach (bit 64)
50 foreach (os_name "windows" "linux" "freebsd" "macos" "android" "ios" "ps4" "web")
51 foreach (arch "x86" "arm" "wasm32")
52 builtin_to_cpp(${bit} ${os_name} ${arch} "${supported_archs}" "${supported_oses}" res${bit}${os_name}${arch})
53@@ -428,7 +428,7 @@ function (generate_common_builtins resultList)
54 endforeach()
55 endforeach()
56 if (XE_ENABLED)
57- foreach (bit 32 64)
58+ foreach (bit 64)
59 builtin_xe_to_cpp(${bit} res_xe_${bit})
60 list(APPEND tmpList ${res_xe_${bit}} )
61 if(MSVC)
62--
632.17.1
64
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/6a1b2ffae0cc12467838bc671e3b089924de90a6.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/6a1b2ffae0cc12467838bc671e3b089924de90a6.patch
deleted file mode 100644
index 6aac0c79..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/6a1b2ffae0cc12467838bc671e3b089924de90a6.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 6a1b2ffae0cc12467838bc671e3b089924de90a6 Mon Sep 17 00:00:00 2001
2From: Dmitry Babokin <dmitry.y.babokin@intel.com>
3Date: Thu, 5 May 2022 16:34:34 -0700
4Subject: [PATCH] Bump ISPC version v1.19.0dev
5
6Upstream-Status: Backport
7
8Include only the LLVM specific bits and not the ispc version bump.
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12diff --git a/src/ispc_version.h b/src/ispc_version.h
13index 0e28dfcfa..2b9d9b0cc 100644
14--- a/src/ispc_version.h
15+++ b/src/ispc_version.h
16@@ -51,7 +51,7 @@
17 #define ISPC_LLVM_15_0 150000
18
19 #define OLDEST_SUPPORTED_LLVM ISPC_LLVM_10_0
20-#define LATEST_SUPPORTED_LLVM ISPC_LLVM_14_0
21+#define LATEST_SUPPORTED_LLVM ISPC_LLVM_15_0
22
23 #ifdef __ispc__xstr
24 #undef __ispc__xstr
25@@ -63,7 +63,7 @@
26 __ispc__xstr(LLVM_VERSION_MAJOR) "." __ispc__xstr(LLVM_VERSION_MINOR) "." __ispc__xstr(LLVM_VERSION_PATCH)
27
28 #if ISPC_LLVM_VERSION < OLDEST_SUPPORTED_LLVM || ISPC_LLVM_VERSION > LATEST_SUPPORTED_LLVM
29-#error "Only LLVM 11.0 - 14.0 are supported"
30+#error "Only LLVM 11.0 - 14.0 and 15.0 development branch are supported"
31 #endif
32
33 #define ISPC_VERSION_STRING \
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/ec35a6f8e60ba77e59a6f2bfec27011e0ab34dda.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/ec35a6f8e60ba77e59a6f2bfec27011e0ab34dda.patch
deleted file mode 100644
index a5ab8c19..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/ec35a6f8e60ba77e59a6f2bfec27011e0ab34dda.patch
+++ /dev/null
@@ -1,63 +0,0 @@
1From ec35a6f8e60ba77e59a6f2bfec27011e0ab34dda Mon Sep 17 00:00:00 2001
2From: Arina Neshlyaeva <arina.neshlyaeva@intel.com>
3Date: Tue, 23 Aug 2022 15:21:50 -0700
4Subject: [PATCH] Adjust opt passes for LLVM 15
5
6Upstream-Status: Backport
7Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
8---
9 src/opt.cpp | 17 +++++++++++++++++
10 1 file changed, 17 insertions(+)
11
12diff --git a/src/opt.cpp b/src/opt.cpp
13index 910821e26..86219f384 100644
14--- a/src/opt.cpp
15+++ b/src/opt.cpp
16@@ -84,6 +84,9 @@
17 #include <llvm/Transforms/Scalar.h>
18 #include <llvm/Transforms/Scalar/GVN.h>
19 #include <llvm/Transforms/Scalar/InstSimplifyPass.h>
20+#if ISPC_LLVM_VERSION >= ISPC_LLVM_15_0
21+#include <llvm/Transforms/Scalar/SimpleLoopUnswitch.h>
22+#endif
23 #include <llvm/Transforms/Utils.h>
24 #include <llvm/Transforms/Utils/BasicBlockUtils.h>
25
26@@ -647,7 +650,11 @@ void ispc::Optimize(llvm::Module *module, int optLevel) {
27 optPM.add(llvm::createCFGSimplificationPass());
28 #endif
29
30+#if ISPC_LLVM_VERSION < ISPC_LLVM_15_0
31+ // Starting LLVM 15.0 this pass is supported with new pass manager only (217e857)
32+ // TODO: switch ISPC to new pass manager: https://github.com/ispc/ispc/issues/2359
33 optPM.add(llvm::createArgumentPromotionPass());
34+#endif
35
36 optPM.add(llvm::createAggressiveDCEPass());
37 optPM.add(llvm::createInstructionCombiningPass(), 241);
38@@ -722,7 +729,11 @@ void ispc::Optimize(llvm::Module *module, int optLevel) {
39 optPM.add(CreateInstructionSimplifyPass());
40
41 optPM.add(llvm::createFunctionInliningPass());
42+#if ISPC_LLVM_VERSION < ISPC_LLVM_15_0
43+ // Starting LLVM 15.0 this pass is supported with new pass manager only (217e857)
44+ // TODO: switch ISPC to new pass manager: https://github.com/ispc/ispc/issues/2359
45 optPM.add(llvm::createArgumentPromotionPass());
46+#endif
47
48 optPM.add(llvm::createSROAPass());
49
50@@ -736,7 +747,13 @@ void ispc::Optimize(llvm::Module *module, int optLevel) {
51 optPM.add(llvm::createReassociatePass());
52 optPM.add(llvm::createLoopRotatePass());
53 optPM.add(llvm::createLICMPass());
54+ // Loop unswitch pass was removed in LLVM 15.0 (fb4113).
55+ // Recommended replacement: createSimpleLoopUnswitchLegacyPass
56+#if ISPC_LLVM_VERSION < ISPC_LLVM_15_0
57 optPM.add(llvm::createLoopUnswitchPass(false));
58+#else
59+ optPM.add(llvm::createSimpleLoopUnswitchLegacyPass(false));
60+#endif
61 optPM.add(llvm::createInstructionCombiningPass());
62 optPM.add(CreateInstructionSimplifyPass());
63 optPM.add(llvm::createIndVarSimplifyPass());
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb
deleted file mode 100644
index 6a2e6059..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb
+++ /dev/null
@@ -1,49 +0,0 @@
1SUMMARY = "Intel(R) Implicit SPMD Program Compiler"
2DESCRIPTION = "ispc is a compiler for a variant of the C programming language, \
3with extensions for single program, multiple data programming."
4HOMEPAGE = "https://github.com/ispc/ispc"
5
6LICENSE = "BSD-3-Clause & Apache-2.0-with-LLVM-exception"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=da5ecffdd210b3cf776b32b41c182e87 \
8 file://third-party-programs.txt;md5=3cd6f8a7c3bd9d2bb898fcb27c75221a"
9
10inherit cmake python3native
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \
15 file://0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch \
16 file://0002-cmake-don-t-build-for-32-bit-targets.patch \
17 file://0001-Fix-QA-Issues.patch \
18 file://6a1b2ffae0cc12467838bc671e3b089924de90a6.patch \
19 file://ec35a6f8e60ba77e59a6f2bfec27011e0ab34dda.patch \
20 "
21SRCREV = "f7ec3aa173c816377c215d83196b5c7c3a88db1c"
22
23COMPATIBLE_HOST = '(x86_64).*-linux'
24
25DEPENDS += " clang-native bison-native flex-native"
26RDEPENDS:${PN} += " clang-libllvm clang clang-libclang-cpp"
27
28YFLAGS='-d -t -v -y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}'
29
30do_configure:prepend() {
31 sed -i -e 's#\${BISON_EXECUTABLE}.*#\${BISON_EXECUTABLE} ${YFLAGS} #g' ${S}/CMakeLists.txt
32 sed -i -e 's#\${FLEX_EXECUTABLE}.*#\${FLEX_EXECUTABLE} \-L #g' ${S}/CMakeLists.txt
33}
34
35EXTRA_OECMAKE += " \
36 -DISPC_INCLUDE_TESTS=OFF \
37 -DISPC_INCLUDE_EXAMPLES=OFF \
38 -DISPC_NO_DUMPS=ON \
39 -DARM_ENABLED=OFF \
40 -DISPC_CROSS=ON \
41 -DISPC_ANDROID_TARGET=OFF \
42 -DISPC_FREEBSD_TARGET=OFF \
43 -DISPC_WINDOWS_TARGET=OFF \
44 -DISPC_IOS_TARGET=OFF \
45 -DISPC_PS4_TARGET=OFF \
46 -DSYSROOT_DIR=${STAGING_DIR_NATIVE} \
47 "
48
49BBCLASSEXTEND = "native nativesdk"