summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb
new file mode 100644
index 00000000..db4f31b4
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb
@@ -0,0 +1,60 @@
1SUMMARY = "Intel(R) Implicit SPMD Program Compiler"
2DESCRIPTION = "ispc is a compiler for a variant of the C programming language, \
3with extensions for single program, multiple data programming."
4HOMEPAGE = "https://github.com/ispc/ispc"
5
6LICENSE = "BSD-3-Clause & Apache-2.0-with-LLVM-exception"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=da5ecffdd210b3cf776b32b41c182e87 \
8 file://third-party-programs.txt;md5=3cd6f8a7c3bd9d2bb898fcb27c75221a"
9
10inherit cmake python3native ptest
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \
15 file://0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch \
16 file://0002-cmake-don-t-build-for-32-bit-targets.patch \
17 file://0001-Fix-QA-Issues.patch \
18 file://0001-Add-print-function-to-print-test-run-status-in-ptest.patch \
19 file://run-ptest \
20 "
21
22SRCREV = "ee43967286215a0511c2bc090e604848b4a32bed"
23
24COMPATIBLE_HOST = '(x86_64).*-linux'
25
26DEPENDS += " clang-native bison-native flex-native"
27RDEPENDS:${PN} += " clang-libllvm clang clang-libclang-cpp"
28RDEPENDS:${PN}-ptest += " python3-multiprocessing"
29
30YFLAGS='-d -t -v -y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}'
31
32do_configure:prepend() {
33 sed -i -e 's#\${BISON_EXECUTABLE}.*#\${BISON_EXECUTABLE} ${YFLAGS} #g' ${S}/CMakeLists.txt
34 sed -i -e 's#\${FLEX_EXECUTABLE}.*#\${FLEX_EXECUTABLE} \-L #g' ${S}/CMakeLists.txt
35}
36
37do_install_ptest() {
38 cp -rf ${S}/run_tests.py ${D}${PTEST_PATH}
39 cp -rf ${S}/common.py ${D}${PTEST_PATH}
40 cp -rf ${S}/tests ${D}${PTEST_PATH}
41 cp -rf ${S}/test_static.isph ${D}${PTEST_PATH}
42 cp -rf ${S}/fail_db.txt ${D}${PTEST_PATH}
43 cp -rf ${S}/test_static.cpp ${D}${PTEST_PATH}
44}
45
46EXTRA_OECMAKE += " \
47 -DISPC_INCLUDE_TESTS=OFF \
48 -DISPC_INCLUDE_EXAMPLES=OFF \
49 -DISPC_NO_DUMPS=ON \
50 -DARM_ENABLED=OFF \
51 -DISPC_CROSS=ON \
52 -DISPC_ANDROID_TARGET=OFF \
53 -DISPC_FREEBSD_TARGET=OFF \
54 -DISPC_WINDOWS_TARGET=OFF \
55 -DISPC_IOS_TARGET=OFF \
56 -DISPC_PS4_TARGET=OFF \
57 -DSYSROOT_DIR=${STAGING_DIR_NATIVE} \
58 "
59
60BBCLASSEXTEND = "native nativesdk"