summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.2.1.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.2.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.2.1.bb b/dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.2.1.bb
new file mode 100644
index 00000000..2684ac93
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.2.1.bb
@@ -0,0 +1,55 @@
1HOMEPAGE = "https://www.oneapi.com"
2SUMMARY = "Deep Neural Network Library"
3DESCRIPTION = "This software is a user mode library that accelerates\
4deep-learning applications and frameworks on Intel architecture."
5LICENSE = "Apache-2.0 & BSD-3-Clause & BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=8e17c0f9656ebaf0c380d9b22707c846 \
7 file://tests/gtests/gtest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
8 file://src/cpu/x64/xbyak/COPYRIGHT;md5=3b9bf048d063d54cdb28964db558bcc7 \
9 file://src/common/ittnotify/LICENSE.BSD;md5=e671ff178b24a95a382ba670503c66fb \
10 file://doc/assets/mathjax/MathJax.js;endline=17;md5=25a014ad78c3d72a0e15d15f1d007c20 \
11 "
12SECTION = "lib"
13
14inherit pkgconfig cmake ptest
15
16S = "${WORKDIR}/git"
17SRCREV = "f58682cd8bd0615f41d879f8afc8f1511ab42d24"
18SRC_URI = "git://github.com/oneapi-src/oneDNN.git;branch=rls-v2.2 \
19 file://run-ptest \
20 "
21
22UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"
23
24CVE_PRODUCT = "intel:math_kernel_library"
25
26COMPATIBLE_HOST = '(x86_64).*-linux'
27COMPATIBLE_HOST_libc-musl = 'null'
28
29EXTRA_OECMAKE += " \
30 -DDNNL_LIBRARY_TYPE=SHARED \
31 -DDNNL_BUILD_EXAMPLES=ON \
32 -DDNNL_BUILD_TESTS=ON \
33 -DDNNL_CPU_RUNTIME=OMP \
34 -DDNNL_ARCH_OPT_FLAGS="" \
35 -DCMAKE_SKIP_RPATH=ON \
36 "
37
38PACKAGECONFIG ??= ""
39PACKAGECONFIG[gpu] = "-DDNNL_GPU_RUNTIME=OCL, , opencl-headers ocl-icd, intel-compute-runtime"
40
41do_install_append () {
42 install -d ${D}${bindir}/mkl-dnn/tests/benchdnn/inputs
43 install -m 0755 ${B}/tests/benchdnn/benchdnn ${D}${bindir}/mkl-dnn/tests/benchdnn
44 cp -r ${B}/tests/benchdnn/inputs/* ${D}${bindir}/mkl-dnn/tests/benchdnn/inputs
45}
46
47do_install_ptest () {
48 install -d ${D}${PTEST_PATH}/tests
49 install -m 0755 ${B}/tests/api-c ${D}${PTEST_PATH}/tests
50 install -m 0755 ${B}/tests/test_c_symbols-c ${D}${PTEST_PATH}/tests
51}
52
53PACKAGES =+ "${PN}-test"
54
55FILES_${PN}-test = "${bindir}/mkl-dnn/*"